Jump to content

[GFX] Forum Activity


Alex.amazingboy

Recommended Posts

  • Replies 84
  • Created
  • Last Reply

Hi,

I just noticed on the version on the forum sidebar I am getting a green poll vote icon with number of votes showing up ok

But on my ipcontent page the green icon and poll vote number is not showing

Yeah thats not good of IP.Content .. It doesn't allow me to grab Poll Votes without using another Hook for just Poll Votes in IP.Content.. and another hook for it was not a good idea IMO :)

Link to comment
Share on other sites

Purchased.

Questions:

  • Will this be updated when 4.0 comes out?
  • Does it follow permission masks? (Can I select forums and stuff to display without having to worry about a security breach)
  • For some reason my thing doesn't scroll at all. I have default scrolling settings and I've even set it to 10 threads to pull up. Nothing.

Bugs:

Language Bit Error: Last Post Info is bugged. Instead of Text: Username it's Text :Username

Display Bug: The boxes seem to be "Cut Off" at the right most edge. I'm not sure if this is intentional or if I need to edit it to better fit my skin, or what. I noticed on the left side you can see where the box begins but on the right it just ends.

Display Bug: Doesn't scroll for me. I think it might be conflicting with something because the demo works.

Feature Requests and Idea's I had that you might want to consider:

  • Pulls new information via Ajax. - I think that's what Ajax is for, rather than reloading the page.
  • Updating Effect (Which would be optional, kinda a little sneaky I suppose) - It uses the speed information, and basically a randomiser (I think it's a small PHP script or something) so instead of it moving in uniformed times there's a -5ms to +5ms randomness or something.
  • Different Scroll Direction (Bottom to Top for example) - Again probably make it an option. Could it be possible to use "Transitional Effects" like make it come from left to right and appear to expand from a smaller size for example.

Looking forward to your response, sir.

Link to comment
Share on other sites

Any chance you can add to the settings the ability to name the block, currently it reads "Forum Activity" I prefer to not use the word forum, I always use Community, and would like to be able to change it.

Thanks!

That can be edited in the template "forum_activity" in "Board Index" of your skin(s).

<h3>Forum Activity</h3>

to

<h3>Community Activity</h3>

I feel exactly the same way.

Link to comment
Share on other sites

I didn't make any changes at all. Those images are being picked up by default. My site is http://sphlforums.com


I am gonna join there to see whats the issue :smile:

Will this be updated when 4.0 comes out?


Yes i ll update it for 4.0

Does it follow permission masks? (Can I select forums and stuff to display without having to worry about a security breach)


Yes it does :smile: Don't worry

For some reason my thing doesn't scroll at all. I have default scrolling settings and I've even set it to 10 threads to pull up. Nothing.


If scroll isn't working then its causing JavaScript Conflict with your other hooks etc. please check your page source code if there is two jQuery scripts included of different versions.it may conflict slider.

Language Bit Error: Last Post Info is bugged. Instead of Text: Username it's Text :Username
Display Bug: The boxes seem to be "Cut Off" at the right most edge. I'm not sure if this is intentional or if I need to edit it to better fit my skin, or what. I noticed on the left side you can see where the box begins but on the right it just ends.
Display Bug: Doesn't scroll for me. I think it might be conflicting with something because the demo works.


I ll update that file with Language bug, Gonna fix CSS and Gradient color will be removed. For Scrolling thing i explained above. :smile:

Feature Requests and Idea's I had that you might want to consider:

  • Pulls new information via Ajax. - I think that's what Ajax is for, rather than reloading the page.
  • Updating Effect (Which would be optional, kinda a little sneaky I suppose) - It uses the speed information, and basically a randomiser (I think it's a small PHP script or something) so instead of it moving in uniformed times there's a -5ms to +5ms randomness or something.
  • Different Scroll Direction (Bottom to Top for example) - Again probably make it an option. Could it be possible to use "Transitional Effects" like make it come from left to right and appear to expand from a smaller size for example.

Mate i am afraid about it because i am not so good in javascript and AJAX, i am still learning stuff but yeah i was thinking about that AJAX Request before creating this hook.

I thought it would be nice but IMO it is not worthy also, because if slide gonna move only when data pulled by AJAX, then there is no use for continuous sliding effect for eg. (1 topic pulled by ajax will make 1 one slide is ok, but if ajax found there is 10 new topics or posts between 5 seconds or whatever timer selected in settings, then slider will Skip all 9 slides and u will only see last 10th one topic/post) which will look abrupt (just trying to make you understand). And if you installed this hook with AJAX on a busy board/forum. then it will generate heaps load and may slow down your website. or if installed on a normal board

Am sorry if i am not able to make it understand to you because my English sucks too much :smile: coz am not a native English speaker

Any chance you can add to the settings the ability to name the block, currently it reads "Forum Activity" I prefer to not use the word forum, I always use Community, and would like to be able to change it.

Will update that file :smile: with that setting

Link to comment
Share on other sites

I did the update and there are two things. First, the hook file doesn't show the correct version number in the ACP...it still shows 1.0. Second, the small images that show by my members names aren't lining up. In this example, you will see the arrowed image should be beside the highlighted name. Is there a fix? I know many forums use small images by their usernames.

post-130113-0-10482700-1391101819_thumb.

Link to comment
Share on other sites

If scroll isn't working then its causing JavaScript Conflict with your other hooks etc. please check your page source code if there is two jQuery scripts included of different versions.it may conflict slider.

Yes there is, 1.7.x and 1.9.x also yours seem to have 1.9.x and 1.10.x

It's odd; it works for everyone but me. Which would suggest the problem is my computer. But no matter which browser I use it doesn't work. I'm not entirely sure what's causing it or if I should just go around and replace all the 1.7.x with the 1.9.x jQuery file. Also I figured you'd have more of an ensight into the AJAX thing. What you said certainly makes sense, I can see why that would be a bad thing.

Thanks for your timely response.

Found an issue for you with your latest update (1.1), I had to uninstall the hook and reinstall from fresh because of my modifications.

activity_loader:

background-image: -webkit-gradient(linear, left top, left bottom, color-stop(0, {$this->settings['slide_gradient_top']}), color-stop(1, #ebebeb));

I'm pretty sure that color-stop(1, #code)); is supposed to be {$this->settings['slide_gradient_bottom']} -- not #code. :)

Actual Hook:

The version inside the hook information is incorrect. (1.0, still)

Actual Modification:

Since updating the modification doesn't even show up on the forums. No scratch that. Like a plank I turned the hook off in the hook settings. I'm such a plank.

Link to comment
Share on other sites

I did the update and there are two things. First, the hook file doesn't show the correct version number in the ACP...it still shows 1.0. Second, the small images that show by my members names aren't lining up. In this example, you will see the arrowed image should be beside the highlighted name. Is there a fix? I know many forums use small images by their usernames.

attachicon.gifCapture.JPG

I'm pretty sure that color-stop(1, #code)); is supposed to be {$this->settings['slide_gradient_bottom']} -- not #code.

tqfasw9.png

Sorry about that, maybe i was in sleep mode while updating this hook lol. Now please install 1.1 again and thanks for pointing these bugs :smile:

Link to comment
Share on other sites

Yes there is, 1.7.x and 1.9.x also yours seem to have 1.9.x and 1.10.x

Umm this is not gonna work if two jQuery colliding each other. try to remove this line from activity_loader template.

<script src="http://code.jquery.com/jquery-1.9.1.min.js"></script>


i am using jQuery 1.9 and jQuery UI 1.10. Well if you are using any other version of jQuery UI also then you need to remove this code too.

<script src="http://code.jquery.com/ui/1.10.3/jquery-ui.min.js"></script>
Link to comment
Share on other sites

Hello;

A new customer of your module :smile:

Great module I have a question do you added an option for a block for the latest posts, or code that would venture to make the last posts and topics ?

See you on the forum

Edit; module does well both as I wanted :thumbsup:

Link to comment
Share on other sites

I would like to put a limit in Show Info Forum?
Want to show forum link of the topic?

For that when it exceeds and jumps a line here a screenshot

attachicon.gifCapture.PNG

and it's not very pretty.

See you on the forum

I recently posted a solution for this bug when i saw it on my Demo Board

Please check this post out. You can increase Margin from 50px to more high. or you can Truncate forum names :) by forum_activity template to make it fit with your sidebar width

This is happening because our sidebar width is not much to show text in a single line for eg:

in A Test Forum A Test Forum by bigbuds.

i hope you can understand what i am trying to say :smile:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...