Jump to content

Linux CentOS 6.5 PHP Issues?

Recommended Posts

Hey guys...

So I own my own Linux CentOS 6.5 dedicated server, it's a 12 core server with 8GB RAM.. I have cPanel/WHM installed on it etc.. - For the past 5 hours (approx) my server has been randomly giving me Internal Server Errors, yet when I check the Apache logs, nothing reports.. I was trying to put IP.Board 3.1.x on simply because I want to take some template edits from it to import/use on IP.Board 3.4.6. However, when I tried to install it (after uploading the files) it just came up with ISE.. (Internal Server Error).. So I logged into SSH and did the following (saves time uploading via FTP)

root@darknight [/home/<snip>/public_html/phpbb]# wget https://www.phpbb.com/files/release/phpBB-3.0.12.zip
root@darknight [/home/<snip>/public_html/phpbb]# unzip phpBB-3.0.12.zip

Then tried to see if I get an Internal Server Error with phpBB...and what did my wondering eyes appeal, it gives an error. At first I thought it might be mod_security breaking the PHP scripts...but then I thought...it can't be, because the PHP scripts was working 5 hours ago... so at the moment I'm currently rebuilding Apache and PHP to see if that fixes anything..

Any ideas what could be causing these issues? Not to mention I've had FTP permission denied errors as well... :sad:


So the rebuild just finished with the following error:

    -- Begin test 'Basic HTTP Request for static content' --
localhost did not have any working mirrors.  Please check your internet connection or dns server. at /usr/local/cpanel/Cpanel/HttpRequest.pm line 610.

Thanks guys!

Link to comment
Share on other sites

Well I've ran through checks with PHP but it seems that something else may be wrong. All it's giving for every single PHP script is a 500 Internal Server Error, which obviously indicates something wrong with the webserver. (Namely Apache) but am unable to find any error logs that gives any indication of a problem.. :/

Link to comment
Share on other sites

This can be marked as resolved. I've fixed the issue by running this following command in SSH:

# find /home/*/public_html -type f -name '*.php' | xargs chmod 0644 --
# find /home/*/public_html -type d | xargs chmod 0755 --

which is an indication you are running suphp and had your perms as 777.

Link to comment
Share on other sites

Yes Dmac, my hosts file was also a bit messed up, but that wasn't the issue. I had multiple hostnames for my server which I had originally set it up with, but I purchased a domain for my servers hostname. Turns out the user permissions was also a bit messed up for cPanel accounts.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...