Jump to content

Community

Aiwa

Steam Profile Integration (3.4.x)

Recommended Posts

IN the signature, no. If you've already got the data in the link you provided, you can just use an IMG tag to put that in your signature.

Steam information is displayed under the members avatar next to each of their posts. A popup also shows additional information. See the >pictures, #4 specifically.

I may be able to provide more options in placement on topic view, though.

Share this post


Link to post
Share on other sites

Updated from 1.0.4 to 1.1.0 by uploading files and installing hook. It seems all cached steam profile data for users has been removed. I went and tried to manually run the scheduler task and was redirected to just a blank page. Nothing in SQL error logs, but I found this error:

2014/02/12 15:46:01 [error] 22038#0: *2993093 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /srv/joinsg/www/htdocs/ips_kernel/classDbMysqliClient.php on line 471" while reading response header from upstream, client: , server: www.joinsg.net, request: "GET /admin/index.php?adsess=7bd308c9ea92bb757ca50bae84e7fb85&app=core&module=system&section=taskmanager&do=task_run_now&task_id=55&tab=members HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "www.joinsg.net", referrer: "http://www.joinsg.net/admin/index.php?adsess=7bd308c9ea92bb757ca50bae84e7fb85&app=core&module=system&section=taskmanager&do=task_unlock&task_id=55&tab=members"

Any ideas? It worked fine on the previous version. I even tried lowering the number of users to update at once to 15 and still get the same thing.

Share this post


Link to post
Share on other sites

Try turning off the pulling of owned games and try again.

You're running out of php memory. I've got my DEV server set to 128M as well and don't see this issue.

That is disabled on my end. I lowered the users to fetch even more as well. The thing that is peculiar is that the error shows this: tried to allocate 32 bytes

Which is clearly less than the maximum O_O.

Share this post


Link to post
Share on other sites

32 over the limit. 128M already allocated.

Can you increase your memory limit and see it the error persists?

Increased to 200M and still getting 32 exceeded. Do you think this is related to why the previously cached steam profiles are no longer showing on the forums? Or does it always clear the template cache on upgrade.

Share this post


Link to post
Share on other sites

Can you PM me an ACP and FTP login?

I'd like to see how much data you have to try and get an idea of where the memory bottle neck is.

The new version shouldn't be using anywhere near as much memory as the old version. Data is handled in smaller pieces and released after it's been stored.

Share this post


Link to post
Share on other sites

Can you PM me an ACP and FTP login?

I'd like to see how much data you have to try and get an idea of where the memory bottle neck is.

The new version shouldn't be using anywhere near as much memory as the old version. Data is handled in smaller pieces and released after it's been stored.

PM'd.

Share this post


Link to post
Share on other sites

When you say task, what do you mean?

When I click on the location to where the image is I get this message. Other users on my site can see them... So I most have done something to disable it. Any advise?

Oops! Google Chrome could not find media.steampowered.co

Share this post


Link to post
Share on other sites

It has been sorted. Could see that I had the same problems on the Steam client today, when I looked at my account or the community, It just got a white page with blue linke.. Is working again after Steam did something on their side.

Thanks, and my apologies.

Lars

Share this post


Link to post
Share on other sites

All changes I made on your board have been included in the new version. So you'll maintain the same functionality you have now plus the new features of 1.1.0.

Version 1.1.0 should resolve the SQL server error you were getting initially.

Be sure to not uninstall version 1.0.3. Upload the files, and Install the hook and it will upgrade the currently installed 1.0.3 hook for your automatically.

Share this post


Link to post
Share on other sites

Strange thing happened. I upgraded the hook from an older version to the latest by uploading new files and reimporting the hook.

All went well. I went to my profile and I renewed my games. All went well. I opened up another member and also updated his games from his profile. All went good. I opened up another member. I clicked to validate his steam name - it was valid. Then I clicked to import his games - message said all went well but the WHOLE STEAM PROFILE BLOCK DISAPPEARED off of the profile. what the?

Share this post


Link to post
Share on other sites

Just noticed an issue. When I click on the members name on the side bar it links to the wrong members profile. Noticing this with all players listed. (Not having the issue with your BF4 hook)

Share this post


Link to post
Share on other sites

I can't duplicate this on either my dev site or my own live site that's using this.

Can you please submit a ticket here and send me your board URL in the ticket so I can take a look?

Share this post


Link to post
Share on other sites

Hello, thanks for this plugin.

I've bought it already and installed; however, the tasks are already set and working. But, inside members profile and outside (sidebar block), is not working properly. Doesn't show anything. Custom profile field is done by the book, API steam key set. Can someone please assist?

Thanks in advance.

Cheers.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...