Jump to content

cPanel / PHP5 / DSO

Recommended Posts

Ended up having to migrate to cPanel and I'm having one odd issue I can't resolve.

As I mentioned this is a cPanel / PHP5 / DSO PHP Handler / Suexec [OFF] configuration.

I can't rewrite / update my furlCache.php or globalCaches.php from the ACP > Tools & Settings > Cache Management

The error I receive is:

Could not write to the cache file,
please check permissions on /cache
and /cache/furlCache.php

Checking the permissions on the directory and files

# stat -c %a /home/www/public/cache

# stat -c %a /home/www/public/cache/furlCache.php

# stat -c %a /home/www/public/cache/globalCaches.php

Same errors for both globalCaches.php and furlCache.php.

I've also tried different ownership on the files and directory with the same results.

I have no errors in the Tools > Permission checker.

There are no errors when I run the recache all tool, or recache the skins. Just these the two caches mentioned.

Anyone have any ideas what I'm doing wrong, This shouldn't be that difficult. I know running DSO handler has to be possible, I hope I don't have to change to cgi.

Thank you in advance.

Link to comment
Share on other sites

You have to make /cache/furlCache.php and /cache/globalCaches.php 666 writeable in order for Rebuild FURL Cache or Rebuild Global Caches Cache to work. You can try making it 777 writeable and check that /cache/ is 777 writeable too.

Link to comment
Share on other sites

Thank you Nevo -

I have tried every variable I can think of between ownership and permisions. CHMOD 666 to those files does not work. CHMOD 777 to those files does not work. CHMOD 777 to the directory and files does not work. rwxrwxrwx is a higher permission than rw_rw_rw_ so it should work, but it does not. I can't figure it out for the life of me.

Link to comment
Share on other sites

Is this a php script that maybe needs permission to run, and error is generic because the script failed. I've checked the permission settings and everything is green. Which file is being executed by php when that task is triggered, maybe I'll look at that and see if it fixes the issue.

Had a mental blob after I posted that. Sorry.

Link to comment
Share on other sites

Do also check whether the owner and group of the specific home directory and all files is the same, as should be the group owner. We had lots of problems with this in the past.

You may have to run chown for all directories and files to fix this.

HTH, warm regards, Wim

Link to comment
Share on other sites

This is a classic case of RTFM, read the flippin manual.

I had not done an upgrade on my initdata.php file since I was running version 3.3.4 as most know the more recent versions have a different initdata.php file. I never changed this file because it had specialized settings in it that I was too lazy to port over, but I usually give them a once over to be sure this time I did not. I made an assumption and it came back to bite me. So now that I'm running 3.4.5 (just upgraded BTW) the task didn't have the path necessary to write the file. Without the path the task was actually trying to write the output to /root/. That path for obvious reasons has permission issues and why it was throwing the can't write path and file warning.


Updated my initdata.php file and took all my customizations and put them into a constants.php file so I'll never have this problem again.

Recached all working caches, global cache, furl cache, then recached all the skins.


It's working as intended. Thanks to a few folks in the support system and countless hours blaming it on the handler.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...