Jump to content

FYI - PHP 5.4.14 issues


Recommended Posts

My hosting has just upgraded to php 5.4.14.

In this version the min/max functions have been deprecated.

To the IPB user this means errors occur. Error messages at the top when managing hooks for a start. It also shows with certain apps (a certain arcade is one, shows when editing cats).

Long story short, My host won't downgrade, so I'm now stuck with these errors ( and those I haven't found yet) til invision find a work-around.

If you get these errors ( the message mentions min or max) it's the php and by my experience there isn't much you can do about it yourself unless you on a dedi or a home server.

Link to comment
Share on other sites

I coulda made the title more precise, which I've corrected now. It seems specific to the 5.4.14 then. i was upgraded straight from 5.3.xx.

Specifically it's an OVH server, so we could be looking at this affecting all the peeps who are hosted on an ovh server, either through ovh or a reseller. These functions have definitely been deprecated.

Link to comment
Share on other sites

Think your issue is ioncube. Your arcade is using ioncube if it is the one by ibProMods, and you will need to get the decoder files for PHP5.4 or you will have problems. The older loaders are a common problem with PHP5.4 and ioncube.

Link to comment
Share on other sites

Interesting point. The more I ask the more I hear it's this, it's that. I've encoded my board's conf_global.php to protect the database and that's fine.

Could you possibly point me in the direction of any documentation that explains that?

Link to comment
Share on other sites

From the ioncube support: "Encoding files using the PHP5.4 language requires a new compiler." Version 8 to be precise. If your files are encoded with earlier ioncube encode versions, you may have problems on PHP5.4. Apparently the PHP5.3 decoders work, contrary to what I said above. It always pays if I do a bit of research first. :huh:

You should also upgrade your Arcade. I do work for ibProMods, but the Arcade is not my project. However I know that their latest mod versions are encoded with encode version 8.

Link to comment
Share on other sites

Thank you for your input Sandi. It was Shady who mentioned 'Something in how PHP handles MIN MAX changed'.

so I have to wait now til a release of the arcade and battle system encoded with version 8. I finally have an answer, after the host blames me, I blame the hosts, the software author blames php, and I blow a fuse. I'll have to wait for the next round of updates as the arcade 4.2.2 is throwing these error too.

Turns out there's no issue with php.

But now I have several ipb files that I encoded before the php changed and a forum full of errors lol. I gotta light the other end of this candle to get it sorted. Back to it.

Thank you everyone for your input. Issue resolved ;)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...