Jump to content

[IPBLounge] Topic Covers


aSimpleIdea
 Share

Recommended Posts

hi,

I am a noob when it comes to these things so let me excuse myself in advance.

first things first:

1. Where do I download this skin?

2. As PPlanet suggested is it possible to make it into a side bar as well as full screen?

3. How beta is your beta :), we run a small but very active site so changes will be noticed and problems will be screamed at :).

thank you for your time.

Link to comment
Share on other sites

2) This may be possible now by tweaking some hook (and in that case I'd be happy just to edit my hook instead of suggesting this as a change for all users), is it possible for the grid view not to take the full page width and respect sidebars if any available. (That would be category width instead of full page width). I use DawPi's Global Sidebars, so I have sidebars in subforums too.

By the way this (see attachment) is vaguely what I mean above except that I don't have the forum's index in mind, but any subforum where I happen to have sidebars too.

post-186017-0-91518800-1377010793_thumb.

Link to comment
Share on other sites

Hi man.

Any idea how to generate automaticaly topic covers for more than 500 topics I already have?

Also, few bugs found:

1. Topic preview doesn't parse attached images properly

2. App works incorrectly with moved topics

THx.

Thank you for your reports. I'm testing a way to automatically do that at a specific time of the day, but i'm not sure i'll include that on the upcoming release. :)

It's looking really nice. A couple of questions:

1) When using the mobile theme, would it be possible to automatically default to the classic list view (as opposite to finding nothing bar the option to change to Full Version)? Maybe in the general settings you could have a menu where you can select what skins/themes the application works with. Of course, all this is assuming it won't work with the mobile theme in a near future.

2) This may be possible now by tweaking some hook (and in that case I'd be happy just to edit my hook instead of suggesting this as a change for all users), is it possible for the grid view not to take the full page width and respect sidebars if any available. (That would be category width instead of full page width). I use DawPi's Global Sidebars, so I have sidebars in subforums too.

1 ) I didn't develop a mobile theme yet, so the classic list should show instead. Can you show me a screenshot? :)

2 ) Hmm, I have to test that one. Thank you for your report.

hi,

I am a noob when it comes to these things so let me excuse myself in advance.

first things first:

1. Where do I download this skin?

2. As PPlanet suggested is it possible to make it into a side bar as well as full screen?

3. How beta is your beta :smile:, we run a small but very active site so changes will be noticed and problems will be screamed at :smile:.

thank you for your time.

1. Get at very first page of this topic, and click the link at the bottom at very first post. You'll be redirected to the download page.

2. Read the previous reply :)

3. It is very stable so far, you can test it too if you want :)

By the way this (see attachment) is vaguely what I mean above except that I don't have the forum's index in mind, but any subforum where I happen to have sidebars too.

attachicon.giftopicsexample.jpg

Yes, that's exactly what I had (and still have) in mind :)

Link to comment
Share on other sites

Thank you for your reports. I'm testing a way to automatically do that at a specific time of the day, but i'm not sure i'll include that on the upcoming release. :smile:

Thanks for your efforts in advance! Actually, in my humble opinion, feature "Edit cover" should be optional first of all, but not must. Otherwise you need all the members of your board to be pretty engaged and advanced... but in fact you know - 90% of them are not... some of them don't even have any idea on how to start new topic in general... and that's a reality we have only to put up with, unfortunately.

Link to comment
Share on other sites

  • 2 weeks later...

Yes, I agree with you. That really sucks, that's why I'm thinking of a way to make it smoother. One thing I thought about: if you are viewing a topic started by you which does not have a cover, a simple google-stlye popup will appear saying: "hey, it seems like you did not post a cover for this topic! Want to make it nicer? Upload a cover! ", with a form letting you upload the cover. It's just a small thing, but it's a good way to start to make users aware of the system. :)

Anyway, guys, I've just uploaded version 1.1. Please report any issue or bug. :)

Thank you! Hope you'll like it!

Link to comment
Share on other sites

  • 2 weeks later...

Man, great!

But it seems you didn't get one of the things I tried to explain :smile: I tried to eplain the situation when I enable your app on existing forum with more than 500+ topics, which have been already posted long time ago to this forum. The point is that all these topics will miss preview. And we just need some batch tool, which will help admin to generate previews for all these topics automatically based on existing content (taking first image found in post body eg.). At the moment we can only go through each topic one-by-one in ACP and we have to select preview for each topic manually. For 500+ topics it will take few days, not less...

Thx.

Link to comment
Share on other sites

This is coming along (or has come along) really nicely. To the point that I feel bad about keep suggesting things, but I guess that any feedback is good since it can be taken on board or left alone at the author's wise discretion.

Apart from several things already suggested in this thread, I reckon the title of the thread could be more prominent somehow. Not sure if bigger, or bolder, or maybe even over a semi-transparent area juxtaposed a bit on top of the bottom of the thumbnail. Personally I would even do without all or most other info currently present like topic starter, number of replies, number of views, members' avatars, etc. and give that room to the title.

Link to comment
Share on other sites

Hello. I recently purchased and installed this modification, but when I try to edit the settings for the desired board, I get this error. This is only when I click "save settings" in the admin CP.

There appears to be an error with the database.

If you are seeing this page, it means there was a problem communicating with our database. Sometimes this error is temporary and will go away when you refresh the page. Sometimes the error will need to be fixed by an administrator before the site will become accessible again.

You can try to refresh the page by clicking here

Return to the index

Perhaps there's something I missed?
I've tested it on an empty test board as well as the desired board for the covers (which has existing covers), it still gives me the same error.

Link to comment
Share on other sites

Okay, I fixed what I THOUGHT was the issue (unicode) and it's still giving me this error. When I try refreshing the page, as reccomended with the other error, it tells me

System Error

[#11TC13] Invalid sort order.

What should I do? I'm completely at a loss. Also, being unable to edit my previous post is the pits.

Link to comment
Share on other sites

I haven't had a problem with this app on my Test site, but the other day I installed it on my live site, and I got a similar error to the one described by Mikirin under the same circumstances. I do have 1000s of sub-forums (and funnily enough I'd be happy to use this app in just one of them), so I wonder if this has anything to do with it or whether the reason lies elsewhere.

Link to comment
Share on other sites

I wonder if it's interfering with mods or hooks? I'm using the latest version.
I have...
ibEconomy
Custom Sidebar Blocks

Quotes System
Manage Inactive Members
Auto Welcome Members
Custom Name Style
Global Forum Message
Members Away
Topic Title Colored
Quote Selected Text
Members Online Today
Average Posts per Day
Link to Profile Card on Members List
Image Resizer

It seems that the mod is also trying to look for something that doesn't exist...

Date: Fri, 04 Oct 2013 05:17:19 +0000
Error: 1054 - Unknown column 'topic_view' in 'field list'
IP Address: 184.--.---.-- - /forum/admin/index.php?adsess=8e0ec753f0e55799189eb9b4914a2c3d&app=tcovers&module=settings&section=settings&do=save_settings&f=90

It's looking for a column 'topic_view' in the database but can't find one?

I'm only trying to use it in a standalone board, no subboards and it's not part of a subboard.

I initially thought it was a unicode issue, but I fixed that and it's still giving me those errors. I'm wondering if I should try to reinstall it?

Link to comment
Share on other sites

Thank you very much for your reports guys. :smile:

Hello. I recently purchased and installed this modification, but when I try to edit the settings for the desired board, I get this error. This is only when I click "save settings" in the admin CP.

Perhaps there's something I missed?
I've tested it on an empty test board as well as the desired board for the covers (which has existing covers), it still gives me the same error.

UPDATE: I just found that it is caused by one of invision power's functions, though I'm still trying to see why

Okay, I fixed what I THOUGHT was the issue (unicode) and it's still giving me this error. When I try refreshing the page, as reccomended with the other error, it tells me

System Error

[#11TC13] Invalid sort order.

What should I do? I'm completely at a loss. Also, being unable to edit my previous post is the pits.

Yes, that should be the different character set. I'll see what's wrong with that.

For the second error, it should happen because the sorting order selected does not exist. May I check your board, so I can see what's wrong myself? :smile:

I haven't had a problem with this app on my Test site, but the other day I installed it on my live site, and I got a similar error to the one described by Mikirin under the same circumstances. I do have 1000s of sub-forums (and funnily enough I'd be happy to use this app in just one of them), so I wonder if this has anything to do with it or whether the reason lies elsewhere.

As before, the problem is generated by the characters set, which I'm currently trying to fix. :smile:

I wonder if it's interfering with mods or hooks? I'm using the latest version.
I have...
ibEconomy
Custom Sidebar Blocks

Quotes System
Manage Inactive Members
Auto Welcome Members
Custom Name Style
Global Forum Message
Members Away
Topic Title Colored
Quote Selected Text
Members Online Today
Average Posts per Day
Link to Profile Card on Members List
Image Resizer

It seems that the mod is also trying to look for something that doesn't exist...

It's looking for a column 'topic_view' in the database but can't find one?

I'm only trying to use it in a standalone board, no subboards and it's not part of a subboard.

I initially thought it was a unicode issue, but I fixed that and it's still giving me those errors. I'm wondering if I should try to reinstall it?

When do you get this error?

I installed it twice and it's the same. Mind you, the installation process goes well; it's only when you try to save the settings for any sub-forum.

I'm currently fixing these issues. :smile:

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 5 weeks later...
  • 4 weeks later...

I have problem, some solution for this in ACP:

Cover not works in front.

I can Save changes and i recaching topic and stilll not working.

Warning: Invalid argument supplied for foreach() in /home/allemoto/domains/allemotocykle.pl/public_html/forum/admin/applications_addon/other/tcovers/skin_cp/cp_skin_tcovers_settings.php on line 52

???

thanks

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...