Jump to content

Community

[DR] IP.Content Live Streams


Recommended Posts

There are way too many threads for me to read on this so if this has been answered previously sorry, but could you repeat it for me please! I don't want just anyone to be able to add their stream to my site can I set restrictions to the "Add Streams" button and if so where can i do that? Thankies!

Link to post
Share on other sites
  • Replies 368
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Yes, still doing installs for free. Are you following the install instructions in the readme? The site instructions are outdated. Need to get that going again Will look into this for you

Hey mate, Throw this onto your content page: <script type="text/javascript"> //<![CDATA[ if ( $('nav_stream') ) { $('nav_stream').addClassName('active'); } //]]> </script> whe

Working on my own little upgrades to the stream platform. How does it look? Changed to an H3 tag, edited the hover effects too. Added a better 'glow' and made it so that the header is on top of the Ch

Posted Images

Alright, still working away on this. -- New blocks and upgrades will hopefully be finished this weekend provided time allows it.

Anyways, here is an image of the block I'm working on.

s0CKble.jpg' alt='' class='ipsImage' wid" alt="s0CKble.jpg">

Better styling of the block compared to the first edition. When you hover over one of the items in the list, a window will pop out that will contain more information.

Contains the User's photo | Channel Name
Channel Status
Submitted by: <Name> | (x) Comments

Also, working on another block for those interested and have ProMenu, so when you hover over the navigation (live streams) a list comes down containing the Stream previews, and who is online. Lastly, will be adding tabs at the bottom of the page for counting. For example (There are (31) Live Streams in the Database (8) are online with (23,684) Viewers or something like that

What do you think?

Link to post
Share on other sites

Wasn't sure how easy it was to use ;) -- But I think I'd rather go that route. Might of put some work into this, probably still include it anyways just cause.

I wasn't sure all the data I should put inside the hovercard. If you have suggestions for that, let me know. That said, I'll try to get this new version out tomorrow. I haven't had time to work with the Justin.TV API. So probalby won't be another big update.

Just some more fixes to improve the overall quality, With some additional things like the block(s)

Link to post
Share on other sites

I think I had a problems during the install part. I cannot access the general setting.

System Error
[#404] incorrect_furl

Should I uninstall and try again?


No. It will always give you that. It doesn't have any settings and is strictly for the task manager
Link to post
Share on other sites

I'm getting the following error message every time I try to run the task to refresh the view:

There appears to be an error with the database.

Granted that I am running PHP 5.2.17 (in the process of upgrade to 5.3), is this to be expected?

Also, the view of streams simply appear to be stuck in "Waiting for update" and I've gone through most of the recommended solutions so far in this thread, but to no avail.

I look forward to running this hook efficiently. It would greatly help our service.

Thanks in advance.

Link to post
Share on other sites

I got an error page when clicking on the link to the install instructions. Are you still doing installs for free? I might need your help to get things working.

Yes, still doing installs for free. Are you following the install instructions in the readme? The site instructions are outdated. Need to get that going again

I recommend that add a future for this hook by show a block on sidebar forum index not only in IP Content, would be WOW!

Will look into this for you

I'm getting the following error message every time I try to run the task to refresh the view:

There appears to be an error with the database.

Granted that I am running PHP 5.2.17 (in the process of upgrade to 5.3), is this to be expected?

Also, the view of streams simply appear to be stuck in "Waiting for update" and I've gone through most of the recommended solutions so far in this thread, but to no avail.

I look forward to running this hook efficiently. It would greatly help our service.

Thanks in advance.

The issue is because you're on 5.2.17 and not 5.3 -- Could also be that a field is not set correctly but regardless, this won't run without upgrading to 5.3... there is 0 reason to upgrade to 5.3 as it's been around since 2009. It's easy to upgrade to 5.3 if you're on cPanel (navigate to php management and follow the instructions there) or email your host.

------------------

@All -- I know the install process is painful, nothing I can do about that since it's IP.Content :sad:

Link to post
Share on other sites

The issue is because you're on 5.2.17 and not 5.3 -- Could also be that a field is not set correctly but regardless, this won't run without upgrading to 5.3... there is 0 reason to upgrade to 5.3 as it's been around since 2009. It's easy to upgrade to 5.3 if you're on cPanel (navigate to php management and follow the instructions there) or email your host.

------------------

@All -- I know the install process is painful, nothing I can do about that since it's IP.Content :sad:

Thank you for your response, Dylan. I will try that out and give you feedback.

Link to post
Share on other sites

Yes, still doing installs for free. Are you following the install instructions in the readme? The site instructions are outdated. Need to get that going again

Will look into this for you

The issue is because you're on 5.2.17 and not 5.3 -- Could also be that a field is not set correctly but regardless, this won't run without upgrading to 5.3... there is 0 reason to upgrade to 5.3 as it's been around since 2009. It's easy to upgrade to 5.3 if you're on cPanel (navigate to php management and follow the instructions there) or email your host.

------------------

@All -- I know the install process is painful, nothing I can do about that since it's IP.Content :sad:

Worked like a charm, Dylan. Now I'm just looking at how to place the block on the homepage as you have in your pictures and above.

Also, if there could be a hook for sidebar as someone has already raised, that would be money! :smile:

Here is one problem I noticed after installing the hook this morning. All the smaller Twitch channels set at 160x260 are now appearing full height but with smaller width. This has caused some issues with some of our forums embeded streams. Any idea what may have caused this? (See attached)

post-367285-0-29468800-1366233814_thumb.

Thanks man!

Link to post
Share on other sites

Worked like a charm, Dylan. Now I'm just looking at how to place the block on the homepage as you have in your pictures and above.

Also, if there could be a hook for sidebar as someone has already raised, that would be money! :smile:

Here is one problem I noticed after installing the hook this morning. All the smaller Twitch channels set at 160x260 are now appearing full height but with smaller width. This has caused some issues with some of our forums embeded streams. Any idea what may have caused this? (See attached)

attachicon.giftwitch.jpg

Thanks man!

Can you link me to a preview so I can see what's going on. I'm not really sure what you're saying. Also, the block on the previous screens aren't released yet. It's going to be in an update coming here soon. Just trying to decide what else I want to add in this version. I will possibly look at creating a hook for adding this to the sidebar.

Link to post
Share on other sites

What version of PHP are you on? When you run the task manually (system scheduler) does it lock/throw an error?

If it runs "successfully" then it's either the stream is using some sort of different capital letters (try all lower case) or it should be working fine and when you checked it, it just wasn't updated yet.

Feel free to PM details to your site and I'll take a look for you right after work tomorrow at around 5:00pm Central time

Link to post
Share on other sites

PHP 5.2

I have ran task and says "successfully"

sure thing...

If you were on 5.2 -- should of thrown an error. I'll take a look for you when I get off work tonight. Also, you'll have to update to PHP 5.3+ for this to work correctly. There isn't anything I can do about that. It's easy to upgrade if you're on cPanel, simply navigate to PHP Management and select the version you want. (5.3+)

------

@All

What do you think of the new block now? Still working on it 2w0boDZ.png' alt='' class='ipsImage' wid" alt="2w0boDZ.png">

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy