Jump to content

Table bbcode


Eudemon
 Share

Recommended Posts

%7Boption%7D



File Name: Table bbcode

File Submitter: Eudemon

File Submitted: 07 Jan 2013

File Category: User and Social Engagement



This will create a table
So after toying around with IPB's regular expression filter
I decided to give up the idea of php-file-less
which fixed some bugs and gives more space for new features

How to install
upload all files from 'upload' folder
log in to admin cp -> look & feel -> post content -> BBCode Management -> import (bottom)

How to upgrade
Run the sportfield ten times upload & import the newer one, it will automatically replace old one (99% sure)

Done, have fun

and BTW, don't ask question on the file page, use the support topic (BECAUSE I CANNOT COMMENT ON MY OWN FILE) ah, sorry for shouting.. すみませんでした(ヽ´ω`)

My lunch today was one small boiled egg!!
Donate

by Eudemon (´・ω・`)



here to download this file

Link to comment
Share on other sites

i would suggest border and background color support (maybe alternating row colors?)

the current way im going to implement, only one css property can be used in one tag

e.g i can put boarder on [table] and background color on [tr] (members can choose the value)

if i allow all, then the way member use tag would be bit messy (when they are allow to customize it)

there is another thing i'm thinking about adding -> advance table mode, which will allow member to use all table properties

but that has potential to make ur template look messy, so i will include both versions, and the admin(you) can choose which one to use

Hi, does this work for IP.Content bbcode? I'm trying to create a table on a IP.Content page and it's not working :sad:

i just tested on my test server, it works fine on ip.content page

are you sure you're using bbcode mode in your page?

Link to comment
Share on other sites

I'm getting major white space above my table as seen here. I have one table row per line (otherwise it's a nightmare to edit) so it seems like it's taking breaks from the end of each [tr]..[/tr] (or each line) and somehow adding them to the top of the table (but it doesn't appear to show in the page source). I'm using version 1.1 and deleted the old bbcodes from the previous version of the other table plugin, uploaded the files via ftp and imported the xml files. Also tried clearing all cache that I could find and rebuilt templates.

Edit: Also tried default IPB skin, same issue.

Edit 2: If I post a table without any URLs it works fine. Seems that URLs are creating white space at the top.

Edited by Stylez84
Link to comment
Share on other sites

Here's the code I was using:

[table]
[tr][th]Mod Name[/th][th]Install To[/th][th]Notes[/th][th]Mod Version[/th][th]MC Version[/th][/tr]
[tr][td]Minecraft Forge   [/td][td]JAR[/td][td]Required by all mods below.[/td][td]6.6.0.499 [/td][td]1.4.7[/td][/tr]
[tr][td]CodeChickenCore   [/td][td]CoreMods[/td][td]Required by ChickenBones' mods[/td][td]0.7.0.2 [/td][td]1.4.6[/td][/tr]
[tr][td]Not Enough Items   [/td][td]CoreMods[/td][td]Requires CodeChickenCore.[/td][td]1.4.5.0 [/td][td]1.4.6[/td][/tr]
[tr][td]Treecapitator   [/td][td]CoreMods[/td][td]Take note: Treecapitator is now a core mod as of 1.4.5![/td][td]FML 1.4.6.r03 [/td][td]1.4.6[/td][/tr]
[tr][td]MAtmos   [/td][td]Custom+Mods[/td][td]Extra files (sounds) need to be copied to Minecraft folder[/td][td]r21 [/td][td]1.4.6[/td][/tr]
[tr][td]NEI Plugins   [/td][td]Mods[/td][td]Requires Not Enough Items. Disabled as it's not updated to latest NEI.[/td][td]1.0.4.1 [/td][td]1.4.6[/td][/tr]
[tr][td]Ender Storage   [/td][td]Mods[/td][td]Much more versatile ender chests. Requires CodeChickenCore.[/td][td]1.3.1.1 [/td][td]1.4.6[/td][/tr]
[tr][td]Inventory Tweaks   [/td][td]Mods[/td][td]Unofficial by Lordmau5.[/td][td]1.49 [/td][td]1.4.6[/td][/tr]
[tr][td]Rei's Minimap   [/td][td]Mods[/td][td][/td][td]3.2_06 [/td][td]1.4.7[/td][/tr]
[tr][td]ExtraBiomesXL   [/td][td]Mods[/td][td]Download linked to mirror. Author's ad.fly link broken.[/td][td]3.8.0 [/td][td]1.4.7[/td][/tr]
[tr][td]Metallurgy 2   [/td][td]Mods[/td][td]Install all metals, ores modules and Mystcraft addon. Optifine makes metal chests flicker and/or crash.[/td][td]2.4.2 [/td][td]1.4.6[/td][/tr]
[tr][td]RedPower2   [/td][td]Mods[/td][td]Using all modules.[/td][td]PR6 [/td][td]1.4.6[/td][/tr]
[tr][td]Wireless Redstone CBE   [/td][td]Mods[/td][td]Requires RedPower2. v1.3.2.3[/td][td]Core, Addons, RP [/td][td]1.4.6[/td][/tr]
[tr][td]Buildcraft   [/td][td]Mods[/td][td][/td][td]3.4.0 [/td][td]1.4.7[/td][/tr]
[tr][td]Forestry   [/td][td]Mods[/td][td]Install with Buildcraft and IndustrialCraft2 for best results.[/td][td]1.7.0.3 [/td][td]1.4.7[/td][/tr]
[tr][td]Compact Mobs   [/td][td]Mods[/td][td]Mob transportation and more! Requires Buildcraft.[/td][td]1.2.3 [/td][td]1.4.6[/td][/tr]
[tr][td]Logistics Pipes (RS485)   [/td][td]Mods[/td][td]Requires BuildCraft.[/td][td]RS485's 0.7.0.76 [/td][td]1.4.7[/td][/tr]
[tr][td]Valve Pipe   [/td][td]Mods[/td][td]Requires BuildCraft.[/td][td]1.4.6 [/td][td]1.4.6[/td][/tr]
[tr][td]Thermal Expansion   [/td][td]Mods[/td][td]Recommend using with BuildCraft.[/td][td]2.1.6 [/td][td]1.4.6[/td][/tr]
[tr][td]OmniTools   [/td][td]Mods[/td][td]Convert between ore dictionary items and adds a universal wrench.[/td][td]3.0.0 [/td][td]1.4.7[/td][/tr]
[tr][td]IndustrialCraft 2   [/td][td]Mods[/td][td]Open beta for 1.4.6[/td][td]1.112.170-lf [/td][td]1.4.6[/td][/tr]
[tr][td]Compact Solars   [/td][td]Mods[/td][td]Requires IndustrialCraft2.[/td][td]3.2.3.23 [/td][td]1.4.7[/td][/tr]
[tr][td]Transformers   [/td][td]Mods[/td][td]Requires IndustrialCraft2 and BuildCraft.[/td][td]1.7b [/td][td]1.4.6[/td][/tr]
[tr][td]ChargePads   [/td][td]Mods[/td][td]Requires IndustrialCraft2.[/td][td]2.3.0.58 [/td][td]1.4.6[/td][/tr]
[tr][td]IC2 Nuclear Control   [/td][td]Mods[/td][td]Requires IndustrialCraft2[/td][td]1.4.5 [/td][td]1.4.6[/td][/tr]
[tr][td]Advanced Power Management   [/td][td]Mods[/td][td]Requires IndustrialCraft2.[/td][td]1.1.55-IC2_1.112 [/td][td]1.4.6[/td][/tr]
[tr][td]Railcraft   [/td][td]Mods[/td][td]Recommend using with BuildCraft and IndustrialCraft2.[/td][td]6.14.0.0 [/td][td]1.4.7[/td][/tr]
[tr][td]ComputerCraft   [/td][td]Mods[/td][td][/td][td]1.481 [/td][td]1.4.6[/td][/tr]
[tr][td]MiscPeripherals   [/td][td]Mods[/td][td]Requires ComputerCraft.[/td][td]2.3[/td][td]1.4.6[/td][/tr]
[tr][td]Weee! Flowers   [/td][td]Mods[/td][td][/td][td]1.01 [/td][td]1.4.6[/td][/tr]
[tr][td]Mystcraft   [/td][td]Mods[/td][td][/td][td]0.9.5.00 [/td][td]1.4.6[/td][/tr]
[tr][td]Steve's Carts   [/td][td]Mods[/td][td][/td][td]2.0.0 a42 [/td][td]1.4.6[/td][/tr]
[tr][td]Portal Gun   [/td][td]Mods[/td][td][/td][td]1.4.7v2 [/td][td]1.4.7[/td][/tr]
[tr][td]Soul Shards   [/td][td]Mods[/td][td][/td][td]1.26 [/td][td]1.4.6[/td][/tr]
[tr][td]Greg's Lighting   [/td][td]Mods[/td][td][/td][td]1.7 [/td][td]1.4.6[/td][/tr]
[tr][td]XACT: Xhamolk_'s Advanced Crafting Table   [/td][td]Mods[/td][td][/td][td]0.2.3   [/td][td]1.4.6[/td][/tr]
[tr][td]Somnia [/td][td]?[/td][td]Waiting for update. Currently being re-coded.[/td][td]24[/td][td]1.2.5[/td][/tr]
[/table]

It seems that if I paste the raw BBCode into the editor in raw code mode (using the light switch at top-left of editor) it works fine. If I paste it in using the WYSIWYG mode in a rich text format (such as copying it from another post in the thread) is when I get the white space. Further testing: Even if I modify a post that has the whitespace, switch the editor into raw mode, and immediately save the post it removes the white space.

Link to comment
Share on other sites

i really have to say it's probably IPB editor's issue

there are numbers of bugs been reported that are caused by the 3.4.x editor improvement

and i know they're working on a fix in 3.4.2, so please wait til that patch released

in the mean while, do it in raw code mode or try this patch http://community.invisionpower.com/resources/guides.html/_/knowledge-base/341-editor-parser-updates-r262

Link to comment
Share on other sites

Thanks,
I tried that patch but it didn't help. Either way, I'm fine with doing
it in raw mode anyway as long as the end result is fine I don't mind
taking an extra step.

Thanks for your help!

Currently
trying it on 3.4.1 with the Editor patch installed. In raw mode it
works in the forums, in IP.Content (where I need to use it for looooong
tables), I get line breaks for each table row before the table. :cry:

1.2 released

improved line break handling with editor

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 1 month later...
  • 1 month later...
  • 1 month later...

I think break lines is not managed in 3.4.5

It was great in 3.3.1 with auto style integration but now not work in 3.4.5

I add examples with custom and standard skins.

Custom Skin

before (3.3)

post-362298-0-84187800-1375452230_thumb.

now (3.4.5)

post-362298-0-03873900-1375452232_thumb.

Default Skin

now (3.4.5)

post-362298-0-36347700-1375452233_thumb.

before (3.3)

post-362298-0-61498100-1375452234_thumb.

I will appreciate if you can make the same integration of styles.

Link to comment
Share on other sites

  • 1 month later...

Please help...

Can someone please show me how the bbcode should be... my tables are NOT working at all...

they look like this:

[table

I]Nome do TópicoAutor do Tópico[td=50%]Ially Mazza[/td][td=50%]Minotauro1975[/td][td=50%]Iara Ramos[/td][td=50%]babyy[/td][td=50%]Iara Vieira[/td][td=50%]thipaol[/td][td=50%]Ilha Pinna Hopf[/td][td=50%]Willie Coyote[/td][td=50%]Ilsy Von Rolfh[/td][td=50%]minotauro1975[/td][td=50%]Índia[/td][td=50%]louro[/td][td=50%]Ines Ventura[/td][td=50%]Nunoy[/td]

when they SHOULD look like this:

1bIyuCS.png

This is what they looked like in the previous IPB... now in 3.4.5 they have gone BEZERK... totally messed up...

Can someone please HELP ME...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...