Jump to content

Community

User Geolocation Restriction


Recommended Posts

Thanks for getting back to us. I'm not getting the licence error message now.

Thanks also for looking at the mod not always working. For example I'm in New Zealand and when I click on the Test API button the result is "Unidentified Location". This is what's happening with some of the members from banned countries getting through. If was to ban "Unidentified Locations" I would end up banning myself and a whole heap of my members.

Cheers

3DKiwi

Link to post
Share on other sites
  • Replies 301
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

​It's under update already. Can't give you right now a date though. @all: Yesterday night I received an email from the hosting company about a general file system error on the machine. I also host th

Alright guys, the server is up again, I just need to fix some script details as the new configuration uses a newer version of PHP and the API produces some warnings. It'll be sorted out in a couple of

Guys, I had resolveip.info and another domain on godaddy, and all of the rest domains I administer on another registrar. So, 5 days before the domain expired I asked for a domain transfer to my other

Posted Images

The API got moved to its new "home" and I hope it stays there for a long time. It's a matter of a couple of hours until the new nameservers are propagated and it'll work for all of you! :)

Tomorrow I'll start working on the couple of bugs reported in the previous posts!

Thanks for your understanding and patience guys.

Link to post
Share on other sites

Greetings...

I figured I would go out on a limb here and give this app a shot as it looks like it could be a great help to regain blocking.

Just purchased and installed. I put in my member ID to get the API key and when I click "Create Account" the only thing that happens is the same page refreshes.

Member ID = 192276

Please be so kind to help to correct this so I may get my API key.

Thank you.

Link to post
Share on other sites

Greetings...

I figured I would go out on a limb here and give this app a shot as it looks like it could be a great help to regain blocking.

Just purchased and installed. I put in my member ID to get the API key and when I click "Create Account" the only thing that happens is the same page refreshes.

Member ID = 192276

Please be so kind to help to correct this so I may get my API key.

Thank you.

Hi. Let me take a moment to the API registration form, as you're the first customer (I think) since the API's server change, and I may have missed something...

I'll get back soon.

Link to post
Share on other sites

I believe I have found a bug in the search portion of the software. When I went to search our member databases in the ACP for members within China & Users that have 0 posts it returns 79 users. If I press the button to move all found members those members to a different group it then prompts me asking if I want to move ~ 7000 users. I believe it is ignoring the country and only using the native post count from the search when I click the move all members found, and I'm assuming if I press prune members it would ask the same thing.

Alright, this is fixed. It was extremely difficult to debug, and even more difficult to correct, as it depended on a heavy jQuery file of the IPS suite, but it's fixed now.

As far as I can tell the mod is only working some of the time. I'm getting registrations from blocked countries. The issue seems to be that the mod thinks most IP's are from unknown places. I did send you a pm explaining this and haven't heard back. Even my own IP is showing up as an unknown place.

Can you help?

I've debugged this, and indeed it's an error that affects only 64-bit servers due to a bug in ip2long() PHP method that appears only in 64-bit machines, and for certain IPs. At least this is easy to fix, so expect v1.1.2 in a couple of days. :)

Ok, great. Works now just as one would expect. I have my key and am now building my current member list then to see how best to use this plug in.

Thank you again.

Yesterday in the other topic I didn't want to tell you anything about UGR because you might think I said it for the money... But now that you've purchased it, I can tell you only one thing; you'll love it. I guarantee that. ;)

Link to post
Share on other sites

"Alright, this is fixed. It was extremely difficult to debug, and even more difficult to correct, as it depended on a heavy jQuery file of the IPS suite, but it's fixed now."

Is their an update then or are you saying the fix will be in it when you release 1.1.2? (Or are you saying it was already fixed in 1.1.1?)

Thanks

Link to post
Share on other sites

Hello...

After running the DISCOVER tool several times, I always seem to have 7,300 Undiscovered Locations. That 7.4% of the membership. The number I also find strange as it is a whole number, 7,300. Not 7,243 or something. But 7,300 exact. I have run it 4 times.

Any thoughts?

Thank you.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy