Jump to content

Embed Tweet


MadMikeyB

Recommended Posts

%7Boption%7D


File Name: Embed Tweet

File Submitter: Mikey

File Submitted: 17 Nov 2012

File Category: Integration

This file is considered END OF LIFE by the author and is no longer supported.

Embed Tweets allows you to embed Tweets in your forum using the Twitter provided shortcode. Users can use either of the following:

[tweet https://twitter.com/MadMikeyB/statuses/269877302475780096]

[tweet 269877302475780096]

Users simply go to Twitter.com. click Embed Tweet:

%7Boption%7D

Copy the shortcode:

%7Boption%7D

and post it on your forum:

%7Boption%7D

%7Boption%7DImportant: Please Note Unfortunately because of the way IP.Board 3.3 does not permit Javascript in custom BBCodes, if you want this BBCode to parse, you'll need to add a few lines of code into your includeMeta template.

<script src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
<style>
    .post_body .post {
        overflow-y: hidden !important;
    }
</style>                


Alternately, if you do not have Nexus installed, you can go to your AdminCP > System > System Settings > Ad Code Integration > Header Code, and put the above code in that box. Ensure that the Ad Code System is enabled and not restricted.

here to download this file

Link to comment
Share on other sites

  • Replies 68
  • Created
  • Last Reply

just to clarify to avoid issues, this is for 3.3.x only correct?

I think it is per answers in another thread but thought I would ask and possibly avoid issues for you if people try it on 3.4.

As 3.4 is not yet released I would not be making hooks for it. That could be construed as encouraging people to use a beta on a live site, which in turn could be seen as irresponsible. :)

Yes, this is for 3.3.

Link to comment
Share on other sites

That depends entirely on your javascript locale. What is that set to?

It is set to en_US so I am not really sure what else to tell you. I like the mod and I am not going to uninstall it because of this but I sure would like it fixed. Could it be something to do with my hosting as I am on shared hosting?

Well let me rephrase that as far as I can tell it is set to en_US.

Link to comment
Share on other sites

If I made the changes mentioned in this guide post to this would it work in 3.4. I did try quickly but ended up with a blank page

http://community.invisionpower.com/resources/guides.html/_/advanced-and-developers/miscellaneous/34-custom-bbcode-php-changes-r181

I've not tested so I can't say. This doesn't work on 3.4 at the moment.

It is set to en_US so I am not really sure what else to tell you. I like the mod and I am not going to uninstall it because of this but I sure would like it fixed. Could it be something to do with my hosting as I am on shared hosting?

Well let me rephrase that as far as I can tell it is set to en_US.

Can you PM me a link to your site and Admin details?

It keeps giving me an error like... it just does:

[tweet https://twitter.com/.811767018741]

It works on some of my posts, on others it doesn't.

Any reason why?

Are you on 3.4?

Link to comment
Share on other sites

  • 4 weeks later...

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...