Jump to content

[IF] IPB Shoutbox


Pete T

Recommended Posts

cloudflare does not cause this issue for me unless you have rocket loader on

Rocket loader is off

Seems to be doing it for certain users only.

like user from Iraq posts in shoutbox, it's 2:30 in Ireland but 4:30 in iraq, his post in shoutbox will keep on top of everyones before his time till we pass it.

Link to comment
Share on other sites

like user from Iraq posts in shoutbox, it's 2:30 in Ireland but 4:30 in iraq, his post in shoutbox will keep on top of everyones before his time till we pass it.

It is now in my Tracker to look at.

Link to comment
Share on other sites

I would be interested to see if it happens with cloudflare off, because it should not matter, and I don't think the CF geoip header would affect it. maybe worth disabling that to test with though.

I think this time issue had cropped up once before in the older longer thread or maybe over on Michaels site some time back.

Link to comment
Share on other sites

If you turn off your CDN does it work normally? Does your CDN service have some hints that may point to the cause?

Will try it and let you know

It is now in my Tracker to look at.

Thanks

I would be interested to see if it happens with cloudflare off, because it should not matter, and I don't think the CF geoip header would affect it. maybe worth disabling that to test with though.

I think this time issue had cropped up once before in the older longer thread or maybe over on Michaels site some time back.

Will put cloudflare on pause and see if it still happens and get back here to let yahs know.

Link to comment
Share on other sites

I messed around a bit last night and could not duplicate on test board, were diffeent time zones in use, but if anything would mess with it I would look towards the CF geoip header ( Add the CF_IPCountry header to all requests to your site. ) setting or possibly (unlikely) the SPDY setting.

Link to comment
Share on other sites

I messed around a bit last night and could not duplicate on test board, were diffeent time zones in use, but if anything would mess with it I would look towards the CF geoip header ( Add the CF_IPCountry header to all requests to your site. ) setting or possibly (unlikely) the SPDY setting.

I dont have spdy enabled, and have just my DNS been resolved by cloudflare and the shoutbox is still 2 hours ahead of me.

If this is happening with cloudflare off it may be another fault.

My host server is in the UK, I'm in Ireland so the time should be correct.

it's now 00:35am but if i post in shoutbox it shows 02:35am

both short n long time settings for the shoutbox have been untouched.

Link to comment
Share on other sites

Some details of the v1.3.9 update

@name formatting
The way the formatting of shouts using the @name have been changed you will need to go back and edit the format to include the @ something like;

@<b>{name}</b>

Or more fancy?

<span style='color: red;'>@</span><span style='color: green;'><b>{name}</b></span>

The parsing is now done on display so if you change the formatting shazzam it will reflect in the SB straight away.


Javascript niggles

A bunch of JS issues were stomped with the help of Marcher Technologies including one where disabling the global hook caused mayhem to the site (seriously not SB's fault but it is fixed anyway). Some other code cleaning was also performed. Still will be a while before I reckon it is all spiffy though.

User Sound Preference

Volume control was supposed to be in this version but it is being a bit of a monster putting it into the Ajax popup. But users are now able to turn sounds off themselves if they wish, in the standard popup window.

Next please?

There are about a page of items in the Tracker but Awards & Links also need some work. Plus I am tinkering with another application so expect more updates from JLogica land.

Link to comment
Share on other sites

this is odd, installing on fresh test board and global hook won't show up at all.

going to try older version then upgrading

same with 1.3.8 on board with no mods.

edit: this MAY have been a computer issue on my end, still investigating.

was only on one computer, although 4 browsers, but is not issue with shoutbox app itself.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...