Jump to content

Links Directory [IP.Board 3.4]

Adriano Faria

Recommended Posts

  • Replies 1.2k
  • Created
  • Last Reply

I have just installed this - seems like theres an issue with posting of comments. The comments are not showing.

I wrote a ticket about the issue in the bug-tracker also. Have checked all permissions and "everything else" - but I guess I have overlooked something - but what?

My site


is it this?

Run the database checker tool from support -> diagnostics and let it resolve any errors it finds and let me know if that resolves it.

As a note...... I'm not going to be able to back-port a fix, but I need to know if I have already resolved it within the current code-base I work with, the code-base is radically different at this point already.

Link to comment
Share on other sites

There's no errors when I run the Database checker.

On my testboard I have 3.4 - and there - everything is OK. I will upgrade my main site one of the coming days.

I send you admin details. Might be I have missed something.

Regards KI

PS: I really have trouble with this board today

Hi, it appears for some reason the database checker in this case was not reporting this error, I ran the query in the linked tracker entry and it is working properly now.... same bug I have already found and fixed in the current working code-base.

I have opted to patch the current download for these 2 critical errors to reduce affected installs while i work on the new version:



Many other bugs are already fixed, but literally required me to rewrite entire libraries within the application to fix, hence I really need to keep moving forward on development of this build.

Link to comment
Share on other sites

I've also got what looks like background text in individual links, as below:


My Firebug on Firefox seems broken with blank tabs and whatnot, so I can't try to figure out what it is. As it's broken, I also can't see where I might be able to increase the font size of the text description when viewing the link itself. Would there be some way I could increase the font size please without having to do so via the editor for each individual link?

Please link me where this occurs, I have been trying to reproduce, and have been unable to.

Link to comment
Share on other sites

I don't know if this is a known issue, or if it's how it should be (odd as it is) or if I should report it in the tracker. I've just (finally!) installed Links and am adding links whilst the Links Directory is supposed to be "offline" and whilst members and guests et al aren't supposed to be able to access it at all according to the member group's tab. But all the new links I'm adding are visible in View New Content as the "Links Directory" tab is visible to anyone and everyone.... However, if someone clicks on the list of new Links (all 2 pages of them in VNC so far), they get the "Ooops" error message.

Would you mind confirming if this fixes the issue for you?

Link to comment
Share on other sites

If it's OK, I'll PM you with login details, being as Links is offline and inaccessible to all but Admins and Mods.

ok, i've iterated the app version due to the template change required to fix link view, and fully fixed the vnc issue.
4.1.0 from here out is my work-flow.


We have recently purchased this and installed it.

A member has submitted 2 links and when going in to the moderation queue and clicking approve the following error (minus my server info) has appeared.

Warning: Missing argument 2 for linksFollow::sendNotification(), called in /usr/www/xxxxxxxxxxxx.com/forums/admin/applications_addon/other/links/sources/classLinks.php on line 180 and defined in /usr/www/virtual/xxxxx.com/forums/admin/applications_addon/other/links/sources/classWatchedContent.php on line 203

On clicking back and retrying to approve the link it goes through without the error the second time.

Sadly, this is not fixed in the update I just uploaded, but I can confirm it is fixed is 4.1, as I noted previously an entire rewrite of the application libraries is required to fix it.

Link to comment
Share on other sites

Hi as you can see here "http://forum.studio154.it/links/category/1-siti-web-di-fotografia/" I have bought and installed your app and it seems to work well.
But it there are 2 issues that I cannot understand:
1. You will see that appears a strange searching and ordering menu (usually I have only in the bar. How I can hide it? Why I see it? I notice that in your demo it there isn't.
2. In the editor I haven't an HTML editor but only a simple editor without commands and menu... please take a look:
Can I have a complete editor? Where I can mange it?
3. I notice that where a member insert a FB link it doesn't works well and doesn't appears in a new window with bar... depends it by Facebook platform or other?
Many thanks for your help
Link to comment
Share on other sites

1 and 2

"NetworkError: 400 Bad Request - http://forum.studio154.it/public/min/index.php?ipbv=ddb6137d502d9edc2317f2fd77f912eb&charset=UTF-8&f=public/js/ipb.js,cache/lang_cache/2/ipb.lang.js,public/js/ips.hovercard.js,public/js/ips.quickpm.js,public/js/ips.links.js,public/js/ips.like.js"

please upload the accompanying /public/ directory.... ips.links.js is coming up missing.

Link to comment
Share on other sites

try using https in the link?

Yes I tried to use https in the link... it doesn't works

Do you have check url valid on?

Yes I try to change this and another link and nothing happens... for example: http://forum.studio154.it/links/link/26-portfolio/

PLEASE NOTE: It happens with the first link that is inserted by the "links directory" form... the link inserted manually by the editor redirects well

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...