Jump to content

Links Directory [IP.Board 3.4]


Adriano Faria

Recommended Posts

  • 2 weeks later...

i have some issues with this app:

1. I cant enter the category-description. When i enter something, click on "Edit Category" i receive the message "The category has been updated", but there is nothing shown and when i edit the category again, the description field is empty...

2. The search item "Link Directory" (like on the demo site) is missing.

3. When i submit a Link, the system redirect me to a an error-page:

Sorry, we couldn't find that!

[#10CCS2]

We could not find the page you were looking for.

But when i enter the Links-Directory, the Link is submitted.

Any help would be nice!

Thank you

Link to comment
Share on other sites

Can you try this please? I seem to have found the submit redirect issue.

Upload the attached to adminapplications_addonotherlinkssourcesclassespostattachicon.gifmodel.php, overwriting the file that is there.

on quick tests it seem sto work fine, have not had much time to really check it but so far results are encouraging.

thank you :)

Sorry to muddle this thread - but you just turned my day around Dmacleo :lol: Thank you! x ten internets

Been there many times myself, just never read anyone actually say it.

:P I am blunt :)


Can you try this please? I seem to have found the submit redirect issue.

Upload the attached to adminapplications_addonotherlinkssourcesclassespostattachicon.gifmodel.php, overwriting the file that is there.

i have some issues with this app:

1. I cant enter the category-description. When i enter something, click on "Edit Category" i receive the message "The category has been updated", but there is nothing shown and when i edit the category again, the description field is empty...

2. The search item "Link Directory" (like on the demo site) is missing.

3. When i submit a Link, the system redirect me to a an error-page:

Sorry, we couldn't find that!

[#10CCS2]

We could not find the page you were looking for.

But when i enter the Links-Directory, the Link is submitted.

Any help would be nice!

Thank you

this fix is for this issue.same issue I had

Link to comment
Share on other sites

i have some issues with this app:

1. I cant enter the category-description. When i enter something, click on "Edit Category" i receive the message "The category has been updated", but there is nothing shown and when i edit the category again, the description field is empty...

2. The search item "Link Directory" (like on the demo site) is missing.

3. When i submit a Link, the system redirect me to a an error-page:

Sorry, we couldn't find that!

[#10CCS2]

We could not find the page you were looking for.

But when i enter the Links-Directory, the Link is submitted.

Any help would be nice!

Thank you

Ok...point #3 is fixed. Thank you Dmacleo !!! (working now with the model.php-File...)

Link to comment
Share on other sites

Feature suggestion for a future version (if it's not available yet): Option to add "weight" to links.

Weight being a number (from 1 to 100 for example). The "heavier" the weight, the higher on the list the link will appear.

Why this? mainly because it makes it easier to sell link adverts (the more they pay, the higher on the list the link will appear).

- Can a url appear on more than one category? it couldn't be done in some previous versions.

Why this? because sometimes a site will clearly belong to more than 1 category, and you don't want users to miss out on it...

Link to comment
Share on other sites

Feature suggestion for a future version (if it's not available yet): Option to add "weight" to links.

Weight being a number (from 1 to 100 for example). The "heavier" the weight, the higher on the list the link will appear.
Why this? mainly because it makes it easier to sell link adverts (the more they pay, the higher on the list the link will appear).

Custom fields - on @todo, shaping up to be more of a IPS4 feature honestly though.

- Can a url appear on more than one category? it couldn't be done in some previous versions.
Why this? because sometimes a site will clearly belong to more than 1 category, and you don't want users to miss out on it...

I have an idea of how to address this, however I have been profiling my possible implementation to be sure the footprint remains small, and will adjust as needed once I have an idea of how this handles with large data sets.
In short, I don't want to release the feature just to have it explode on a site with a large amount of links. This is actually one of the reasons I abstracted out the post model, to be able to generate a LOT of links easily for testing purposes.
Link to comment
Share on other sites

Future Suggestion, too:

Fetch Meta-tags and Meta-Description if nothing is entered from a member....

You are asking that they are auto-filled based on the given URL? http://www.marchertech.com/board/tracker/issue-58-suggestion-to-improve-link-submission/
Also on @todo.... as above, needed to fix the bugs first, as they were preventing usage in some scenarios. :smile:
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...