Jump to content

(e32) Points Per Subscription

(e) Eric

Recommended Posts


File Name: (e32) Points Per Subscription

File Submitter: (e) Eric

File Submitted: 15 Aug 2012

File Category: User and Social Engagement

Supported Versions: IP.Board 3.2.x

Purchase subscriptions with points. An ibEconomy Plug-in.

Version 0.0.2

This version REQUIRES IPB 3.2+, Subscriptions Manager, and ibEconomy 2.1.1+.

Main Settings:

  • On/Off
  • Use ibEconomy Group Percentage Adjustment?
  • Which ibEconomy tab to display the page on
  • Name of page

Group/Subscription Settings:
  • Group Allowed?
  • Subscription Enabled?
  • Subscription Cost

here to download this file

Link to comment
Share on other sites

No, that didn't fix it.

  • Uninstalled hook.
  • Reinstalled hook.
  • Set up subscription packages and cost in the settings page.
  • Checked to see if I had permissions to view the premium membership thing (Can Purchase Subscriptions For Points) Yes, I do.
  • Go to the economy home page.
  • Click Shop.
  • Nothing but All Categories and All items. Neither of which contain the subscriptions for points thing.

That's what I did in that order.
Link to comment
Share on other sites

Try recaching your ibEconomy and your skins and such.

Also, try placing it in another ibEconomy tab.

Have you tried any other ibEconomy plug-in that comes with it's own page?

And double check that all the files in the upload folder were in deed uploaded to the proper locations on your server.

Link to comment
Share on other sites

Recaching worked perfectly. It's appearing however there's another problem (Marked in red)

It displays this in the shop:

  • Gold VIP - 1 Month - $100.00
    Duration: 1 days· Group: Golden Member
  • Gold VIP - 12 months - $1200.00
    Duration: 12 days· Group: Golden Member

What's even more worrying is that a package set to never expire says the duration is 0 days. It's set up in IP.Subscriptions correctly, as the durations for each package is correct.
Link to comment
Share on other sites

No, sorry. I didn't explain it properly my apologies. The problem with the highlighted text is: (Bold text shows how long it actually is, red text shows the error)

For example 1 month shows as 1 day(s) in the subscriptions. 12 months shows as 12 days in the subscriptions. And yes the plural for days is off. It should be 1 Month shows as 28/30/31 days or just 1 month. 12 months should be shown as 365/366 days or 12 months, or 1 year. Does this clarify what I am saying?

>_< Sorry, I know, I'm dreadful at expressing my voice in text.

Link to comment
Share on other sites

  • 1 year later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...