Jump to content

Sign in through Google


Lavo

Recommended Posts

I have installed the plugin and everything works fine on "forced" prompt type.

When I switch to "automatic" prompt type, I get a 404:

The requested URL /interface/board/http%252525253A%252525252F%252525252Fwww.lifeimprove.co.il%252525252F was not found on this server.

I did change the domain name (old one redirects to the new one) and I think it might have something to do with it.

(tried removing and reinstalling)

Any help will be highly appreciated.

A week later - decided to uninstall the plugin. Too many issues unfortunately.

I apologize for this, development has seen a shift to github due to this being a freely available modification and other authors able and willing to patch issues. The automatic prompt failure is one of the items fixed, unfortunately by removal, as it proved to be something bugging out on google's handling of the data in this mode. The github repo is available here: https://github.com/MarcherTech/IPB-GOOGLE-LOGIN I would encourage anyone having issues to re-install from the GIT repo at this time, as I am trying to ensure the next update to the file listing here catches all the outstanding issues.

Link to comment
Share on other sites

  • Replies 375
  • Created
  • Last Reply

Hey marcher.

Some of my users (and me) are having an issue where when you click to sign in with google, the "allow access" page comes up. The problem is that you have to click allow access maybe 6 or 7 times before it actually logs you in. And then when it brings you back to my site, the "sorry, couldn't find that page" error comes up.

Do you have any idea how I might go about fixing this?

Thanks for your help. I really appreciate it.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Marcher,

Thank you for your earlier support on the ticket system.

I have re-routed our login system via custom page which gives more prominence to the Google login.

My one remaining issue is with new customers in Nexus. Upon checkout new customers are redirected to the loginOrRegister.html page with the link at the top of the page to login if the customer already has an account in the template the link is as follows...

{parse url="app=nexus&module=payments&section=pay&do=login&id={$invoice->id}&secure_key={$this->member->form_hash}" base="public"}

If I swap thie above out for a direct link to the Login in with Google hook upon return to our website the customer loses the items in their basket. Would there be a way to pass the same info above via the Google login?

Many thanks,

Jasper

Link to comment
Share on other sites

  • 2 weeks later...

Hello

This plugin seems to be working perfectly. There is one issue I'm having and I was hoping someone can direct me properly.

The login box appears to be putting the sign in with google on another line in another div, as opposed to be horizontally lined up with the facebook and twitter logins. Here is a screenshot.

Any help would be greatly appreciated

post-505833-0-92854100-1383494798_thumb.

Link to comment
Share on other sites

I ran a search for 'line 17' and nothing came up. Was hoping to not have to post lol :D

I havnt looked at it yet myself

But anyway, on my mobile theme, whene I goto log in, i receive this error:

Fatal error: Call to a member function displayButton() on a non-object in /home/website/public_html/forums/hooks/googleLoginDisplayButton_f7e9f400260c19083b50685bac753cf0.php on line 17
Link to comment
Share on other sites

  • 1 month later...

I get no error messages when linking my account to my new forum, but then when it reloads the forum it says

Your account is currently not linked with a Google account. To link it to one press the button below.

Anyone had issues with the version from the marketplace successfully linking on the most recent IPB Board?

Link to comment
Share on other sites

  • 1 month later...

I ran a search for 'line 17' and nothing came up. Was hoping to not have to post lol :D

I havnt looked at it yet myself

But anyway, on my mobile theme, whene I goto log in, i receive this error:

Fatal error: Call to a member function displayButton() on a non-object in /home/website/public_html/forums/hooks/googleLoginDisplayButton_f7e9f400260c19083b50685bac753cf0.php on line 17

Re-cache your skin sets from your Admin Panel > Look & Feel > Template Tools.

Worked like a charm. However, the process of setting up an application on Google is not so easy, and a tutorial on that would be nice.

I will go through setting it up again and update the instructions accordingly.

Any way to move the button location to the correct place? See attached screenshot.

http://community.invisionpower.com/topic/361879-sign-in-through-google/page-13#entry2367154

Link to comment
Share on other sites

  • 4 weeks later...

When trying to login with a user, I am getting this error: invalid_client.

I have made sure that I created a user with this email address and the username is the email address as well. Any ideas what may be happening.

Link to comment
Share on other sites

Some food for thought: How come the >Sign in through Steam is able to put everything on the same line?

PS: For me it doesn't matter anymore, as since I enabled Facebook, Twitter, Windows Live, and Steam, there is no space for the Google button there. Thanks for the attention and keep up with the good work!

By ignoring the fact if it is the only social login enabled it will not work by using that specific hook point. :smile:

When trying to login with a user, I am getting this error: invalid_client.

I have made sure that I created a user with this email address and the username is the email address as well. Any ideas what may be happening.

Please re-read the readme, your email address is NOT your google app client ID.
Link to comment
Share on other sites

  • 2 weeks later...

I cannot get the red cross beside the "Sign In With Google" (Community Enhancements) to go green and allow me to use it.

What am I doing wrong?

Link to comment
Share on other sites

  • 2 weeks later...

Please re-read the readme, your email address is NOT your google app client ID.

Supplied instructions must not be current. Continue to get the following:

Error:invalid_client
no application name

Advice please.

I am getting the exact same error. Error:invalid_client. Also, I don't see any information about e-mail address in the readme file.

How to fix it? Thank you and keep up the awesome work!

Link to comment
Share on other sites

  • 2 weeks later...

Supplied instructions must not be current. Continue to get the following:

Error:invalid_client
no application name

Advice please.

I am getting the exact same error. Error:invalid_client. Also, I don't see any information about e-mail address in the readme file.

How to fix it? Thank you and keep up the awesome work!

I had this error, you have to go into APIs & auth >> Consent Screen and fill out the "Product Name"

Link to comment
Share on other sites

Marcher,

I noticed there is no way to associate the Google Account with an existing account when attempting to sign in with it the first time? It automatically tries to create a new account, I'm assuming it is doing an underlying email match and it a match isn't found it just goes to create an account rather than give a user an option to associate an existing account? I can log into my account (via IPS or Facebook Connect) and then go to "Edit Profile" and "Manage Google" to associate the account though. Just seems like unlike Facebook Connect, the Google Connect doesn't allow for that initial existing account association.

Link to comment
Share on other sites

I had this error, you have to go into APIs & auth >> Consent Screen and fill out the "Product Name"

The product name is already filled out. Makes zero difference to the issue for me.

Still have: invalid_client no application name

Thanks for your help :thumbsup: but it looks like this mod is no longer supported by the developer.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...