Jump to content

Sign in through Google


Lavo

Recommended Posts

  • Replies 375
  • Created
  • Last Reply

I can PM you the ACP details if you would like

Thanks.

k, one last thing one could check is the order of the login modules... this one depends on a unique request parameter to trigger so should be safe at the top if need be, from what i can tell, the redirect uri on the google page is correct, which is very confusing.

Anyone experiences this, drag the Google Login module to the top of all Login modules, specifically and most importantly above IPB internal Auth from ACP=> System => Tools & Settings=> Login Management.
Clear your browser cache before throwing another test at it, it appears to be WAI now. Also tested live and internal auth(you have both enabled, so obviously test), which work as well with this login module at top.....
I don't rightly know what it was doing there.... very odd. :unsure:
Link to comment
Share on other sites

I like this idea, but what about when the forum board gets an update? will this stop working? will people not be able to sign in through it?

..........................................................

With as often as you directly ask this, it is quite apparent you do not trust any of us to update our works, I would suggest that you run a completely vanilla IPB install and never do anything beyond update it if you have so very little faith.

The whole point of a hook is to survive updates by avoiding source file modification.

I am actually nearly speechless by being asked this when not only is this free file one of the __first__ to be vetted/updated, but is the first to add a 'Community Enhancement' to 3.4.

For reference, your existing members registered through google would still be able to sign in normally(with password reset or having set a local), complete removal of this mod does not stop that.

No members of your community will be 'lost' in any case.

Link to comment
Share on other sites

..........................................................

With as often as you directly ask this, it is quite apparent you do not trust any of us to update our works, I would suggest that you run a completely vanilla IPB install and never do anything beyond update it if you have so very little faith.

The whole point of a hook is to survive updates by avoiding source file modification.

I am actually nearly speechless by being asked this when not only is this free file one of the __first__ to be vetted/updated, but is the first to add a 'Community Enhancement' to 3.4.

For reference, your existing members registered through google would still be able to sign in normally(with password reset or having set a local), complete removal of this mod does not stop that.

No members of your community will be 'lost' in any case.

It wasn't a question of your work.. If anything I was questioning the IPB software.

You are WAYY rude!

I know this won't mean anything, but forget about me. You've just lost someone from installing this, paid or free, you are a very rude developer.

Link to comment
Share on other sites

It wasn't a question of your work.. If anything I was questioning the IPB software.

You are WAYY rude!

I know this won't mean anything, but forget about me. You've just lost someone from installing this, paid or free, you are a very rude developer.

I really was not trying to be, I just get quite tired of seeing people ask the same question in several support topics, and your words did imply bad design of the modification or a lack of the work I put in to keep said free modification supported and updated, look through this topic.

It might not mean anything, but I do regret the tone with which I replied..

Link to comment
Share on other sites

It wasn't a question of your work.. If anything I was questioning the IPB software.

We 3rd party developers have no way of knowing what changes will be made in future IPS products. Even IPS can't tell you what 3rd party mods will break. It's impossible for us to know if a hook / app / mod of any kind will work on future versions. Completely impossible. The only real way to know for sure is to test when the new version comes out.

The question you should be asking, instead of the one you did, was whether or not the author is continuing support and will be updating the mod for future versions when they are released.

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I get this error on 3.4.1

Error:redirect_uri_mismatch
The redirect URI in the request: http://phoneunlockserver.com/interface/board/linkgoogle.php did not match a registered redirect URI

I tried editing the link as in post 7 but I cannot see where to put the link :(

Any help?

Thanks in advance

Link to comment
Share on other sites

  • 2 weeks later...

Google is not showing up in my Login Authentication Manager under Community Enhancements. I don't understand it, I put in the correct Client ID and Client Secret, I uploaded the files exactly as directed, installed the hook. Even uninstalled and re-installed the hook and re-entered my client info and I am getting the message Warning - Google Login Module Disabled. I noticed in my authentication manager it has a red X but all it does is show me the client info I already entered.. it is nowhere in the list to enable.. please help!

Link to comment
Share on other sites

did you follow the link it gives you?

http://community.invisionpower.com/topic/361879-download-sign-in-through-google/?p=2331492

I just checked the zip from download fresh, the files adding the login module are there, and in the correct structure.

Clicking 'DISABLED' enables it, and it must be installed from the list below the installed login modules first if not already.

Link to comment
Share on other sites

that would mean the whole directory /admin/sources/loginauth/google/ is missing from your server... if you have a renamed admin directory, as the readme states, you will need to upload the *contents* of /admin/ to it.

Again, I did check before responding to your post, it *is* in the download. If it would help, given access I can look into the difficulty you are facing, but the above is the only explanation if it is not listed in installed login handlers or other available login handlers..

Link to comment
Share on other sites

  • 4 weeks later...

i have tried ot set up google log in, i have only been able to log in once i keep getting this error, sorry if this is a obvious error in setting up the api, any idea son how i could fix this? :D


www.xxx/ipboard/interface/board/google.php did not match a registered redirect URI

Link to comment
Share on other sites

make your https:// into http:// instead in those links, or copy them, paste them in again after the existing, and change the 2 'extras' if you wish to at some later date route logins through https... You are not processing logins through https, visited your site and inspected the login page.

Google is evil picky about that.

Also was not jumping you, apologies if it came off as such, just covering the #1 repeat possible cause, though that(https versus non) now has the close second in that... will likely add to the readme to add both https/http, as it does 0 harm, and saves headache. :smile:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...