Jump to content

Sign in through Steam - IPB3


Lavo

Recommended Posts

Something is wrong with this. When trying to register with it, completing the registration gives a blank screen with the final details:

3b5d0Tf.png

Twitter/Facebook work.

EDIT: I've figured out what causes it literally seconds later. If you disable members from choosing a display name, you will get stuck at this screen.

Hi,

What plugin version and IP.Board version are you running?

Link to comment
Share on other sites

  • Replies 167
  • Created
  • Last Reply

Latest for both. I've solved it though. What I did was enable Display Name changing globally and disabled it on a per-group basis.

That is a rather odd bug... I'll have to look into it. Thanks for reporting it :)

Link to comment
Share on other sites

  • 4 weeks later...

Hello Lavo great work!! ... I wanted to know how I can do to determine if the user is online from steam or not? useful for <if test="$post['author']['login']['steam']['_online']">...</if> or <foreach loop="member[login][steam] as $user">list of member by steam and if play with a game appear a title</foreach>

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
  • 4 weeks later...

Hi. I change my host/domain recently and now this is not working anymore.

I tried reinstall it without sucess.

When i try login, im redirect to Steam Login site, enter login and pass, click Login button, confirm account and click Login button again, but nothing happens.

I keep get redirect to same page (Steam Login site).

My IPB is 3.4.5.

http://manosforever.com/forum

Any help?

ps: sorry for my english.

Link to comment
Share on other sites

  • 4 weeks later...

Can you add HTTPS support for your image ?

The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 index.php:1
The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 index.php:1573
The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 index.php:1622
The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 

Thanks :thumbsup:

Link to comment
Share on other sites

Hi. I change my host/domain recently and now this is not working anymore.

I tried reinstall it without sucess.

When i try login, im redirect to Steam Login site, enter login and pass, click Login button, confirm account and click Login button again, but nothing happens.

I keep get redirect to same page (Steam Login site).

My IPB is 3.4.5.

http://manosforever.com/forum

Any help?

ps: sorry for my english.

Are you still having this issue? The Steam Login works perfectly fine on my GTA forum. :)

Link to comment
Share on other sites

  • 3 weeks later...

My community cannot seem to login after moving servers... I get to the steam website to sign in.. Type user and pass then it will go like its logging in, but then it will go directly back to the login page on steam. Not sure if i can explain this any better other than seeing it first hand. www.gcinema.net/forums

http://goo.gl/3qNonh i found when i took apart the url lol. deleted a section.

it links to http://www.gcinema.net/forums/interface/board/steam.php (which will just loop you back to the steam login page)

Link to comment
Share on other sites

Hi,

Is there any way to bridge your product with this one? It would be awesome if associating a Steam account would automatically populate that product's field and pull the appropriate info.

Not on this one since this is just to provide a login service, however the one you are referring to can use that this stores in the database.

I would say to go request it there, but you already have. :P

Link to comment
Share on other sites

Can you add HTTPS support for your image ?

The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 index.php:1
The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 index.php:1573
The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 index.php:1622
The page at index.php?app=core&module=global&section=login displayed insecure content from public/style_extra/signin/login-steam-icon.png.
 

Thanks :thumbsup:

I second this- anyone know where this image is being set?

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
  • 2 weeks later...

Hows one to configure this to allow current members to use the steam login option? (how do they associate their steam account w/their current IPB account? or how do I configure the settings in the ACP?)

I went to my profile, and unlike Facebook login where it prompts you to associate, there was nothing for me to associate with the Steam login. I do have a custom steam ID field we have had for a couple years....hope that's not an issue.

Link to comment
Share on other sites

Lavo,

Currently, you've hard coded the HTML output within the hook php file. This forces all skins to use the same HTML.

Some custom skins do manipulate the output in the login areas and thus cause the output of your hook to break the site. The only way to fix this is to update the hook php file, which then changes ALL skins and breaks the ones it was working on.

You really should consider template abstracting the HTML output so any issues can be fixed per skin in the ACP rather than globally by editing the hook php file.

Just a suggestion.

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Can I disable registering with Steam?

I just had to disable this plugin because I'm having a major issue.

After a user signs up it's redirecting them to steam to login. I do not want to force users to go to that page, how do I disable this?

You can't disable it, because that's how OpenID works. The user gets redirected to the providers site to login and/or verify that they are indeed requesting the login.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...