Jump to content

Tutorials


Adriano Faria

Recommended Posts


hou about compatibility with board that have installed miniTutorial? is it possible the transfert?




Here is what you can do. Convert the tutorial from miniTutorial to topics and uninstall that one. Now, install Michaels tutorial mod and convert topics to tutorials in his mod.

It should work fine because I did same above thing couple of months back.
Link to comment
Share on other sites

  • Replies 1.2k
  • Created
  • Last Reply

Here is what you can do. Convert the tutorial from miniTutorial to topics and uninstall that one. Now, install Michaels tutorial mod and convert topics to tutorials in his mod.



It should work fine because I did same above thing couple of months back.




ok understand. thanks :)
Link to comment
Share on other sites

  • 3 months later...

Upgraded this to version 1.1.1 today. New features include:

  • Pinned tutorials
  • Quick edit an article
  • Ajax toggling of hidden/shown
  • Link to mark just the tutorials system as read, only able to do it category-by-category or entire site now
  • Receiving email notifications when tutorials have comments
  • Ability to do a Facebook Like for an article
  • Support for Sitemap Generator
  • A single RSS feed for the whole system
  • Setting for whether RSS updates by article submit date or article updated date
  • IP.Content plugins
  • Add the number of comments each article has to the category view
  • Settings for meta description and keywords for the tutorials index
  • Add additional quick tags into support topic template
  • Add the tutorial description as support topic description
  • Clean up page titles ('main category : Subcategory : Sub-subcategory : article')

In addition to these, the following bugs were fixed in this release:


Full announcement: http://www.codersrefuge.com/topic/2834-im-tutorials-111-released/
Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

I don't understand what you're saying. What settings did you check? It doesn't show up at all in the My Apps section? The best I can tell given what you're saying is that you haven't actually installed it yet. Did you follow the instructions in the documentation? Does it show as an application you can install from the Manage Applications & Modules page?

Link to comment
Share on other sites


Basically i'm asking how do you add a app in the "My Apps" section of the ACP Administration????



Applications that are installed show up there, there isn't anything special you have to do. Are you the only Admin on the site? It sounds to me like your account has ACP restrictions in place preventing you from seeing this App. I'm not sure if you can check this or you have to have another Admin check it, but someone needs to look on the Admin CP's Member tab in the Manage ACP Restrictions page and see if they can either remove your restrictions or add the Tutorials app as something you're allowed to access.
Link to comment
Share on other sites

A very useful mod. I've purchased it for use as an Articles repository for my site. One question: I don't see the links to download or print the article and I think I've set things up properly. Evan as admin, where I've ticked all the boxes, I can't find these links. Where should they be?

Thank you, Michael - you have a satisfied customer :)

Cheers

=:~)

Link to comment
Share on other sites

Aha! Board policy is to disable Share Links so I've disabled Facebook, Twitter and the like and now I can see the appropriate icons. The problem now is that Download only downloads in HTML - there's no option for Word. What have I missed?

Cheers

=:~)

Link to comment
Share on other sites

Looks like you haven't missed anything, it appears the only download option included in the Share Links is to actually just download as HTML. I had Word as an option in earlier versions before IPS added the Share Links button, I didn't realize they had removed that as a download option; it used to be a choice when downloading topics so I assumed it was still there. I'll update the app's description, and see if I can re-add a download as Word option in the future. I apologize for the confusion.

Link to comment
Share on other sites

  • 2 weeks later...

I appear to have made something of a micro-fubar while trying to tweak things to my liking. As mentioned above, I purchased Tutorials because it makes a cracking articles repository and a fine addition to the board. Since I'm using it for articles, I'd gone through the language strings replacing "tutorials" with "articles" where appropriate - so far so good.

To satisfy my somewhat perverse desire for order within the forums, I wanted to change the name of the tutorial folder within application_addons such that the URL showed a path to /articles rather than /tutorials. This, I thought cunningly, could be achieved by dint of renaming the folder and then going to Manage Applications & Hooks | Tutorials and changing the application directory accordingly. My joy at such an apparently simple solution was as short-lived as the aftermath of a couple of LHC proton collisions when, upon clicking the (now) Articles menu button forum-side, the board threw a major hissy fit and spat out a few no-nonsense PHP fatal_error warnings. Still, no real harm done: just undo those two changes and we're tickety-boo... and so it was forum-side. It wasn't until I went to My Apps and tried to access the program that events took on a faintly surreal aspect. Instead of the comforting view of Tutorial's config settings et al, I was, rather rudely I thought, dumped right back to the Dashboard and on every attempt thereafter.

This behaviour, as you might well imagine, prompted the biggest WTF moment since Julius Caesar copped a backful of steel on his way to a local performance of A Funny Thing Happened On The Way To The Forum. Simple logic declares that if you reverse the changes, harmony is restored. Over on the forums, all is sweetness and light (in varying proportions); on the admin side... well something is odd and having been driving an Invision board for eight years (I think we started with 1.1.3) and being well used to rummaging around in the undergrowth, trusty text editor in hand, I can say with all honesty that I've never seen such infuriatingly irrational behaviour. The muted mutterings coming from my console for the last hour have led the cat to adopt an air of haughty disdain and the memsahib to poke me sharply in the ribs whenever the volume becomes intolerable.

So between the sense of bewildered incomprehension and the small round bruises appearing all over my left side - not to mention the rapid approach of the Silly Season - I am a tad discombobulated. Do you, Michael, have the faintest idea a) what I'm talking about and b) where I can go and poke around with a spanner to fix it? Knowing me, I've probably done something monumentally stupid :D

TIA

=:~)

Link to comment
Share on other sites

If you wish to alter the directory, I assume you mean the FURL version.

Mine for example is at http://www.fansfocus.com/info and my categories are known as leagues

You will need to alter /admin/applications_addon/other/tutorials/extensions/furlTemplates.php

$_SEOTEMPLATES = array( 'cat'			=> array( 'app'		  	=> 'tutorials',

												  'allowRedirect' => 1,

												  'out'       	=> array( '#app=tutorials(?:&|&)cat=(.+?)(&|$)#i', 'info/league/$1-#{__title__}/$2' ),

												  'in'        	=> array( 'regex'   => "#/info/league/(\d+?)-#i",

																			'matches' => array( array( 'app', 'tutorials' ), array( 'cat', '$1' ) ) ) ),


						'article'   	=> array( 'app'		  	=> 'tutorials',

												  'allowRedirect' => 1,

												  'out'       	=> array( '#app=tutorials(?:&|&)article=(.+?)(&|$)#i', 'info/article/$1-#{__title__}/$2' ),

												  'in'        	=> array( 'regex'   => "#/info/article/(\d+?)-#i",

																			'matches' => array( array( 'app', 'tutorials' ), array( 'article', '$1' ) ) ) ),


						'app=tutorials'	=> array( 'app'       	=> 'tutorials',

												  'allowRedirect' => 1,

												  'out'       	=> array( '#app=tutorials$#i', 'info/' ),

												  'in'        	=> array( 'regex'   => "#/info/?$#i",

																			'matches' => array( array( 'app', 'tutorials' ) ) ) ),

					  );



Is the critical parts that I have altered (my version shown above)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...