Jump to content

Topic Preview On Hover


Ryan Ashbrook

Recommended Posts



File Name: Topic Preview On Hover

File Submitter: Ryan Ashbrook

File Submitted: 08 Apr 2012

File Category: Integration

Supported Versions: IP.Board 3.3.x



New Features:
- Truncation Character(or not to truncate at all)
- Controls, and removes the "click" table row from the list.
- The Topic preview on:hover now extends to Search, View New Content, Forum and Board index, IPS Recent Topics Hook, and RealStats.



here to download this file

Link to comment
Share on other sites

  • Replies 78
  • Created
  • Last Reply

I may have misread the item and installed it on my 3.2.3 board. It's working great! Going to upgrade to 3.3 in the next 2 - 3 weeks, but this is a VERY welcome hook, and I am very happy that it's working (and hasn't crashed) on my 3.2.3 board.

Link to comment
Share on other sites


I may have misread the item and installed it on my 3.2.3 board. It's working great! Going to upgrade to 3.3 in the next 2 - 3 weeks, but this is a VERY welcome hook, and I am very happy that it's working (and hasn't crashed) on my 3.2.3 board.



well I will be shoddered.
:tongue: ...Do NOT Install the Content bit if you go this route(that WILL break).
the only reason it works is cause i tore apart the regex after it broke on 3.3 to... not require me to update the regex again hopefully ;)
Link to comment
Share on other sites


Hey Marcher, it's not clear, at least for me... this is for IP.Content only or works on IP.Board as well ?



it works for IPB by itself.
just added a /ccs/ directory for content's hook/block template. Not required.

Hi there,



had to delete hook and block, they were causing an error in ipcontent and forum.



IPC Version? and what error, specifically?
Link to comment
Share on other sites


Any possibility of getting this to work on the View New Content listing of topics too? Thanks for taking this over. Works fine on my 3.3 installation!



feasibly... i'll look... different hook point... hopefully enough valid markup there for me to latch onto :tongue:
EDIT: should be possible, though its gonna be a bit of a messy regex as the topic id is not on the a tag, but is on the tr itself there.
Link to comment
Share on other sites


feasibly... i'll look... different hook point... hopefully enough valid markup there for me to latch onto :tongue:


EDIT: should be possible, though its gonna be a bit of a messy regex as the topic id is not on the a tag, but is on the tr itself there.



Yes.... this is doable(done it locally... packaging) had to use a skin overloader though, which severely limits it's compatibility backwards tbh.... BUT... I went the full keante with it as it were..... VNC and search topic popups.
Link to comment
Share on other sites


well I will be shoddered.


:tongue: ...Do NOT Install the Content bit if you go this route(that WILL break).


the only reason it works is cause i tore apart the regex after it broke on 3.3 to... not require me to update the regex again hopefully ;)




Well installing on a 3.2.3 board, worked for some, and not for all, so I disabled the hook and will add it in again after the upgrade to 3.3. This is a VERY welcome modification and there was quite a bit of excitement for those who it did work for.
Link to comment
Share on other sites


Well installing on a 3.2.3 board, worked for some, and not for all, so I disabled the hook and will add it in again after the upgrade to 3.3. This is a VERY welcome modification and there was quite a bit of excitement for those who it did work for.



hrmm.... what do you mean by worked for "Some"? its not.... hrmm..... permissions? there's very little that could cause that..... i don't even think its possible for a skin to bork it... BUT code differences between the versions could be.
as i said, im not worried about 3.2..... the support topic for the unsupported 3.1 version has a tested fully compatible 3.2 file.
Link to comment
Share on other sites


Well installing on a 3.2.3 board, worked for some, and not for all, so I disabled the hook and will add it in again after the upgrade to 3.3. This is a VERY welcome modification and there was quite a bit of excitement for those who it did work for.



ah.
Dont install this file on a 3.2 board... use this instead http://community.invisionpower.com/topic/323896-download-topic-preview-on-hover/page__st__60#entry2224195
and the reason it errors is because of missing templates..... and IPSMember functions.,,, ones added not present in the linked file.
I SAID I updated it... that includes member photo template use, and microformat/Functions..... I do have to check whether the poster is "Inactive" ergo, banned now.... and whether profiles can be viewed by the user before showing any links.... ergo, massive consistency updates WERE done for this file for 3.3, so I am NOT Surprised.
Link to comment
Share on other sites


there... file updated.


VNC+Search Hovers.


pretty darn certain this latest version will only work on 3.3, as such a put a version requirement on the hook, and left 1.0 on the previous versions.


Also... NO.... I am NOT going to go through the shenanigans on archived when stock doesn't work on it :tongue:




Works like a charm! Thank you so much!
Link to comment
Share on other sites

The post for the 3.2.3 systems works perfectly, thank you! I also put the latest version on my 3.3.0 board and I REALLY like the changes made, especially the hover for new content! This mod should be a standard feature.

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...

On the version for 3.3 - Some users are noticing on smart phones using the full version of our site that clicking on a topic title brings up the hover preview. On some phones it locks up the browser. On others, the preview can't be closed and you must select View Latest Unread to go into the topic.

Link to comment
Share on other sites


On the version for 3.3 - Some users are noticing on smart phones using the full version of our site that clicking on a topic title brings up the hover preview. On some phones it locks up the browser. On others, the preview can't be closed and you must select View Latest Unread to go into the topic.



does it do this on other hoverCards? i suspect more an IPB js bug here.... but can use some checks to naturally degrade it to what is stock regardless I suppose.
Link to comment
Share on other sites


does it do this on other hoverCards? i suspect more an IPB js bug here.... but can use some checks to naturally degrade it to what is stock regardless I suppose.




Since you asked, we tested on several types of phones to see if it happens when in a topic clicking on a member's name above their photo. It takes us directly to the user's profile as expected from a phone. Rather than pop up the hover card for the member's information.

Any other hover cards we might test?
Link to comment
Share on other sites


Since you asked, we tested on several types of phones to see if it happens when in a topic clicking on a member's name above their photo. It takes us directly to the user's profile as expected from a phone. Rather than pop up the hover card for the member's information.



Any other hover cards we might test?



just one... this is weird cause i know its the same code btw.


http://www.marchertech.com/board/syndication/

Link to comment
Share on other sites


http://invisionfocus...gory/1-ipboard/

if it does it there... stop barking up my tree :D and go report it in the tracker for IPB.


I'm calling the stock standard ipb.hoverCardRegister.initialize in all my code.




That seems a bit rude..... But OK.

I had several folks stop by and test it there to see if it happened on the topic preview popup. Had them all try other hover popups as well. I thought you were wanting people to try it to see if it was only on the topic preview hover popup or on all hover popups. Well, it is only on the topic preview one both there and on our site.

Sorry for providing you with the information you requested.
Link to comment
Share on other sites


That seems a bit rude..... But OK.



I had several folks stop by and test it there to see if it happened on the topic preview popup. Had them all try other hover popups as well. I thought you were wanting people to try it to see if it was only on the topic preview hover popup or on all hover popups. Well, it is only on the topic preview one both there and on our site.



Sorry for providing you with the information you requested.



Nothing to be sorry about... confused, but will add some code to do epicly nothing if the user-agent is a phone.... at least with what methods are available to me for checking such.
as a curiousity, does the normal preview sans this hook function on the phones?
and out of further curiousity, why exactly are we browsing the full skin on a phone and then giving grief when not all WAI?
I did not add mobile templates to the rss app for my good health... the full skin is not meant for phones.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...