Jump to content

Community

Recommended Posts


Having trouble with a number of feeds. I often get...



[color=#5D8005]We could not find any changes in the RSS feed (nothing to import).[/color]



For this feed...

http://ezralevant.com/atom.xml

I tried converting it with Feedburner and it still gave the same result.



http://community.inv...__fromsearch__1
http://community.inv...809#entry136809
I use the standard IP.Board RSS library, and at this time have little spare time to code an atom-compatible library from scratch.
that being said.
I am exploring getting it and reading it as a straight xml file with other IPBoard libraries available to me.

Share this post


Link to post
Share on other sites

http://community.inv...__fromsearch__1
http://community.inv...809#entry136809

I use the standard IP.Board RSS library, and at this time have little spare time to code an atom-compatible library from scratch.


that being said.


I am exploring getting it and reading it as a straight xml file with other IPBoard libraries available to me.




I got it to work using Yahoo Pipes. If anyone else has this problem...

http://pipes.yahoo.com/pipes/

Share this post


Link to post
Share on other sites

Marcher, I'm somewhat confused after testing your demo.



When I hover over an RSS feed title, I get the hovercard which displays the content of the feed, nicely formatted. Great!



However, when I click the RSS title link, I expect to be taken to a page that contains full page view of that RSS feed, similarly formatted as the hovercard, so I can easily read say 15 entries.



Instead I am taken to the default RSS display mode, as determined by my web browser. In other words, it looks horrible in Chrome (XML code), and nice in Safari. This seems very limiting in my opinion.



Could there be an icon perhaps next to the title that brings up a full-screen-width hovercard (like a lightbox) at least. Something like the YouTube fullscreen icon. I would still rather the title links takes the user directly to a dynamically generated 'page' on my site that they can bookmark for later use (in other words they can use my site as a full-screen RSS reader if there browser doesn't have it).




You already have the link to the source, and I agree it should stay. The original source feed could be optional though as some admins might not want anyone knowing their RSS feed URL's as they'd copy them into their own competing websites.



When you hover over the RSS icon in your mod (orange thing with white curves) it says "View Source: IPS News". So the source link's already positioned where I think user's would expect to see it.



ok
question
I went a slightly different route... each feed has its own "view" with a page( i mean literal page, in the skin, not a popup, not a card).
should this follow the truncation for the cards? i ask as it fully parsed... looks pretty nice... but it is a rather lot of data to take in... in fact what you would see only nicely in the skin when visiting the actual source..

I got it to work using Yahoo Pipes. If anyone else has this problem...



http://pipes.yahoo.com/pipes/

I have ATOM compatibility functioning at this time locally.

Share this post


Link to post
Share on other sites

If I understand correctly I would say fully parsed but how much in terms of resources used?



honestly, no more than the cards themselves.
im not doing any additional processing, it is handing me the straight HTML after reading the feed, and i cache the xml locally already.. though after noting a bug, thats going to be a LONGTEXT on upgrade.

Share this post


Link to post
Share on other sites

I don't understand the term "LONGTEXT" I assume it has something to with character length. Would this be a problem and if so how would it manifest itself>



it is a newly-discovered problem in 1.0.2
it would manifest itself by the cards lying and stating no content is present when there is content, and would only occur with IMMENSE feeds like:
http://blogs.msdn.co...?Type=BlogsOnly
basically, the columns limit invalidates the feed and it silently fails out.
have resolved this... am working final touches/requests like choosing the size of the uploaded image resize, and url field for databases/show on Frontpage for articles.... basically tidying the place.

Share this post


Link to post
Share on other sites

It took a while... mainly as i had to run rampant through nearly every file, standardize and enhance pretty much every aspect of this application, but file updated.


[/color]



[color=#000000]It works when I click "import to database" so that should be fine.[/color]





Not what I need [img]

[/img] I want them to show up in their category but not on the front page.



Another thing I noticed that I hope you can address. The URL field does not appear to be populated using this import function.



Input field keys and values, in this format: article_homepage=,0,;url_off={url};some_key=some value; Replacement will occur for all ccs_databases column names for their values, and all ccs_database_categories column names for their values. Example:{database_name} would be replaced with the Content Database name. {category_name} would be replaced with the category name if importing into a category.


Basically, you have unlimited flexibility on what to fill the fields with here, and Content Data Hooks are now fully supported.... as is the {url} dynamic replacement.

Marcher, I'm somewhat confused after testing your demo.



When I hover over an RSS feed title, I get the hovercard which displays the content of the feed, nicely formatted. Great!



However, when I click the RSS title link, I expect to be taken to a page that contains full page view of that RSS feed, similarly formatted as the hovercard, so I can easily read say 15 entries.



Instead I am taken to the default RSS display mode, as determined by my web browser. In other words, it looks horrible in Chrome (XML code), and nice in Safari. This seems very limiting in my opinion.



http://www.marcherte...ps-marketplace/

Marcher, Your app Imports feeds have Tags functionality?



Every app import type now supports Tags.

Having trouble with a number of feeds. I often get...



[color=#5D8005]We could not find any changes in the RSS feed (nothing to import).[/color]



For this feed...

http://ezralevant.com/atom.xml

I tried converting it with Feedburner and it still gave the same result.



ATOM Compatible, both on imports and output.


have resolved this... am working final touches/requests like choosing the size of the uploaded image resize, and url field for databases/show on Frontpage for articles.... basically tidying the place.



On this... I found it was really, really, really not a good idea to allow you as the user to nuke a picture spread about possibly 100's of records.
Upload a new image to affect further imports, input the maximum dimensions for the image to be resized to.
I reworked pretty much everything here. 1.0.3 is IPB 3.3.x and IPC 2.3.x compatible only, Do Not upgrade this application to 1.0.3 if still using IPB 3.2/IPC2.2.

Share this post


Link to post
Share on other sites

wow, amazing redo! I had a look at the IPC article import link.

question 1: does this app allow for approval prior to publish? I may want to publish some articles but not others from a given feed ...

thanks for taking so much time to create this

Share this post


Link to post
Share on other sites

wow, amazing redo! I had a look at the IPC article import link.



question 1: does this app allow for approval prior to publish? I may want to publish some articles but not others from a given feed ...



thanks for taking so much time to create this



one of the stock options pre-1.0.3, Records Approved?
the addition of the text area to specify values for other fields was a need from another user.... I simply decided to give it more flavor with database/category values as well.

Share this post


Link to post
Share on other sites

In the upload folder there appears to be an additional index.html file in the admin sub directory. This caused my ACP to return a 403 forbidden message, which was just that index file being used instead of the index.php of the ACP.

Just a heads up for anyone else getting the same issue and maybe the dev would like to remedy this in the available version.

Share this post


Link to post
Share on other sites

In the upload folder there appears to be an additional index.html file in the admin sub directory. This caused my ACP to return a 403 forbidden message, which was just that index file being used instead of the index.php of the ACP.



Just a heads up for anyone else getting the same issue and maybe the dev would like to remedy this in the available version.



.... woops.... yes, remedying immediately.... don't remember putting that index file there at all.

Share this post


Link to post
Share on other sites

File Updated.
Also going to nuke 1.0.3, theres a bad furl Template in it, basically 10 as the feed id would cause /1-title-seo/0 and so on.... bad stuff, glad i caught that.
Added Session integration and a Viewing the APP on the index, and Viewing this Feed Active users Support.

Share this post


Link to post
Share on other sites

Just Clicking Create New Stream does that?


trying to allocate [color=#000000]4096 bytes(4 kb) for the Forums dropdown it is running out of memory.... that's not really normal...[/color]


[color=#000000]Need better specifics to help.. or access, the error literally makes 0 sense.... I could potentially see a literal insanity of forums causing a little extra memory usage, but that makes little sense for 4kb usage to go left...[/color]




We've had similar problems. on clicking "Create New RSS Import Stream...":


Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 46 bytes) in /home/***/public_html/forum/admin/applications/forums/sources/classes/topics.php on line 733

Share this post


Link to post
Share on other sites

We've had similar problems. on clicking "Create New RSS Import Stream...":



Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 46 bytes) in /home/***/public_html/forum/admin/applications/forums/sources/classes/topics.php on line 733



Disable the stream when adding.
importing is an intensive process.... try editing it disabled... does it still occur when toggling it active and recaching that feed?
how many items per go are you doing?
going to go look at that line again... this is odd.... that's not my file.... I'm using it, but thats not my file.
Is This simply trying to load the form?
... how many topics are in that forum?
... I may have to do a type-ahead here.
PM me access to investigate?

Share this post


Link to post
Share on other sites

in essence.
if it is literally trying to load the form...
it could be this.


if ( ! $this->func_topic )

  {

   $classToLoad = IPSLib::loadLibrary( IPSLib::getAppDir( 'forums' ) . '/sources/classes/topics.php', 'app_forums_classes_topics', 'forums' );

   $this->func_topic = new $classToLoad( $this->registry );

  }

  $_topics[] = array(0, $this->lang->words['app_rss_new_topic']);

  $topics = $this->func_topic->getTopics(array('forumId' =>  !empty($this->request['rss_import_forum_id']) ? $this->request['rss_import_forum_id'] : $rssstream['rss_app_type_1'], 'onlyViewable' => FALSE, 'onlyVisible' => FALSE));

  if(count($topics) && is_array($topics))

  {

   foreach($topics as $t)

   {

    $_topics[] = array($t['tid'], $t['title']);

   }

  }

Share this post


Link to post
Share on other sites

in essence.


if it is literally trying to load the form...


it could be this.




That's what it looks like. Clicking on the "Create New RSS Import Stream..." button will cause the out of memory fatal error.

Share this post


Link to post
Share on other sites

or... at least to get it usable, and due to the highly complex but working intricacies of Contents import form selections... ill simply patch the file giving issues at this very moment.... simply re-upload the files... tell me if that resolves the issue?
Is a type-ahead returning the forum/topic id.... no extra loads to nab the "names" just to load the form.
Not nearly as intelligent though, admittedly.... if you choose a forum id then choose a topic from a different forum... which it allows... it will go about making a new topic in that forum.

Share this post


Link to post
Share on other sites

This is an update of functionality nearing completion(Block Templates work being done). I have found the stock Content RSS feed to be quite limited in the data returned, and allowable sources.... therefore, 1.0.5 will feature an XML Content Feed block. What does this mean specifically for IP.Content owners?
RSS Feeds with enclosure/media data preserved, ATOM Feed blocks, and full reads of any valid XML File, no muss or fuss.

Share this post


Link to post
Share on other sites

Hi,

I have been getting this error and not sure how to fix:

Error: Could not load template 'rssLink' from group 'rss'

Steph
www.enseignercpartager.org

Share this post


Link to post
Share on other sites

Custom skin? edit the IP.Board skin, make the skin key default if it is not(i would guess not), save, and rebuild from xml and recache all skins.
If you are not ignoring signatures, mine actually references a tracker entry for the bug you just hit in IPB.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...