Jump to content
Holiday Closures ×

Community

phpony

Download: Inline Image Uploader for IP.Board 3.x

Recommended Posts

File Name: Inline Image Uploader for IP.Board 3.x
File Submitter: Aoyagi Ritsuka
File Submitted: 20 Feb 2012
File Category: Hooks and Plugins

External image uploader for CKEDitor in IPB 3.x.

Extends IP.Board 3.x visual editor by adding additional "upload" tab to "Image" dialogue. Images are being uploaded and inserted into posts as "img" tag with direct link to uploaded image file. No access control, simple limitations. Perfrect solution for uploading inline illustrations.

Check readme.txt for installation instructions.

Not a modificatoin, cause no file edits are needed, but a more functional replacemend for "image" CKEditor's plugin. Can easily be reverted back by uploading original one from distributive.

Click here to download this file

Share this post


Link to post
Share on other sites

This doesn't work for 3.2.3? I press upload and browse the image, then click on Send to server and nothing happen?




I agree, not working for 3.2.3.

I do have a 3.3.0 Alpha 1 demo server and it works fine on that.

Anything we need to do to get it working on 3.2.3?

P.S: Nice hook by the way :laugh: All the other upload hooks dont work well with our server theme, but this one does. Nice job! %7Boption%7D

Share this post


Link to post
Share on other sites

I'm also running 3.2.3, followed instructions, CHMOD to 777 the folder just in case, and nothing is being uploaded after clicking "send to server". It does take a while, and looks like it finished uploading but nothing in the folder when I check via FTP.

Share this post


Link to post
Share on other sites

Works on one of my borads using 3.2.3, but not the other.

One is in swedish on my own server (don´t work) other in english (works) hosted here by IPS.

Weird...

Addition: I get a 404 error thats kind of hidden within the "popup" itself.

Share this post


Link to post
Share on other sites

Well it looks like I will have to wait until 3.3.0 comes out %7Boption%7D

It is a shame this hook is not supported by the developer, it is such a great hook.



Addition: I get a 404 error thats kind of hidden within the "popup" itself.




Yeah this is what happens on my 3.2.3

Share this post


Link to post
Share on other sites

He only submitted it 3 days ago. Give him some time, he might be on holidays, real-life commitments, etc.




Yeah I have done the waiting game with this developer over here

So I expect the same will happen here with this mod - NO SUPPORT AT ALL!

Share this post


Link to post
Share on other sites

There is so many broken image on my forum. It such a shame I been waiting for this mod all this time and now it does not work. I have send him pm but now he don't respond back anymore.

Share this post


Link to post
Share on other sites

I have send him pm but now he don't respond back anymore.




This developer needs to be banned if they submit mods and never respond to hooks that do not work.

I am marking this mod as broken.

Share this post


Link to post
Share on other sites

I just installed this on a test board and it worked fine for me. I'm removing the broken file flag.




What version is your IPBoard? Does this mod depend on the host too?

Share this post


Link to post
Share on other sites

The issue with this modification is a few things.

First look at your error log for Apache, if you see the following error:

client denied by server configuration: /home/<user>/public_html/uploads/inline/upload.php[/CODE]

Then you have no execute access to the file (upload.php), this may have been caused by several different server security configurations, it also may have happened by the following. If you have been in the security center in the ACP and have clicked "IP.Board PHP/CGI .htaccess Protection" this will add a .htaccess file in the following folders:

[CODE] Written .htaccess to /cache/... Written .htaccess to /public/style_captcha... Written .htaccess to /public/style_css... Written .htaccess to /public/style_emoticons... Written .htaccess to /public/style_extra... Written .htaccess to /public/style_images... Written .htaccess to /hooks... Written .htaccess to /uploads..



After it has written the .htaccess file, it will restrict the "/uploads/inline/upload.php" file from executing.

A) To get this file to execute (and therefore getting this mod to work), delete the .htaccess file from the uploads folder.

I hope this helps the rest of the community.

EDIT: I truly apologize to the developer for the comments I made in this post :logik: - It is in the readme file to check permissions, which is not exactly black and white.

Share this post


Link to post
Share on other sites

I still have same problem, after trying your suggestion of deleting the .htaccess file (from cache and uploads).

Checked my root .htaccess and nothing in there that should be causing problems either.

I also check php.ini and tried a bare-bones version without any functions disabled.

Looking through the source code after the failed upload, this is what it shows.
An Error Has Occured:
[#10CCS2] We could not find the page you were looking for.

To quote bfarber "Basically it means the page requested could not be found".


This mod DOES work on another hosting server I use (for testing) but it is a basic IPS install, so I'm not sure if it's my hosting configuration or some setting I've changed in IPS, or that this mod only works in particular configurations.

Further investigation, a more detailed error:

http://www.mydomain.com/uploads/inline/upload.php?instance=editor_4f56cf8f3458f (replaced my site URL with mydomain.com obviously)

So, at a guess, I have some server restrictions that doesn't allow random strings in URL, or a mod_rewrite messing things up maybe? I have a very similar setup on my other server though.

P.S: Going into ACP > Security Center and running the PHP/CGI protection, which created the .htacess did indeed stop this mod working on my other server. Deleting just the .htaccess file from uploads fixed it. So my problem (possibly same with Kandice) is not caused by the Security Center generated .htaccess files.

Share this post


Link to post
Share on other sites

CPanel > Logs > Error Log:

[Wed Mar 07 16:26:41 2012] [error] [client 203.25.141.5] SoftException in Application.cpp:256: File "/home/censored/public_html/uploads/inline/upload.php" is writeable by group

[Wed Mar 07 14:17:19 2012] [error] [client 203.25.141.5] SoftException in Application.cpp:256: File "/home/censored/public_html/uploads/inline/upload.php" is writeable by group, referer: http://www.mydomain.com/uploads/inline/upload.php?instance=editor_4f56ca8cd1d69



YAY! Thanks for pointing me in the right direction. CHMOD'ed my upload.php file, and then the Uploads folder to 755 instead of 777 and this mod now works!

Share this post


Link to post
Share on other sites

Same error as Freeborne, but finally got mine to work too. Thanks a lot! For anyone who want get this to work, do the following.

CMod Upload folder, Inline Folder, upload.php all to 755. Before I CMod to 777 and it does not work.

Share this post


Link to post
Share on other sites

I think I've confirmed same issue.

I can edit a post, and change the URL of the uploaded image, but I cannot upload another to replace it, or just upload more images.

So once you save, the Upload tab stops working basically.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy