Jump to content

Newsletters


HeadStand

Recommended Posts


Where do you see the word "Weekly"? Are you talking about in the ACP when setting the interval?



No, in two public places: at forum index block (Published weekly) and at "mysite.com/index.php?app=core&module=usercp&tab=newsletter" (Interval)


(congrats and best luck for both :smile: )
Link to comment
Share on other sites

Looks great thanks guys, I see this as maybe an option to also copy the news letter and create a pdf down loadable file and to put it onto file sharing groups as a way to further attract visitors to the site, not sure if that could work but it should not be to hard to convert.

Link to comment
Share on other sites

I just upgraded with the latest version and now when the emails go out, there is not content. This is all they see.




Below are some the hot topics and blogs. Come on over and see what everyone is talking about!



==============================================================




If you no longer wish to receive this newsletter, you may unsubscribe by going to your Control Panel and click



If I preview it in the ACP, it shows the ideal content, but it does not seem to email it.

Link to comment
Share on other sites

Hmm, I know Esther is on maternity just now so she may not respond for a while, but I'm not also getting people telling me (who did receive the newsletter fine previously) that they are not even getting anything from us regarding the newsletter. Again, I got the newsletter fine, but a mixed bag of yahoo/hotmail/gmail users saying they got nothing this week. I've confirmed they are getting ordinary notifications for thread subscriptions, etc, it's just they are not receiving the newsletter anymore, and they haven't unsubscribed.

As it stands just now, I'm having to abandon this mod temporarily and revert to sending mail the IPB way - hopefully once Esther returns from maternity she may be able to spend more time investigating the issue :)

Link to comment
Share on other sites

Yep, I made that change the minute you suggested it Esther - however, I did have a user contact me who hadn't received the email and tell me they did eventually receive it (some 24 hours later) - I've asked them for the header information but as yet I've had no reply - so not really sure what is happening just yet. I sent out a mail using the normal method from the board and everything seemed to go OK.

Link to comment
Share on other sites

Depending on how many members are receiving the email, it is indeed possible that some members may get the newsletter 24 hours later. If I recall correctly, the default configuration is to send 150 emails every 5 minutes. You can adjust this if you have a very large forum - the "150" is a system setting, and the "5 minutes" is based on your task in the System Scheduler.

Getting a blank newsletter is something else, though... but (to my knowledge) the encoding option has always resolved it.

Link to comment
Share on other sites

Well, I've not had anyone report the blank email issue since enabling your recommendation - just some saying they never got the email at all, but I'm going to set up test email accounts on all the major mail providers and sign up to the newsletter, then at least I know if I get the emails delivered to all those addresses, those who are not getting them can contact their respective mail providers and kick up with them !! :thumbsup:

Link to comment
Share on other sites


I just upgraded with the latest version and now when the emails go out, there is not content. This is all they see.






Below are some the hot topics and blogs. Come on over and see what everyone is talking about!



==============================================================




If you no longer wish to receive this newsletter, you may unsubscribe by going to your Control Panel and click



If I preview it in the ACP, it shows the ideal content, but it does not seem to email it.



If my ibfa_search_sessions was crashed, would this have caused the above issue?
Link to comment
Share on other sites

My newsletters have suddenly broken.

All of them have a question mark instead of a trailing slash (after the php)

forum/index.php?topic/109810-illegal-gun-dealer-caught-in-undercover-sting-at-pattaya-petrol-station/

Lots of complains and i have updated to latest version, please help!

Link to comment
Share on other sites


If my ibfa_search_sessions was crashed, would this have caused the above issue?



Nope.


Below are some the hot topics and blogs. Come on over and see what everyone is talking about!



==============================================================




If you no longer wish to receive this newsletter, you may unsubscribe by going to your Control Panel and click



The above looks really odd to me.... I imagine that's a header and footer? The only thing I can think of is that maybe your skin is missing the newsletter templates.
1. Are you using a custom default skin?
2. Can you please check ALL of your skins and verify that the skin_newsletter template group has all of the template bits, and that none of them are empty?


My newsletters have suddenly broken.



All of them have a question mark instead of a trailing slash (after the php)



forum/index.php?topic/109810-illegal-gun-dealer-caught-in-undercover-sting-at-pattaya-petrol-station/



Lots of complains and i have updated to latest version, please help!



Which version of IPB are you running?
Link to comment
Share on other sites


Nope.




Below are some the hot topics and blogs. Come on over and see what everyone is talking about!



==============================================================




If you no longer wish to receive this newsletter, you may unsubscribe by going to your Control Panel and click



The above looks really odd to me.... I imagine that's a header and footer? The only thing I can think of is that maybe your skin is missing the newsletter templates.
1. Are you using a custom default skin?
2. Can you please check ALL of your skins and verify that the skin_newsletter template group has all of the template bits, and that none of them are empty?


Which version of IPB are you running?



the latest one IP.Board 3.3.3
Link to comment
Share on other sites

OK.. it appears that I have two possible templates in my ACP to use. One is the default one, one is blank. The blank one causes the emails to come through with the content. The other causes just the header and footer.

Any way to fix this?

Also, how do you change the logo in the email from the default IPB logo?

Link to comment
Share on other sites

Howdy - I constructed a newsletter using the "events" content type to show upcoming events for the next 30 days. The links provided for each of the events do not actually link to the events themselves, just to the forum page.

This is the format of the links - htt......../index.php?/app=calendar/page__module__calendar__cal_id__4__do__showevent__event_id__187
I am running 3.3.4.

Link to comment
Share on other sites

I apologize for not getting around to posting this sooner.... It's a boy! :)

Baby was born on Monday, July 16th, at 8:35 AM, weighing in at 7 pounds.

I will be taking maternity leave for the next three weeks, returning on Monday, August 13th, on a part-time basis, and for support purposes only. I will be back full-time after Labor Day (Tuesday, September 4th).

Unless it is a critical issue (e.g. a modification is taking down your entire forum), all support issues will be handled - in the order in which they were received - when I return.

Thank you for your patience and your continued support.

Esther

Link to comment
Share on other sites

  • 2 weeks later...

More a recommendation than support request, but it would be good if one of the content options was simply "new content" for a set period of time. For example - my members would like bi-weekly newsletters with just a snapshot of what has been written on the forum over the last couple of days (we have a relatively small dedicated topic forum).

Link to comment
Share on other sites

I guess it really depends on what you're looking for Jinkler, but here's a screenshot of what I have and the code I've amended to get it if it's any use to you or anyone else :smile:

Downloads
post-116929-0-65683500-1344368036_thumb.

skin_newsletter => filesHtml


<div>

  <h3>{$header}</h3>

<div class="file-temp">

<table class='ipbtable' cellspacing="1">

<foreach loop="files:$files as $f">

<tr>

<td width="5%" class="nopad">

<a rel="nofollow" href='{$r['url']}'><img src="http://www.freewarebb.com/index.php?app=downloads&module=display&section=screenshot&id={$f['file_id']}" alt="{$f['title']}" title="{$f['title']}" style="max-width:50px; max-height:50px;" /></a>

</td>


<td width="90%" class="nopad">


<a href='{parse url="app=downloads&amp;showfile={$f['file_id']}" template="idmshowfile" base="public" seotitle="{$f['file_name_furl']}"}'><strong>{$f['file_name']}</strong></a> <if test="showAuthor:|:$params['show_author']"><small>(Added {parse date="$f['file_submitted']" format="long"})</small></if>  <if test="showDownloads:|:$params['show_downloads']"><small>{$f['file_downloads']} Downloads </small></if> <if test="showComments:|:$params['show_comments']"><small>, {$f['file_comments']} Comments</small></if><br />


{$f['file_desc']}

</td>

</tr>

    </foreach>

</div>

</div>

</table>

<br />

Topics post-116929-0-80991300-1344368100_thumb. skin_newsletter => topicsHtml


<div>

  <h3>{$header}</h3>

<ul>

  <foreach loop="topics:$topics as $t">

    <li>

<div class="topic">

      <a href='{parse url="showtopic={$t['tid']}" template="showtopic" base="public" seotitle="{$t['title_seo']}"}'>{$t['title']}</a>


      <if test="showStarter:|:$params['show_starter']"><em>(<small> Started by {$t['starter_name']}: {parse date="$t['start_date']" format="long"}</small>)</em><br/></if>


      <if test="showFirstPost:|:$params['show_first_post']">{$t['post']}<br/></if>


      <if test="showLastPost:|:$params['show_last_post']"><em><small>Last Post by {$t['last_poster_name']}: {parse date="$t['last_post']" format="long"}</em></small></if>

      <if test="showViews:|:$params['show_views']"><em><small>, Views: {$t['views']}</small></em> </if>

      <if test="showReplies:|:$params['show_replies']"><em><small>, Replies: {$t['posts']}</small></em></if>

</div>

    </li>

  </foreach>

  </ul>

</div>


<style>


.topic{

border-bottom: 1px solid #DDD;

padding: 5px;

}


</style> <br />

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...