Jump to content

Newsletters


HeadStand

Recommended Posts

  • Replies 570
  • Created
  • Last Reply

I'll be happy to send the log file soon, sure. But it's neither emailing, or updating the last distributed, just with other people in this thread. It's posting forum threads is all, it should also show us when it's active sending out emails, and how many have been sent, so we get an idea if it's working at all.

So far, it's not working at all whatsoever. So I suggest taking a close look as to why and updating it.

Link to comment
Share on other sites

I have a similar problem to Zyuu. I have it setup to just go to moderators for testing right now.

It generates the post in the thread and it tries to send out emails but when checking the email log it says "Could Not Send Email."

I will say that there are other emails in the log that say the same thing that aren't related to the newsletter extension.

Any help would be appreciated. Attached is a screen shot.
This is the Ip Board error message :
IP.Board Error Message: Could not send the email
SMTP - No info

post-279870-0-09012900-1323257565_thumb.

Link to comment
Share on other sites

OK everyone... I think we got it. :smile:

New version available in the Marketplace. It includes the following changes:

  • Error where last cycle of distributions were not being triggered. Fixed.
  • Enhanced "Back Issues" screen to display total number of expected distributions and number of distributions already sent.
  • Added option to "Back Issues" screen to allow Administrators to manually close an issue.

I am attaching a screenshot of the new "Back Issues" screen. You can access this screen by going to your "Manage Newsletters" screen and selecting "Back Issues" from the dropdown menu on the right.
post-141401-0-11867700-1323268430_thumb.
As you can see, the screen will now show you how many newsletters are expected to be distributed and how many have already been sent. This should give you a better idea as to current status of each issue.

Additionally, if the issue is still open, you will have the ability to manually close it (in case you think there was an error or something got stuck). This will close off the current issue and generate a "next-run" time for the newsletter.

I hope these improvements help. All feedback is appreciated.
Link to comment
Share on other sites


I have a similar problem to Zyuu. I have it setup to just go to moderators for testing right now.



It generates the post in the thread and it tries to send out emails but when checking the email log it says "Could Not Send Email."



I will say that there are other emails in the log that say the same thing that aren't related to the newsletter extension.



Any help would be appreciated. Attached is a screen shot.


This is the Ip Board error message :


IP.Board Error Message: Could not send the email


SMTP - No info



post-279870-0-09012900-1323257565_thumb.

Email errors are unrelated to the Newsletter itself - the Newsletter calls IPB's email functionality and IPB handles the actual email.

It is expected that when triggering a mass distribution (like a Newsletter), there will be a small percentage of errors, as not everyone enters a valid email address, some addresses have changed, etc. If, however, every single email is failing, I strongly suggest that you re-check your IPB email settings. If that doesn't work, you'd best open a ticket with IPS.
Link to comment
Share on other sites


Email errors are unrelated to the Newsletter itself - the Newsletter calls IPB's email functionality and IPB handles the actual email.



It is expected that when triggering a mass distribution (like a Newsletter), there will be a small percentage of errors, as not everyone enters a valid email address, some addresses have changed, etc. If, however, every single email is failing, I strongly suggest that you re-check your IPB email settings. If that doesn't work, you'd best open a ticket with IPS.




Thanks HeadStand.
As I'm only sending to moderators right now, each and every email to them failed. Even the one that was being sent to me. I know all of those email addresses are valid.
I've opened a support ticket to try to figure this out.
Link to comment
Share on other sites


I am attaching a screenshot of the new "Back Issues" screen. You can access this screen by going to your "Manage Newsletters" screen and selecting "Back Issues" from the dropdown menu on the right.


post-141401-0-11867700-1323268430_thumb.

As you can see, the screen will now show you how many newsletters are expected to be distributed and how many have already been sent. This should give you a better idea as to current status of each issue.



Additionally, if the issue is still open, you will have the ability to manually close it (in case you think there was an error or something got stuck). This will close off the current issue and generate a "next-run" time for the newsletter.





Would be nice if IPS had something like this for bulk emails, maybe you should write a hook for this? ;)
Link to comment
Share on other sites

Lower the price, I will purchase then. At $30 this is a very expensive addon. I would value it at $15. I guarantee you more people would buy it at that price and your profit would be greater. At the time, not buying until it becomes more affordable.

Link to comment
Share on other sites


Lower the price, I will purchase then. At $30 this is a very expensive addon. I would value it at $15. I guarantee you more people would buy it at that price and your profit would be greater. At the time, not buying until it becomes more affordable.




Sorry, the price for this mod is not coming down.

Profit is not only judged by the number of purchases, it's also by how much time has been invested, how much is required for support, and how much my time is worth (meaning, how much can I charge if I were working directly for a client as opposed to working on this mod)? $15 is just not worth it for this particular mod.
Link to comment
Share on other sites

I do not have a problem with the price of this mod. As a comparison of high quality - similarly complex mods from Michael and Michael John - this one fits right in.
Since it is new there will be bugs and so far the author has been extremely good about fixing the bugs and adding needed features without additional charge.
A good investment in my opinion.

Link to comment
Share on other sites


Hmm, so it decided to send a very old newsletter which I made over 10 days ago. -_- It didn't send out the latest one though, it just sits there, saying it hasn't sent out any.



That makes sense... it will do the oldest pending issue first.

Try manually closing all the issues except the one you want to send. See if that works.
Link to comment
Share on other sites


I do not have a problem with the price of this mod. As a comparison of high quality - similarly complex mods from Michael and Michael John - this one fits right in.


Since it is new there will be bugs and so far the author has been extremely good about fixing the bugs and adding needed features without additional charge.


A good investment in my opinion.




I'm still planning on purchasing this too, but I'm simply waiting until the bugs are fixed - I just have too much happening at the moment to become involved in bug reports :smile:




Price is fine. I'm going to try the new version in a minute, will let you know how it works.




Thanks to all of you for your show of support. :)
Link to comment
Share on other sites

I tried this:

- Closing all issues except the one I want to send
- Re-making the newsletters completely
- Deleting the app and its files and re-installing it

However, it still haven't sent out the newsletter as I've set them up. Unfortunately.

Link to comment
Share on other sites

Newsletter went out last night without a hitch.
Here's what I did:
1) Changed from PHPMail to SMTP
2) Change from Text Mail to HTML mail.
3) Started a new newsletter from scratch

There was a problem with the PHP Mail headers - probably not from this mod but who knows.

One problem though - if we allow BBcode in the forum it's not parsing before being sent as an HTML email. Here's an example directly from my emailed newsletter

Started by DaGreatGazoo on Yesterday, 04:54 PM


I can't find any video, so if someone does, please post. [color=#000000][font=Verdana, Arial, Helvetica, sans-serif][size=2] Oilers defenceman Andy Sutton has been suspended indefinitely by the NH...



Views: 9 Replies: 1



Not pretty as you can tell. Not allowing BBcode isn't really an answer to the problem. Any help on this would be great before I put this into production.
Link to comment
Share on other sites


I tried this:



- Closing all issues except the one I want to send


- Re-making the newsletters completely


- Deleting the app and its files and re-installing it



However, it still haven't sent out the newsletter as I've set them up. Unfortunately.



Sorry for the delay, it's been a crazy week.

Have ANY distributions been sent out? When you look at the Back Issues screen, what does it say? Total number of distributions? Total distributions sent?

Beyond that, I really really REALLY need to see a log file. Or get ACP access. Otherwise all I can do is take completely random guesses, which isn't really very helpful. :(
Link to comment
Share on other sites

  • 3 weeks later...

I'm receiving the following error when I access mysite.com/index.php?app=core&module=usercp&tab=newsletter


Fatal error: Call to a member function usercpNewsletters() on a non-object in /home/***/public_html/***/admin/applications_addon/other/newsletter/extensions/usercpForms.php on line 209



Please let me know how I should proceed.

Link to comment
Share on other sites





Fatal error: Call to a member function usercpNewsletters() on a non-object in /home/***/public_html/***/admin/applications_addon/other/newsletter/extensions/usercpForms.php on line 209



Please let me know how I should proceed.


Did you create a newsletter? I think you get that if there are no newsletters.
Link to comment
Share on other sites





Fatal error: Call to a member function usercpNewsletters() on a non-object in /home/***/public_html/***/admin/applications_addon/other/newsletter/extensions/usercpForms.php on line 209



Please let me know how I should proceed.


Looks like your skin templates are missing, let's try rebuilding them.

1. Login to the ACP
2. Go to Look & Feel -> Template Tools
3. Under "Rebuild Master Skin Data", check "Rebuild HTML" and check "[HSC] Newsletters"
4. Press "Rebuild"

Let me know if that helps.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...