Jump to content

Newsletters


HeadStand

Recommended Posts

Hello



I bought your mod and thought it maybe will work on 3.4.1 as well but unfortunality it won't. In other apss nothing appears of newsletter not even the name.



Question is can we except a version for 3.4.1 or do you know a solution for my problem so it's maybe working.



DD


If nothing is showing under Other Apps, then the application is not actually installed.

What do you see when you go to System -> Applications & Modules -> Manage Applications & Modules? Is [HSC] Newsletter listed under "Installed Applications"?
Link to comment
Share on other sites

I'm having an issue.

The


{unsubscribe}


tag doesn't work. It just shows up exactly as it appears above in both HTML and Plain Text formats.

How can I resolve this?

P.S. Sorry for posting this originally in the wrong thread...I didn't do it intentionally just thought I was in the correct thread since I was reading both threads and didn't notice I was in the wrong thread.

Link to comment
Share on other sites

I'm having an issue.

The



tag doesn't work. It just shows up exactly as it appears above in both HTML and Plain Text formats.

How can I resolve this?


P.S. Sorry for posting this originally in the wrong thread...I didn't do it intentionally just thought I was in the correct thread since I was reading both threads and didn't notice I was in the wrong thread.


No worries. Thanks for re-posting!

So, for the issue itself... perhaps a dumb question, but are you looking at the preview or at an actual email? Also, are you running the latest version?
Link to comment
Share on other sites


So, for the issue itself... perhaps a dumb question, but are you looking at the preview or at an actual email? Also, are you running the latest version?

Just upgraded to the latest version, running on 3.4.........the tag didn't work in either versions, in either the preview mode and actual email.

Link to comment
Share on other sites


Just upgraded to the latest version, running on 3.4.........the tag didn't work in either versions, in either the preview mode and actual email.


It seems that in 3.4, IPB started putting their own unsubscribe flag into emails, but it looks slightly different than mine. My tag is
{unsubscribe}
while theirs is
<#UNSUBSCRIBE#>

As far as I can see, my tag is being replaced properly, while theirs was not. I have uploaded a new version to the Marketplace. It includes a fix for this.

As for preview mode... that flag will never be replaced in preview mode, as it's generated during distribution. Hope this helps.

Can the developer release a new version / confirm the compatability with 3.4.1?


Done. Just uploaded a new version to the Marketplace.
Link to comment
Share on other sites

  • 2 weeks later...

I purchased this add-on about a month ago and am now trying to get it working for my needs. All seems fine so far but I do have a couple questions....

1. Is there a way to publish a newsletter without it creating a topic in the forum?

2. Where do I go to edit the graphic/logo used at the top of the html newsletters?

Thanks in advance.

Link to comment
Share on other sites

Hi! I am setting up your app and so far so good. run to some hardcoded phrases in the templates.

See photo. is the text Started by, Uploaded by etc , seems they are all hardcoded or i cant find them

Check the skin templates. In the ACP, go to Look & Feel -> Skin -> skin_newsletter. There are different templates for each content type (e.g. eventsHtml, blogsHtml).

I purchased this add-on about a month ago and am now trying to get it working for my needs. All seems fine so far but I do have a couple questions....

1. Is there a way to publish a newsletter without it creating a topic in the forum?

2. Where do I go to edit the graphic/logo used at the top of the html newsletters?

Thanks in advance.

1. Yes. When you edit the newsletter, the "Properties" tab has a setting called "Forum". The dropdown list should have a blank option (the first option in the list). If no forum is selected, no topic will be created.

2. admin/applications_addon/other/newsletter/templates.
You can edit the default template (defaultTemplate.php) or create your own. More detailed instructions on this can be found in the documentation that is distributed with this mod (NEWSLETTER.pdf).
Link to comment
Share on other sites

AS I understand that there has to be forum interaction in order for mass emails to be sent out, does that also apply for the Newsletter? My newsletter doesn't seem to be sending out. I went to back issues to see how many have been sent out and there's 0 sent out.

What can I check to ensure the newsletter is being sent out. It's already enabled.

Ben

Link to comment
Share on other sites

Hello,
Is there anyway to decrease the large space between topics in the newsletter?

Ben


You can try editing the skin templates (I think the one you're looking at here is skin_newsletter - filesHtml but I don't remember off the top of my head). You can probably remove some of the line breaks in there, that should help.
Link to comment
Share on other sites

HI all, I'm using the newsletter again after a while and the previous custom templates I was using seems to work OK but there is an odd problem. When I add more than 3 sections to the newsletter (i.e. Latest Downloads, Latest Topics, Hot Downloads and Hot Topics), the third heading is always missing, the content shows, just the heading isn't there!. When I revert the template bits and use the defaults, everything is fine, well with the headings anyway but I don't like the way things are formatted which is why I'm trying to use my own custom templates ... so, if anyone can spot an issue with my code below I'd really appreciate some assistance :)

Thanks in advance

Marko

filesHtml

<div>
  <h3>{$header}</h3>
<div class="file-temp">
<table class='ipbtable' cellspacing="1">
<foreach loop="files:$files as $f">
<tr>
<td width="5%" class="nopad">
<a rel="nofollow" href='{$r['url']}'><img src="http://www.freewarebb.com/index.php?app=downloads&module=display&section=screenshot&id={$f['file_id']}" alt="{$f['title']}" title="{$f['title']}" style="max-width:50px; max-height:50px;" /></a>
</td>


<td width="90%" class="nopad">


<a href='{parse url="app=downloads&amp;showfile={$f['file_id']}" template="idmshowfile" base="public" seotitle="{$f['file_name_furl']}"}'><strong>{$f['file_name']}</strong></a> <if test="showAuthor:|:$params['show_author']"><small>(Added {parse date="$f['file_submitted']" format="long"})</small></if>  <if test="showDownloads:|:$params['show_downloads']"><small>{$f['file_downloads']} Downloads </small></if> <if test="showComments:|:$params['show_comments']"><small>, {$f['file_comments']} Comments</small></if><br />


{$f['file_desc']}
</td>
</tr>
    </foreach>
</div>
</div>
</table>
<br />
 

topicsHtml

<div>  <h3>{$header}</h3>
<ul>
  <foreach loop="topics:$topics as $t">
    <li>
<div class="topic">
      <a href='{parse url="showtopic={$t['tid']}" template="showtopic" base="public" seotitle="{$t['title_seo']}"}'>{$t['title']}</a>


      <if test="showStarter:|:$params['show_starter']"><em>(<small> Started by {$t['starter_name']}: {parse date="$t['start_date']" format="long"}</small>)</em><br/></if>


      <if test="showFirstPost:|:$params['show_first_post']">{$t['post']}<br/></if>


      <if test="showLastPost:|:$params['show_last_post']"><em><small>Last Post by {$t['last_poster_name']}: {parse date="$t['last_post']" format="long"}</em></small></if>
      <if test="showViews:|:$params['show_views']"><em><small>, Views: {$t['views']}</small></em> </if>
      <if test="showReplies:|:$params['show_replies']"><em><small>, Replies: {$t['posts']}</small></em></if>
</div>
    </li>
  </foreach>
  </ul>
</div>


<style>


.topic{
border-bottom: 1px solid #DDD;
padding: 5px;
}


</style> <br />
 
Link to comment
Share on other sites

  • 2 weeks later...

It would be nice if none members could be able to subscribe.

If this did that it would allow me to take a better control of my audience who visit my site. I struggle to compete against a popular long established site that only my interactions are combating. This would give me another edge and something I'd personally buy if it did. (otherwise I can use the inbuilt system)

Link to comment
Share on other sites

HI all, I'm using the newsletter again after a while and the previous custom templates I was using seems to work OK but there is an odd problem. When I add more than 3 sections to the newsletter (i.e. Latest Downloads, Latest Topics, Hot Downloads and Hot Topics), the third heading is always missing, the content shows, just the heading isn't there!. When I revert the template bits and use the defaults, everything is fine, well with the headings anyway but I don't like the way things are formatted which is why I'm trying to use my own custom templates ... so, if anyone can spot an issue with my code below I'd really appreciate some assistance :smile:
Thanks in advance
Marko

Not sure if this is it... but in your filesHtml, your closing tags are out of order. Your closing table tag should be right after your closing foreach.
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...