Jump to content

Beware if upgrading to 3.2.3 You need PHP5.2.0+


tenaki

Recommended Posts

I have submitted a ticket about this but I think people should be aware

My community suite was upgraded by Invision to 2.2.2 around Sept time and apart from some server downtime all the functions worked as expected.

On Monday Invision upgraded to 2.2.3 and since then gallery doesn't work, you can't edit posts and as yet not sure what else won't work.

I have been told that my php version doesn't meet the requirements for Invision which would mean that between versions 2.2.2 and 2.2.3 the minimum requirements for php must have changed.

I could and probably have missed something but looking at the announcements re upgrades/updates I don't see this mentioned

For me this is a bit of a headache because I now need to pay my host to upgrade my Plesk from 8 to 9 if I had known I would have held off upgrading to 2.2.3 but there were so many bug fixes for 2,.2 that I thought it was worth it.

Anyway please check before getting Invision to upgrade and if anyone knows when the minimum requirements were changed I would be gratefull

Link to comment
Share on other sites

It does list php 5.2. on the requirements page :smile: , I'm not sure if that's been updated recently or has been that way for a while:


[size=3]Minimum Requirements[/size]

  • PHP 5.2.0+
    • GD2 Extension
    • SPL Extension
    • DOM XML Extension



    • PHP 5.2+
      • GD2 Extension
      • SPL Extension
      • DOM XML Extension
      • JSON Extension


[*]MySQL 4.1+ [*]IP.Nexus requires Zend Optimizer or IonCube

[/list]

[size=3]Recommended Requirements[/size]

[*]MySQL 5+ [*]IP.Nexus requires Zend Optimizer or IonCube

[/list]

Link to comment
Share on other sites


2.x series is quite old.



I doubt people will be upgrading to it. That would be like warning people about upgrading to Windows 98 today.




I am assuming he indeed meant the current v3.x series

On Monday Invision upgraded to 2.2.3 and since then gallery doesn't work


as it would seem IPS did the update for him.

If that is the case, the IPS staff member in question should have noted the requirements warning in the update window, you know the page that displays as a check before you proceed with an upgrade.
At that point, the upgrade should have been aborted and the customer informed.

RSVP if I got any of that incorrect.

Richard.
Link to comment
Share on other sites


On Monday Invision upgraded to 2.2.3 and since then gallery doesn't work, you can't edit posts and as yet not sure what else won't work.



2.x series is quite old.



I doubt people will be upgrading to it. That would be like warning people about upgrading to Windows 98 today.



Not only that, but 2.2.x. Before going to 3.0.x, I was on 2.3.x. So yeah, way old.
Link to comment
Share on other sites


I am assuming he indeed meant the current v3.x series



as it would seem IPS did the update for him.



If that is the case, the IPS staff member in question should have noted the requirements warning in the update window, you know the page that displays as a check before you proceed with an upgrade.


At that point, the upgrade should have been aborted and the customer informed.



RSVP if I got any of that incorrect.



Richard.



...ouch 0-o
Invision Doesn't perform upgrades to 2.x....... :logik:
My suspect is this....>.<
Link to comment
Share on other sites


Yes as I thought so why is it only now after upgrading to the very latest version am I being told I don't meet minimum requirements




A game I play "requires" 512 MB of VRAM. My video card has 256. I play it anyway. I'm sure a similar game with the same requirement would refuse to even start.
Link to comment
Share on other sites

in frank honesty
not only does that minimum requirement basically mean if a function is used that isnt existent in a lower version your borked, but any mods you use that use any of these functions (or the IPS derivatives thereof)are as well....
how have you managed to float by like that? as Jay states, PHP 5.2 has been a minimum since well before 3.2.0

Link to comment
Share on other sites

Oh well my mistake, I thought they would have noticed by now when upgrading for me.

So whatever functions have been added in 3.2.3 must have knocked it out.Have been running PHP v5.1.6

So far I am only aware of the gallery not working and edit post not working, dare say there will be more though just wish I had stuck with 3.2.2 but........

Link to comment
Share on other sites

I just wanted to end this post with an apology to the team. Sometimes running a community can be quite fraught if you are having a run of various issues, server and/or software issues and if you get both at the sametime you sometimes can't see the wood from the trees. This was happening when I posted this and it was born out of frustration a lot of which is clear to the experts but not so clear to the layman.

So apologies

Link to comment
Share on other sites


Sorry guys, but PHP 5.2.0 was released exactly FIVE years ago. I wonder that someone still uses an older version.



Dang, you beat me to it.

I was about to say the same exact thing. You would get yelled at by about any PHP developer for running anything bellow 5.2 at this point.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...