Jump to content
Announcing Achievements! ×

Community

(TB) Group Format


teraßyte
 Share

Recommended Posts

  • Replies 186
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

File Name: (TB) Group Format File Submitter: tera

You can do some tweaks to the 4.1.1 version's XML file and then import it and it'll work without issues (at least none I've noticed so far) on 3.4.3 Open the xml file and find "public function profi

New 4.1.0 version released:

Posted Images

  • 3 weeks later...

Just came across this issue on a clients 3.3.1.



If the user is a Partial User (signed up with fb/twitter), with no display name the formatted group name is placed in the place of where the name should be. This can be confusing.



Without the hook enabled: [img]

[/img]



With the hook enabled: [img]

[/img]



(ticket id #804634 for reference)



Have fun with that one :D



Fixed, 1 more bug to go and I'll release later today.
Link to comment
Share on other sites

New 4.1.0 version released:

  • Hook is now compatible ONLY with IP.Board 3.3.0+, however, it works best with IP.Board 3.3.3 which contains fixes for some areas
  • Removed several workarounds from the previous versions since IP.Board 3.3.x already contains the proper fixes
  • Fixed forum view not showing properly the formatted names on 3.3.0-3.3.2
  • Fixed topic history/logs not showing the formatted names
Link to comment
Share on other sites

You missed a variable in the tabFriends function in tbGfSkinProfile:


, $pagination=''

if it ain't added people will get this line added to an error_log in the root forum folder:


PHP Strict Standards: Declaration of tbGfSkinProfile::tabFriends() should be compatible with that of skin_profile_1::tabFriends() in /forums/ADMIN_FOLDER_NAME/sources/classes/output/publicOutput.php(3526) : eval()'d code on line 59

I removed my admin folder name, so that'll of course be different.. The tabFriends function should look like this:


public function tabFriends( $friends=array(), $member=array(), $pagination='' )

{

$member['members_display_name'] = IPSMember::makeNameFormatted( $member['members_display_name'], $member['member_group_id'] );


if ( count($friends) )

{

foreach( $friends as $fid => $fdata )

{

$friends[ $fid ]['members_display_name'] = IPSMember::makeNameFormatted( $fdata['members_display_name'], $fdata['member_group_id'] );

$friends[ $fid ]['members_display_name_short'] = IPSMember::makeNameFormatted( $fdata['members_display_name_short'], $fdata['member_group_id'] );

}

}


return parent::tabFriends( $friends, $member, $pagination );

}

Link to comment
Share on other sites

I have just installed this hook and it appears that its not working on the skin that I'm using. I have a few skins installed on my board and on some of the skins it's showing but only in the board index and not in the rest of it.

I'm running ipb 3.3.1 and I have checked if the skins that I'm using are are updated and they seem to be.

Link to comment
Share on other sites

@Cabola and everyone else: I have just released a new version of the hook which fixes the pagination issue.


I have a question...is there a way to limit this to certain areas? I'd like for this to not work on the board index due to it not looking right on a scroll I am using on my board index. I want it everywhere else...just not on the board index. Any adjustment I could make?


A quick correction. I am only wanting this not to show on the recent topics hook that shows on the board index. Any way to just shut it off there and leave it everywhere else?


There is no option like that right now but I do have plans already on adding a setting for this. I'll probably do so for the next major rewrite I'm planning, I have no estimate for the release though.


I have just installed this hook and it appears that its not working on the skin that I'm using. I have a few skins installed on my board and on some of the skins it's showing but only in the board index and not in the rest of it.



I'm running ipb 3.3.1 and I have checked if the skins that I'm using are are updated and they seem to be.


Which skins are you having trouble with exactly? The hook is coded on the default skin so if those are significantly different it might not work. I can try to have a look at those skins locally if you provide me the links to download them but I make no promises on a solution just yet. If the skins you're using are paid ones it is probably a good idea to contact the skinner, anyway you'll have to ask him for permission to provide me the skin to test it in any case.
Link to comment
Share on other sites


@Cabola and everyone else: [color=#ff0000]I have just released a new version of the hook which fixes the pagination issue[/color].


Was that the only thing you changed in this release because if that's so then I don't need to update as I changed it my self when I reported it ;)



On all the skins I have its not working properly. The skins are all purchased from Evanescence at IBSkin.com.


Even on the default skin of IPB its not showing on forum view. Just like on some of the other skins.


And you downloaded the right version right? The one for 3.3 right? Because there's 2 versions, one for 3.2 and one for 3.3
Link to comment
Share on other sites


On all the skins I have its not working properly. The skins are all purchased from Evanescence at IBSkin.com.


Even on the default skin of IPB its not showing on forum view. Just like on some of the other skins.


IBSkin/Evanescence doesn't provide the "default skin of IPB" so I'm not sure what that is. However, if you are a customer of IBSkin then open a support ticket in your Client area on ibskin.com and provide the URL to your ACP and a username/password that gives access to Look & Feel.

It would be helpful to know what version of board you have and what version of this mod you have so we're singing from the same hymn sheet.
Link to comment
Share on other sites


On all the skins I have its not working properly. The skins are all purchased from Evanescence at IBSkin.com.


Even on the default skin of IPB its not showing on forum view. Just like on some of the other skins.




I have the same problem on the Infusion skin from Evanescence at IBSkin.com after installing the 4.1.1 version. It worked fine with the previous version. On another skin from her all is shown fine.




Unfortunately without taking a look at the skin I have no way to tell what is wrong, ask Evanescence if you can provide me a copy of the skin for testing purposes and if she accepts PM me a copy of it.


Was that the only thing you changed in this release because if that's so then I don't need to update as I changed it my self when I reported it ;)


Yes that's the only fix, but I suggest you to upgrade to it anyway so that the version checker won't report a new version available ;)
Link to comment
Share on other sites


I have found the reason why this hook was not working on my board.


I had

-RAW33- New topics 1.1.0

installed on my board and after disabling it, this 'group format' hook did actually work.


So both hooks inflicted each other.




Thanks for letting me know, I'll have a look at this hook and let the author know in case there is anything that needs to be changed.


Hi tera, there is a problem in the status update hook in the board index.

http://puu.sh/LPba

in the replies of status the groups aren't formatted.



Are you sure the templates of your skin are properly updated? The template was changed in a minor 3.3.x release (can't remember which one exactly) to use the template "userHoverCard" for the reply author which should automatically format the name.

%7Boption%7D
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy