Jump to content

Our Forums


Marcher Technologies

Recommended Posts

%7Boption%7D



File Name: Our Forums

File Submitter: Marcher Technologies

File Submitted: 22 Sep 2011

File Category: Other style options



This Block will allow you to replicate the IPB Forum Index Category/Forum/Sub-Forum List.
If used within IPB/IPC, it functionally remembers each Forum Categories Minimized/Maximized state for the Currently Viewing Member, as well as allowing the Same Maximize/Minimize functionality.
This block Cleverly re-uses the stock boardIndexTemplate and native controller methods, ensuring upgrade survivability, maximum version compatibility, and a proper full forums index shown.
If You Have ever Wanted Your Forum Index, or a single/multiple Forum categories index to be Available "Elsewhere", This Block Is For You.
Inclusion of a Live External usage DEMO in the readme.html with accompanying CSS, to make it fairly easy to use this Block Anywhere.



here to download this file

Link to comment
Share on other sites

  • 2 weeks later...
  • Replies 61
  • Created
  • Last Reply

I think this is an under-rated block. This allows websites to really integrate the forums into their 'frontpage', give each forum it's own IPC page with unique colours and blocks, etc.

A few issues however:
- The forum icons do not appear on the left of each forum.
- User profile on hover does not work.

Link to comment
Share on other sites

  • 3 weeks later...

I think this is an under-rated block. This allows websites to really integrate the forums into their 'frontpage', give each forum it's own IPC page with unique colours and blocks, etc.



A few issues however:


- The forum icons do not appear on the left of each forum.


- User profile on hover does not work.



#1 im going to see about plausibility
#2.
are you using this from a separate domain?
if so im surprised thats the only bit not working.
cross-domain browser/cookie limitations...
actually if i recall the same reason i did not include the unread links/read image regarding #1....
it simply would not work.... i made it as feature-rich as i deemed could be mostly fully functional cross-domain....
because i absolutely expected someone would embed it outside their domain.
Link to comment
Share on other sites

Hmm. Interesting. I never thought about sharing the widget code to show my forums on 3rd party sites.

I was thinking to use it to create a custom page in IP.Content that shows 2 or 3 forums for a specific genre/category. Then that page could have custom blocks on the sites, bit of custom CSS, etc. That's how I thought most people would use it, because we can't really edit our forum index very easily, but IP.Content pages are more customization.

Link to comment
Share on other sites


Hmm. Interesting. I never thought about sharing the widget code to show my forums on 3rd party sites.



I was thinking to use it to create a custom page in IP.Content that shows 2 or 3 forums for a specific genre/category. Then that page could have custom blocks on the sites, bit of custom CSS, etc. That's how I thought most people would use it, because we can't really edit our forum index very easily, but IP.Content pages are more customization.



please link me to the hovercard going bork.
http://www.marchertech.com/forums
it shouldnt be if you arent running ipc or the block somewhere unique.
Link to comment
Share on other sites

  • 2 weeks later...
  • 5 months later...

Hi -



Clicked on the demo link and all I see is one row of recent gallery images. Is that intentional? I guess I had expected to see a replication of

http://www.marchertech.com/board/

or, as usual, am I missing something altogether?



Thanks,



Brian



thanks for that :) http://community.invisionpower.com/tracker/issue-37145-forums-feed-honor-forum-permissions/
Hence why my block ninjaed on me, messed with the config... is fixed for the moment.
Link to comment
Share on other sites


Could this be used to pull say 1 forum category into a page rather than all categories?




wow, I like that idea! I could use that concept on various pages of our website that are external to the ip board. Taking that thought a little further, could this be used to pull one 1 forum from 1 category? I interpreted your question as pulling 1 category.

oh wait, I think you just answered my question as I hit post!
Link to comment
Share on other sites

  • 1 month later...

Have a slight problem.

As soon as I filter out a forum from the block, the block does not work, or show any forums on the page that I am using it on. Also, once highlighting a forum in the Blocks, Step 4, Filters section, I cannot remove that highlight from the Forums selection box. I can move it, but one forum always remains highlighted. See attached grab below:

post-193990-0-39187300-1339662448_thumb.

Can you help?

Link to comment
Share on other sites


I have got rid of the code showing, but cannot get any forum to show, be it sub forum, or primary forum.



some thing to check in the block configuration... are you honouring forum permissions? the linked bug threw me for a loop on that...
You may wish to ss your block configuration that I may better help to find the issue... That block's demo is factually embedded in the read-me functional... :unsure:
Link to comment
Share on other sites

I have tried honouring forum permissions, and disabling them, neither make any difference. To cap it all, my articles currently on the front page will no longer open. I have deleted the block, and reinstalled, still no change, so I am currently at a loss with what to do, and need to try to get the articles to open as priority.

Link to comment
Share on other sites


I have tried honouring forum permissions, and disabling them, neither make any difference. To cap it all, my articles currently on the front page will no longer open. I have deleted the block, and reinstalled, still no change, so I am currently at a loss with what to do, and need to try to get the articles to open as priority.



Submit a ticket, I do not know what is occurring on your install, but i highly doubt by the description it has anything to do with this block.
Link to comment
Share on other sites

You are right, it wasn't this block, I did some searching through the forums and found it was the page cache. Checked that this was not the case with the page that I have the Our Forums block, and it isn't.

So, back to square one.

Under Block configuration I have the following steps: [*]Block details as default [*]Content Type as Forums [*] [*]<if test="count($records)"> {parse js_module="board"} <php> $this->_lang = $this->registry->getClass('class_localization')->loadLanguageFile( array( 'public_boards' ), 'forums' ); /**THIS IS WHY we need subforum array $vars!!!**/ $this->_cat = array(); $this->_forum = array(); $this->_subforum = array(); $this->_subsubforum = array(); $this->_outersubs = array(); $this->_innersubs = array(); /**getting the categories**/ foreach($records as $r) { if($r['parent_id']=='-1') { $this->_cat[] = $r; } } /**getting their forums**/ foreach($this->_cat as $c) { foreach($records as $r) { if($r['parent_id']==$c['id']) { $this->_forum[] = $r; } } } /**getting their subforums**/ foreach($this->_forum as $f) { foreach($records as $r) {<div id='category_{$c['id']}' class='category_block block_wrap'> <h3 class='maintitle'> <a class='toggle right' href='#' title="{$this->lang->words['toggle_cat']}">{$this->lang->words['toggle_cat']}</a> <a href="{parse url="showforum={$c['id']}" seotitle="{$c['name_seo']}" template="showforum" base="public"}" title='{$this->lang->words['view_cat']}'>{$c['title']}</a> </h3> <div class='ipsBox table_wrap'> <div class='ipsBox_container'> <table class='ipb_table' summary="{$this->lang->words['forums_in_cat']} '{$c['name']}'"> <tr class='header hide'> <!--no read/unread $var available--> <th scope='col' class='col_c_forum'>{$this->lang->words['cat_name']}</th> <th scope='col' class='col_c_stats stats'>{$this->lang->words['stats']}</th> <th scope='col' class='col_c_post'>{$this->lang->words['last_post_info']}</th> </tr><a href="{parse url="showforum={$f['id']}" seotitle="{$f['name_seo']}" template="showforum" base="public"}" title='{$this->lang->words['go_to_forum']}'> {$f['title']}</a> </h4> <ol class='ipsList_inline ipsType_small subforums' id='subforums_{$f['id']}'><foreach loop="$this->_subsubforum as $sub"> <if test="$sub['parent_id']==$s['id']"> <li> <a href="{parse url="showforum={$sub['id']}" seotitle="{$sub['name_seo']}" template="showforum" base="public"}" title='{$this->lang->words['go_to_forum']}'>{$sub['title']}</a> </li> </if><a href='{parse url="showuser={$f['last_poster_id']}" template="showuser" seotitle="{$f['seo_last_name']}" base="public"}' class='ipsUserPhotoLink'> {IPSMember::buildProfilePhoto( $f['last_poster_id'], 'mini')} </a> </div> </if> <ul class='last_post ipsType_small'> <if test="!$f['last_id']"> <li class='desc lighter'><em>{$this->lang->words['f_none']}</em></li> <else />

[*]Forums checked




post-193990-0-96037000-1339730365_thumb.































































Link to comment
Share on other sites


is that the code upon editing the block? if so, are you using the CKE as a template editor? [color=#ff0000]Are the parents of that forum selected all the way up?[/color]




And therein lay the problem! Thank you for your patience and assistance! Now, one question (which will give away how little I know), what on earth is the CKE? :smile:

Is there a way that I can create a new forum parent, with a new forum within, but hide it from the main Forums, and have it show in a separate tab by using the Our Forums block in IP Content?

In effect, this would then allow me to have a second forum within the site, that could deal with a different subject. Would this be possible?
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...