Jump to content

Minimum Characters/Words in Posts/Threads


NenaDice

Recommended Posts

%7Boption%7D



File Name: Minimum Characters/Words in Posts/Threads

File Submitter: NenaDice

File Submitted: 05 Sep 2011

File Category: Utilities

Supported Versions: IP.Board 3.4.x



This application will set a minimum of characters and/or words limit in posts/topics. You can exlude also exlude groups from the charatcers/word limit.

The Characters/Word restrictions can be set separately on a forum per forum basis.

Installation and Configuration:

To install this application, upload the admin folder inside the Upload folder to the root of your forum folder. Then go to your Admin Panel->Applications & Modules->Manage Applications & Modules and on the right side where it says: Applications Not Installed you will see a new application added called: Extra Forum Permissions. Click on the install button.

To configure it go to the Forums tab then from the drop down list choose Manage Forums. Then choose the forum and/or the forums where you want to apply the extra permissions, click the edit button and you will see an extra tab added there called: Minimum Characters Words. Click it and set the values to your likings.

To exclude groups from the Characters/Word restrictions, go to the Members tab then from the drop down list choose Member Groups->Manage Member Groups. Then choose the group and/or the groups that you want to exclude groups from the permissions restrictions. Click the edit button and you will see an extra tab added there called: Minimum Characters Words. Click it and exclude that group from the Characters/Words restrictions.


The 3.1x version can be found here:

http://community.inv...n-poststhreads/



here to download this file

Link to comment
Share on other sites


When i reply to a topic with less words than the limit i get on a pop up window the following message:



An error occured:


nenadice_not_enough_chars




It doesn't show the language bit





Can you please uninstall it and re-install it again? it looks like somehow one language string was not added at your forum. I just checked the mod again at a fresh forum and I can not reproduce it. I am also using this at 2 forums without any issue at all.
Link to comment
Share on other sites


I did as you said twice without any good result... Also i checked on languages and i saw that the language bits are present.. any other idea?




If the language strings are added properly then it should have been displayed ok. Maybe something is conflicting with it. Where does it do that exactly, when replying from the quick reply? If you want me to have a look, I would need admin log in info for your forum and possibly ftp access as well.

P.s. can you redownload the package once again please and give it another try first and see how it will go?
Link to comment
Share on other sites


I have uninstalled the app - downloaded again - reinstalled.



On reply everything is good.. but in quick reply still the same issue.




In that case, would you mind giving me access to your Admin Panel and ftp so I can check it for myself?



I bought the version for 3.1x 2 weeks ago and now that we are upgrading our IPB we will be needing the newer version. Is their a possibility we could DL it without purchasing it again? sorry if I'm asking in a wrong forum




Yes, I am afraid that you will have to buy again this application for the 3.2x version because this was a total rewrite and submitted as a new item.
Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

I just opened hooks.xml and replaced all instances of "nenadice_not_enough_words" with something like "You have not entered enough words, please leave at least 100 words", obviously edit the message to suit. hooks.xml is found in "admin/applications_addon/other/mincharwords/xml/hooks" - once you've edited the file, upload it, uninstall the app then reinstall. Not really impressed with the support for this file if I'm honest - the developer isn't even following their own support topic, shame really cause it's a worthwhile mod let down :cry:

Link to comment
Share on other sites


I just opened hooks.xml and replaced all instances of "nenadice_not_enough_words" with something like "You have not entered enough words, please leave at least 100 words", obviously edit the message to suit. hooks.xml is found in "admin/applications_addon/other/mincharwords/xml/hooks" - once you've edited the file, upload it, uninstall the app then reinstall. Not really impressed with the support for this file if I'm honest - the developer isn't even following their own support topic, shame really cause it's a worthwhile mod let down :cry:




This mod is fully supported. As I already explained above about the language issue, I can not reproduce it and I can not fix something that I am not seeing. The Marketplace moderaors could not reproduce this either when they checked the application before they approved it btw.
Link to comment
Share on other sites

The last reply regarding this issue was the fact you asked for another users details to take a look - you didn't explain you had done this nor what the results were so as far as anyone reading this thread is concerned that was the last we heard of the issue so presumed it was either fixed or you didn't bother taking it any further. The fact that I am now having the same issues could only lead me to believe you didn't bother investigating any further or maybe the user in question didn't get back to you, I don't know cause I'm guessing as no-one bothered updating this thread.

Link to comment
Share on other sites

  • 2 months later...

Helllo NenaDice,

The application does not take emoticons into account, an emoticons should be considered as ONE character.
Actually, if i set the minimum characters/word to 50/5, the members can not post "Hello how are you?" but they can post " :ike: ".
Therefore, the usefulness of the application becomes very questionable...
I hope you will consider this for your next release, if planned....

Link to comment
Share on other sites

  • 2 months later...

NenaDice, the error message "nenadice_not_enough_chars" also shows when I try to reply using fast reply instead of a custom message.

Also, members are also able to bypass this feature by just posting a photo. Anything you can do to fix this?

Link to comment
Share on other sites

  • 1 month later...

I just opened hooks.xml and replaced all instances of "nenadice_not_enough_words" with something like "You have not entered enough words, please leave at least 100 words", obviously edit the message to suit. hooks.xml is found in "admin/applications_addon/other/mincharwords/xml/hooks" - once you've edited the file, upload it, uninstall the app then reinstall. Not really impressed with the support for this file if I'm honest - the developer isn't even following their own support topic, shame really cause it's a worthwhile mod let down [img]

[/img]




Thank you for this. I had the same exact problem. I tried reinstalling the application on my forum without success.

------------------

Nena, how does it count words?

If I put asdf :lol: , it will post successfully but the rules are set so that I need 10 words.
asdf + would only be 2 words, would it not?
Link to comment
Share on other sites


NenaDice, the error message "nenadice_not_enough_chars" also shows when I try to reply using fast reply instead of a custom message.




I'd just like to add that I'm experiencing this issue as well after installing the hook. I'm willing to let you take a look at my site if needed to reproduce it for yourself.
Link to comment
Share on other sites

  • 4 months later...
  • 3 weeks later...

I'm having the same problem as everyone else here. I'm getting nenadice_not_enough_words

That is a strange issue. If you will check the code then you will see that the language string is present and it should be displayed fine. Personally I can not reproduce this. You can either hard code the error message or enter the language string manually because for some reason it is not being added at your forum.

Will this mod be upgraded to be used with 3.4.x?

It should work with 3.4x as well. From what I have seen, there are no changes that should cause my mod to break and not work. Have you tried it?

Link to comment
Share on other sites

  • 3 months later...

Formatting, such as bold seems to make even single word posts bypass the restriction on a forum requiring at least 5 words.

The count also seems to be off by two words even for plain text posts. "one two three" counts as at least five words, "one two three four five" counts as at least 7 words, and so on.

My guess would be some of the HTML editor changes are causing issues, but I haven't attempted to debug anything yet.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...