Jump to content

Community

HeadStand

Recent Posts (Sidebar Block)

Recommended Posts


... and done. Check out the latest version in the Marketplace. :wink:




Could you post a before and after formatted screenshot as I don't understand the visual difference.

Share this post


Link to post
Share on other sites

names show formatted (with color set on board) and it displays a hover card (if you go with your mouse over the nick name it will pop the card)

Share this post


Link to post
Share on other sites

names show formatted (with color set on board) and it displays a hover card (if you go with your mouse over the nick name it will pop the card)




Hmmm ok, I have obviously already installed that and is working perfectly ;)

Share this post


Link to post
Share on other sites

Great Hook! so beneficial..
Is it possible to remove the "Last reply: " part? and also remove the date. (I only need the time)
to saves some space. If possible, how please?

Share this post


Link to post
Share on other sites

I did manage to remove the "last reply" words, by searching for last_reply key in ACP skin language. I've added a space instead (any better way?)
But how do I remove the space and ":" showing after it, before the member name?

Share this post


Link to post
Share on other sites

I did manage to remove the "last reply" words, by searching for last_reply key in ACP skin language. I've added a space instead (any better way?)


But how do I remove the space and ":" showing after it, before the member name?




This hook has several settings available in the ACP, under System -> System Settings -> HeadStand -> [HSC] Recent Posts (Sidebar block). You can hide the "Last Reply" completely by setting "Display Last Post Info?" to "No".

Share this post


Link to post
Share on other sites

No no, I need the last reply option. I just need it without the "Last Reply: " characters to save space. I mean I want the laste replier name directly. For example I want it to display "HeadStand" instead of "Last Reply: HeadStand"
The key doesn't accept to be empty, so I had to use "|", but the " :" part I cannot remove..
Can it just display the user name without anything before it please?

Share this post


Link to post
Share on other sites

No no, I need the last reply option. I just need it without the "Last Reply: " characters to save space. I mean I want the laste replier name directly. For example I want it to display "HeadStand" instead of "Last Reply: HeadStand"


The key doesn't accept to be empty, so I had to use "|", but the " :" part I cannot remove..


Can it just display the user name without anything before it please?



In that case, just edit the skin template. You can find it under Board Index -> recentPosts.

Share this post


Link to post
Share on other sites

Its possible, that the topic title goes direct to the latest post?



So that users dont have to click on that small "arrow" icon?



Thanks



(sorry for my english, but hope you understand what i mean)





Bump It !

Share this post


Link to post
Share on other sites

Bump It !






A new version has been uploaded to the Marketplace. It includes the following changes:


  • Topic links now go to the first unread post (instead of the first post in the topic)
  • Formatted member names are replaced with standard member hover cards
  • Additional setting to "exclude" selected forums (instead of include)
  • Minor changes to improve performance



???

That was released in January....

Share this post


Link to post
Share on other sites

Describe the problem here. The first topic I opened here:
http://community.invisionpower.com/topic/359723-user-image-in-the-last-posts-sidebar/

So, I posted below the foreach loop from the hook template's Last Posts (this is the simplified form that interests me):

<foreach loop="posts:$recentPosts as $post">


<!-- SHOW LAST TOPIC NAME -->                           

<a href='{parse url="showtopic={$post['tid']}&amp;view=getnewpost" base="public" seotitle="{$post['title_seo']}" template="showtopicunread"}'><u>{$post['title']}</u></a> <a href='{parse url="showtopic={$post['tid']}&amp;view=getlastpost" base="public" template="showtopic" seotitle="{$post['title_seo']}"}' title='{$this->lang->words['view_last_post']}'>{parse replacement="f_lastpost"}</a>

</ br>


<!-- SHOW USER AND DATE -->

<if test="lastPostInfo:|:$this->settings['hsc_rp_last'] == 1">

{IPSMember::makeProfileLink($post['last_poster_name'], $post['last_poster_id'], $post['seo_last_name'])}&nbsp;<span class='date'>({$post['last_post']})</span>

<br/>

</if>

</foreach>


I want the template to display the image of the user who made ​​the last post and I don't know how to do that. Can someone help me?

Share this post


Link to post
Share on other sites

Thanks but I solved the issue, like this:


{IPSMember::buildProfilePhoto($post['last_poster_id'], 'mini')}




Can you put whole code please?

Share this post


Link to post
Share on other sites

<div class='ipsSideBlock'>
<h3><img src='{$this->settings['img_url']}/comment_new.png' alt='' /> {$this->lang->words['recentposts_title']}</h3>
<div class='_sbcollapsable'>
<foreach loop="posts:$recentPosts as $post">
<div class='ipsBox_container ipsPad'>
{IPSMember::buildProfilePhoto($post['last_poster_id'], 'mini')}
<a href='{parse url="showtopic={$post['tid']}&amp;view=getnewpost" base="public" seotitle="{$post['title_seo']}" template="showtopicunread"}'><b>{$post['title']}</b></a> <a href='{parse url="showtopic={$post['tid']}&amp;view=getlastpost" base="public" template="showtopic" seotitle="{$post['title_seo']}"}' title='{$this->lang->words['view_last_post']}'>{parse replacement="f_lastpost"}</a>
<br/>
<if test="forum:|:$this->settings['hsc_rp_showforum'] == 1">
{$this->lang->words['forum']}: <a href='{parse url="showforum={$post['forum_id']}" base="public" seotitle="{$post['forum_name_seo']}" template="showforum"}'>{$post['forum_name']}</a>
<br/>
</if>
<if test="starterInfo:|:$this->settings['hsc_rp_start'] == 1">
{$this->lang->words['started_by']}: {IPSMember::makeProfileLink($post['starter_name'], $post['starter_id'], $post['seo_first_name'])}&nbsp;<span class='date'>({$post['start_date']})</span>
<br/>
</if>
<if test="firstPost:|:$this->settings['hsc_rp_post'] == 'F'">
{$post['post']}
<br/>
</if>
<if test="views:|:$this->settings['hsc_rp_views'] == 1">
{$this->lang->words['views']}: {parse format_number="$post['views']"} &nbsp; {$this->lang->words['replies']}: {parse format_number="$post['posts']"}
<br/>
</if>
<if test="lastPostInfo:|:$this->settings['hsc_rp_last'] == 1">
{$this->lang->words['last_reply']}: {IPSMember::makeProfileLink($post['last_poster_name'], $post['last_poster_id'], $post['seo_last_name'])}&nbsp;<span class='date'>({$post['last_post']})</span>
<br/>
</if>
<if test="lastPost:|:$this->settings['hsc_rp_post'] == 'L' and $post['post']">
{$post['post']}
</if>
</div>
</foreach>
</div>
</div>
<br />

That's it for avatars there too. :)

Share this post


Link to post
Share on other sites

Is this what I need for members to see replies to topics that they have not posted, commented on, or followed?
http://community.invisionpower.com/topic/364229-finding-new-replies-to-topics/#entry2276622

Share this post


Link to post
Share on other sites

Great hook!

Just one small change I would like to see.
Currently, if a sentence in the Post Content is broken in the middle of a sentence, there is an ellipsis (3 dots) inserted.
However, if the Post Content is broken at a new line, there is no ellipsis.

This may lead some to think that the post content displayed is complete.
Can I suggest that an ellipsis is displayed always, unless the whole of the post content fits?

Example
Whole post
Mis-match phase II and clinical observations are headscratchers, and more. Video:

Now displayed
(Yesterday, 01:00 AM) Snuffy Myers unimpressed by SWOG




Suggested display
(Yesterday, 01:00 AM) Snuffy Myers unimpressed by SWOG



TIA
Jim

Snuffy Myers unimpressed by SWOG 9346.




http://askdrmyers.wo...-v-iht-for-pca/

Last Reply:

Admin

9346.Mis-match phase II and clinical

observations are headscratchers, and

more.

Last Reply:

Admin

9346.Mis-match phase II and clinical

observations are headscratchers, and

more. ...

Share this post


Link to post
Share on other sites

[Previously posted under wrong product]
Have down loaded and installed the sidebar hook ok but it has the look of an html table with borders. How can I turn these off and have it so that alternate posts look slightly light and dark (according to our colour scheme) as per the rest of the forum.

Thanks

John

Share this post


Link to post
Share on other sites

The hook was working perfectly, until yesterday, when I edited globalTemplate to change the name of the favicon file (to avoid being overwritten with every forum upgrade). Following that, several errors started showing at top of the forum index page..

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /.../hooks/boardIndexRecentPosts_364a85630c9dc590090b5dcbdae1c4d2.phpon line 116



Warning: Cannot modify header information - headers already sent by (output started at /.../hooks/boardIndexRecentPosts_364a85630c9dc590090b5dcbdae1c4d2.php:116) in/.../admin/sources/classes/output/formats/html/htmlOutput.php on line 114



Warning: Cannot modify header information - headers already sent by (output started at /.../hooks/boardIndexRecentPosts_364a85630c9dc590090b5dcbdae1c4d2.php:116) in/.../admin/sources/classes/output/formats/html/htmlOutput.php on line 127



Warning: Cannot modify header information - headers already sent by (output started at /.../hooks/boardIndexRecentPosts_364a85630c9dc590090b5dcbdae1c4d2.php:116) in/.../admin/sources/classes/output/formats/html/htmlOutput.php on line 136



Warning: Cannot modify header information - headers already sent by (output started at /.../hooks/boardIndexRecentPosts_364a85630c9dc590090b5dcbdae1c4d2.php:116) in/.../admin/sources/classes/output/formats/html/htmlOutput.php on line 137



Warning: Cannot modify header information - headers already sent by (output started at /.../hooks/boardIndexRecentPosts_364a85630c9dc590090b5dcbdae1c4d2.php:116) in/.../admin/sources/classes/output/formats/html/htmlOutput.php on line 141



Once I changed the favicon file to its default name again, the errors dissappeared!
Any idea why is that? ..and do I have to stick with the favicon default file name for this hook to work properly?
(I'm currently using version 3.3.4)

Share this post


Link to post
Share on other sites

The hook was working perfectly, until yesterday, when I edited globalTemplate to change the name of the favicon file (to avoid being overwritten with every forum upgrade). Following that, several errors started showing at top of the forum index page..




Once I changed the favicon file to its default name again, the errors dissappeared!


Any idea why is that? ..and do I have to stick with the favicon default file name for this hook to work properly?


(I'm currently using version 3.3.4)



The icon is unrelated to the hook, and should not affect it in any way.

That being said... if you put your change back and disable the hook, do you still get those errors? I'd be willing to bet that the errors appear with whatever hook is executed first.


How would I change the font?



You can edit the skin template under Board Index -> recentPosts.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...