Jump to content

Download: [mm32] Viglink - Turn Links Posted by Members into Revenue


Mod-Mall.com
 Share

Recommended Posts

File Name: [mm32] Viglink - Turn Links Posted by Members into Revenue
File Submitter: Mod-Mall.com
File Submitted: 01 Aug 2011
File Category: Hooks and Plugins

This modification enables VigLink on your forum, which searchs for links to merchants and turns them into referral links for you.

This means if one of your member posts a link to Amazon (or many many other retailers) about a really good product, and someone buys it after clicking that link... You get a cut of that sale.

Best of all if you already have the link affiliated, it won't touch it leaving all existing channels of income inplace (so you have nothing to lose).

*In your Viglink Account Settings you can tell it to override already affiliated links

As well as inserting the Viglink code, this modification allows you to:

Disable VigLink

  • For certain usergroups
  • For certain forums/categories
  • In certain usergroups posts


It also allows you to set if your members can turn VigLink on or off in their profile settings.

If you have any feature ideas, please submit them on my forum.

If you sign up to VigLink using the link found in the Read Me (or *here*), I earn a referral fee (this does not effect your earnings!)

Kind Regards,
John @ Mod-Mall.com

p.s Please note this modification is not endorsed by VigLink or it's owners, please check it is working correctly on your forum and report any bugs in the support forum.

p.p.s You can use this modification with an existing VigLink account (you don't have to register again)

Click here to download this file
Link to comment
Share on other sites

same error in ACP that wibya gives and profile dropdown is empy
Warning: implode() [function.implode]: Invalid arguments passed in /home/xxxxxx/public_html/admin/applications/core/modules_admin/settings/settings.php(1067) : eval()'d code on line 12

copied that line from original php file and uploaded to try but no difference.

its only the 2 mod-mall hooks that do this to me, I do not use /forums if that matters.

Link to comment
Share on other sites


That error is because the custom profile cache only creates itself once you have created a custom profile field for it to work with...



I will code it out in the next release, but it shouldn't effect anything else in the modification.



but I have not created one, I can't create one unless I am missing something.
can you post how to create one so I can see if I am making error somewhere please?
Link to comment
Share on other sites

created new profile called test, recached everything and same issue with php

Warning: implode() [function.implode]: Invalid arguments passed in /home/xxxxxxx/public_html/admin/applications/core/modules_admin/settings/settings.php(1067) : eval()'d code on line 12



however the profile tab works now.
viglink site reporting me not installed though, will try creating new key to see. should the VL code be geting placed into the global templates file? I can't see where it is.

edit: I setup a test board with NO mods installed and get the same errors. I have content/blogs/gallery/doanloads modules in that makes any difference.

php version error maybe?
Link to comment
Share on other sites

  • 5 months later...
  • 4 months later...
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...