Jump to content

Subscriptions Manager


sijad

Recommended Posts

  • Replies 1.2k
  • Created
  • Last Reply




I have checked, all files are correct and present. Just re-uploaded all files from the upload folder.

The settings option now appears under "apps" in tools and settings. Not sure what was missing, or if I needed to do the recache.

The setting was there, and now it is gone again, when I went from the subscription manager back to tools and settings. The script is still working (as I changed the URL to do=setting_update&id=42) where 42 is the settings for subscriptions...

Very strange behavior, not sure why it isnt displaying...

Thanks
Link to comment
Share on other sites

The only other thing I can suggest is to let me look at your site directly. The link to the settings page should be showing in the My Apps page for this app, and if the files that build that menu are properly uploaded and the menu cache is built, it should show there. Send me a PM with your FTP and Admin CP info if you want me to check.

Link to comment
Share on other sites


You have to have the "Subscriptions: Register Form" hook enabled, you have to have the "Show subscription packages when registering?" setting set to Yes, and each package you want to show has to have its "Show on the registration form" setting set to Yes.




Thanks for reply - i checked and i hook was enebled ... and settings was on all packages to "yes" - but nothing on reg. form ... also all grups was ckecked .

just confused ...what is wrong?

regards

bosss
Link to comment
Share on other sites


The link vanishing from the IPS Apps area is intentional, the idea is that you should be able to control everything about this app, including its settings, directly from its entry in the My Apps area.




Hi,

There seems to be something missing then, none of the options that were previously in the IPS Apps settings tab are available from the My Apps area.
The links to the left are.

Manage Payment Gateways
Install Payment Gateways
Manage Packages
Add New Package
Manage Transactions
Manually Add Transaction
Search Logs
Manage Currencies
Link to comment
Share on other sites


All I can suggest is letting me look at what's wrong on your site to stop this from working, PM me your site's Admin CP and FTP details if you'd like me to check.




I send PM to you!


i also have same links on left side:

Manage Payment Gateways
Install Payment Gateways
Manage Packages
Add New Package
Manage Transactions
Manually Add Transaction
Search Logs
Manage Currencies


regards

bosss
Link to comment
Share on other sites

Somehow the package I uploaded for this wasn't built properly, and was missing the files necessary for that settings link to show up. If you redownload now, reupload all of the files, and run the Recache Apps & Modules tool from the Manage Applications & Modules page, it should restore that link.

Link to comment
Share on other sites

Michael, I wonder if you could help me out with something.

Our forum has had Subscriptions running for a while now, but since upgrading to 3.1.4 we have had the problem of all transactions sticking at "Incomplete" and having to manually approve upgrades. In addition, recurring subscriptions continue to process through paypal, but are not reflected on the board (user groups are downgraded after the initial subscription period, no further transactions appear, incomplete or otherwise).

I have upgraded to 1.0.3 today but testing reveals the issue still remains. The paypal IPN is set up correctly (I have tested on multiple paypal accounts).

We do have Nexus installed, and I would use that for subscriptions. However we use Nexus for physical merchandise which is operated through a separate paypal account to our membership, and as yet we don't have the option to specify different paypal accounts per package in Nexus. Are you aware of any conflicts between Subscriptions and Nexus on one installation?

Link to comment
Share on other sites

Yes, there are definitely conflicts between Nexus and Subscriptions, you should only be using one or the other.

IP.Subscriptions and IP.Nexus cannot be installed together. If you have IP.Subscriptions installed already, IP.Nexus will allow you to convert your data.


Source:
Link to comment
Share on other sites

Michael,
I've been using Subscriptions for years now and have major issues every year when it comes time for my members to renew their subscriptions. We do NOT use recurring subscriptions (after a nightmare with autorenewals.) I'd prefer to stick with Subscriptions, but if you can't fix this by next March, I may have to find another alternative.

Here's my wish list:

1) Be able to set a hard coded date for subscription packages to expire (as opposed to XX days, weeks, months, year, etc.) Currently I have to manually adjust every subscription to the membership year. Unfortunately, I think there's something broken there, because the system does NOT automagically turn everyone off on that date.

2) Allow me to set a group to put members in after the expiration date kicks in. Currently I can only put them back into a group they were previously in - which in some cases puts them back into Member status, if they were upgraded, or dumps them all back to Validating, which makes it hard for me to differentiate actual memberships from uncompleted ones. I'm looking for an option that says "Move members to [pick group] upon package expiration."

3) Allow a package option for current members to be able to select to renew from Manage My Subscriptions. Right now, with the current system, it's difficult with different membership packages to get our renewal process done easily for everyone. Here's the use case:

- New members sign up under a $25 "New Member" package.
- The following membership year, the member needs to be able to select a $15 Renewal package.

The current system sees other packages as "upgrades" and doesn't present the correct price point for other packages being selected. Essentially, all is well if the user used the Renewal package the previous year, but not if they used the New Member package. I have to manually enter a transaction for the Renewal package for them. Very hard on me with hundreds of members to get right!

Feel free to email me/PM me if you have any questions. I'd appreciate whatever you can do to fix these issues.

Thanks,
Pam

3)

Link to comment
Share on other sites

You can submit new feature suggestions for this app here:

http://invisionfocus.com/tracker/project-5-subscriptions-manager-feature-suggestions/

Note anything I might add would probably only be for the version of this app for IP.Board 3.2 onward. And I'd only be considering new feature suggestions for this, or any of my products, when I have all existing stuff upgraded to 3.2.

Link to comment
Share on other sites

Hello Michael (or whomever might know!)

I am setting up the PayPal gateway information, and the text at the top says:

Please ensure that you have Instant Payment Notifications (IPN) switched on in your PayPal control panel.


Please read this

document

if you are unsure.



However, I don't know what URL to put in for the IPN option on PayPal's site and the documentation linked is no longer available.

Any help?
Link to comment
Share on other sites


Where exactly was it in the profiles? I'm not a regular user of this app, I don't think I removed any profile links since I took it over.



It's been years since I used IPB, I was a 1.x-2.x veteran. I found the non-intrusive link to the subscriptions and managed to keep it active while disabling the tab.

Thanks much for your time. You're doing an awesome job and it is appreciated!
Link to comment
Share on other sites

I added a Payment Gateway, which was automatically named "Test", upon clicking either of the links to manage the gateway, I received the following error:

Class 'gatewayApi_test' not found in /home/jay/public_html/admin/applications_addon/other/subscriptions/modules_admin/subscriptions/manage.php

Link to comment
Share on other sites

Oh, this is a lovely issue. There is a lot of inconsistency in how it does that gatewayApi_ class naming, sometimes it's gatewayApi_ and sometimes it's gatewayApi__. There are three files that need patched to correct this.

Open /admin/applications_addon/other/subscriptions/modules_admin/subscriptions/manage.php. Find:

    	$n = 'gatewayApi__' . strtolower( $gateway );

Change to:

    	$n = 'gatewayApi_' . strtolower( $gateway );

Save and upload. Open /admin/applications_addon/other/subscriptions/sources/classes/gateways/apis/authorizenet.php. Find:

class gatewayApi__authorizenet extends apiCore

Change to:

class gatewayApi_authorizenet extends apiCore

Save and upload. Open /admin/applications_addon/other/subscriptions/sources/classes/gateways/apis/test.php. Find:

class gatewayApi__test extends apiCore

Change to:

class gatewayApi_test extends apiCore


Save and upload.

I'll patch this for the next release in both this and the IP.Board 3.2 version.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...