Jump to content

Portal


Michael.J

Recommended Posts

This is broken. At least for me, I dunno about everyone else.

Fatal error: Call to a member function latestPosts() on a non-object in /home/sitename/public_html/admincp/applications_addon/other/portal/sources/blocks.php on line 58

Also:

Fatal error: Call to a member function articles() on a non-object in/home/sitename/admincp/applications_addon/other/portal/sources/blocks.php on line 325

Link to comment
Share on other sites

Directory applications_addon/other/portal/sources
File blocks.php

Comment lines 249/250.

Stil doesn't understand why the reorder is done since the right order should be the one from the resultset from the BDD.

A comment on the purpose of this could be great, in the meatime commenting the two lines in the file restore the good old behavior.

Anaethelion on behalf of the guy who asked me for help.

Link to comment
Share on other sites


This is broken. At least for me, I dunno about everyone else.



Fatal error: Call to a member function latestPosts() on a non-object in /home/sitename/public_html/admincp/applications_addon/other/portal/sources/blocks.php on line 58



Also:



Fatal error[color=#000000]: Call to a member function articles() on a non-object in[/color]/home/sitename/admincp/applications_addon/other/portal/sources/blocks.php[color=#000000] on line [/color]325




I cannot reproduce these errors on a fresh install. In the future, please give the author a day or so after you post about an issue before you report the associated file as broken.
Link to comment
Share on other sites


I cannot reproduce these errors on a fresh install.


I can provide you with the URL in a PM if you'd like, I had installed 1.0.0 of your portal back on 3.1 but hadn't used it as I moved over to uPortal for a while because of the three coloums and custom block feature, which this one now has. So I updated the portal to 1.1.0 (on a IPB 3.3.0 install) and I'm just reporting what I saw.

In the future, please give the author a day or so after you post about an issue before you report the associated file as broken.


Kindly noted, and apologies. I was not aware I had to leave a day before reporting as broken, I thought one reported it broken regardless. So I do apologise, I was in the wrong and I hold my hands up and say that. It won't happen again, now I know. :)
Link to comment
Share on other sites


Fatal error: Call to a member function latestPosts() on a non-object in /web/htdocs/www.dekazeta.net/home/foro/admin/applications_addon/other/portal/sources/blocks.php on line 58





Fatal error[color=#000000]: Call to a member function articles() on a non-object in[/color]/home/sitename/admincp/applications_addon/other/portal/sources/blocks.php[color=#000000] on line [/color]325




Most likely caused by an IPB skin bug, check this article and see if it's the cause here.



How we can get that main blocks looks like board's category? Mean default IB Board skin.




When made some changes in portal settings and click save - i am redirect to admin overview. some solutions to stay in apps?




Suggestions noted. If you don't mind a template edit, the first one can probably be changed with one.


Do you offer a branding free option?




See here.


ok some minor issue, the portal plugin didn't take in account the topic filter key for the 4 forum i use to push on portal it's set by start_date, it act as last_post_date.. so it a big disturbing now on portal like old news came back from grave ... because someone just reply to a old topic on the news section


.....




Thanks for reporting, I assume by your second reply, you've solved this and don't need a patch?
Link to comment
Share on other sites

Well, no major disasters yet and the portal is looking very similar to our old one.

When I create a custom block, is there any way to hide the block if it's not being used. eg. we have a 'photo of the month' block that displays for 2 weeks, then I would usually hide that and show a 'voting now open' block.

Is there a way to display recent posts? I can see I have a block for recent topics but not posts.

Link to comment
Share on other sites


Have same problem " In the admin panel, when I go to configure the plugin appears this error window: The directory '{app_name}/extensions/portalPlugins' does not exist. ". I installed new portal on my test site (clean 3.3.1 board)



what to do?



regards



bosss



I also have this problem. I installed this on a fresh 3.3.1 board. When visiting the "Manage Portal" page, I get the error, "The directory '{app_name}/extensions/portalPlugins' does not exist. Create it and try again." I tried to create the directory, "/admin/applications_addon/other/portal/extensions/portalPlugins/", but it did not remove the problem. Why is this happening? What is the solution to this?


I solved the problem of the administration panel, but the plugin does not work, this error appears (new installation):



Fatal error: Call to a member function articles() on a non-object in /web/htdocs/www.dekazeta.net/home/foro/admin/applications_addon/other/portal/sources/blocks.php on line 325



http://www.dekazeta.net/foro/portal

Please help.



What did you do to fix the admin panel problem?

Thank you to all who reply.
Link to comment
Share on other sites

Have new install and getting following error messages.

If client clicks portal or Portal is set to default app

Sorry, we couldn't find that!

[#404]
Sorry, we could not locate the page you are requesting to view. Please click here to return to the community index

Need Help?


If you go to
System-->Applications and Modules-->Manage Applications and Modules

Shows Portal enabled and up to date
If you go to Other Apps--> ortal you get
System Error

[#404] incorrect_furl


Invision updated system to latest version yesterday at 2:00pm


This was running fine but we reinstalled to clean up other errors
Link to comment
Share on other sites


I also have this problem. I installed this on a fresh 3.3.1 board. When visiting the "Manage Portal" page, I get the error, "The directory '{app_name}/extensions/portalPlugins' does not exist. Create it and try again." I tried to create the directory, "/admin/applications_addon/other/portal/extensions/portalPlugins/", but it did not remove the problem. Why is this happening? What is the solution to this?




If you don't have any portal plugins you don't need to visit this page, if you want to add a block, setup a custom block instead. ACP > Other Apps dropdown > Portal > Custom Blocks.


Have new install and getting following error messages.




Try re-install, including re-upload all the Portal files again.
Link to comment
Share on other sites

I'm certain it's in the correct area as it comes up in the manage applications section. From there and in the install screen I am not allowed to choose it as it say's it's up to date already.

Please see attached to screenshots, this is what's going on.

Also it looks like there are still setting from the old portal. In the system setting, IPS Apps there is still a IPB portsl settings (which I cannot delete) would that be interfering with it? If so, how do I kill it ?

Link to comment
Share on other sites

ACP > Support > SQL Toolbox. Any results for this query. (May need to add database prefix.)

SELECT * FROM core_applications WHERE app_directory='portal'[/CODE]

Might as well check this one as well.

SELECT * FROM upgrade_history WHERE upgrade_app='portal'

If no results, I'll need board access then. I've got no idea why it would still be listed as installed.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...