Jump to content

Portal


Michael.J

Recommended Posts

On 15 September 2015 01:23:14, Mike John said:

Portal shouldn't even utilize that table. Have you tried repairing the table through phpmyadmin?

Hi Mike,

 

Yes, tried that. I also tried to merge two members today and got a similar error:

Quote

 

An error occured with the SQL server:
mySQL query error: UPDATE ipbprofile_portal_views SET views_member_id=1277 WHERE views_member_id=855

This is not a problem with the IPS Community Suite but rather with your SQL server. Please contact your host and copy the message shown above.

 

 

Link to comment
Share on other sites

I have tried a repair using phpmyadmin again this morning with no luck, so I ask to analize the table and this is the error message received:

Quote

 

bvforum.ipbprofile_portal_views analyze Error Can't find file: 'ipbprofile_portal_views' (errno:...

 

Here is a screen shot of how the table appears - I notice it says in use?

 

 

Screen Shot 2015-09-24 at 13.28.03.png

Link to comment
Share on other sites

I think there may be a slight misunderstanding as those tables are not for the Portal but rather part of IPB's core tables for the profiles. It seems like your data might be corrupted, you said you can't rebuild the table through phpmyadmin though? Might be time to seek help from your host then and see if they can rebuild it for you?

Do you have any other 3rd party plugins that might be messing with your profile views?

Link to comment
Share on other sites

53 minutes ago, MOC said:

Mike - I installed Portal and set it as my homepage somehow last year, but now when I remove Portal app, the homepage still looks for it. when you click the site logo (home) or go to my main URL.

Can you check out http://makeoutclub.com/ and tell me how to reverse Portal back to IPB normal?

 

In your root forum directory edit the file initdata.php

Find this line [toward the top]

{
    define( 'IPS_DEFAULT_PUBLIC_APP', 'portal' );
}

Change it to this:

{
    define( 'IPS_DEFAULT_PUBLIC_APP', 'forums' );
}

Save / Reupload

Link to comment
Share on other sites

On 25 September 2015 01:26:16, Mike John said:

I think there may be a slight misunderstanding as those tables are not for the Portal but rather part of IPB's core tables for the profiles. It seems like your data might be corrupted, you said you can't rebuild the table through phpmyadmin though? Might be time to seek help from your host then and see if they can rebuild it for you?

Do you have any other 3rd party plugins that might be messing with your profile views?

Hi Mike, Yes I have a couple of plugins, (SOS33) Topic Viewed by Users, Bump Topics, and Members Online Today.  I try and keep hooks etc to the bare minimum. They only things I have uninstalled recently are 2 portal plugins - Newest Members and Top Posters but I cannot find the original files to re-install them even if I wanted too.  I am not sure what to do so any advice would help? Can I try and find this file and simply upload it, or does it not work like that, it seems to appear as if it is missing

Link to comment
Share on other sites

20 hours ago, Jamer said:

Hi Mike, Yes I have a couple of plugins, (SOS33) Topic Viewed by Users, Bump Topics, and Members Online Today.  I try and keep hooks etc to the bare minimum. They only things I have uninstalled recently are 2 portal plugins - Newest Members and Top Posters but I cannot find the original files to re-install them even if I wanted too.  I am not sure what to do so any advice would help? Can I try and find this file and simply upload it, or does it not work like that, it seems to appear as if it is missing

Contact your hosting provider they should be able to restart the mysql service and use mysqladmin to check and repair any corrupt tables.  That's your quickest solution and if I'm not mistaken that table keeps the latest visitor information for the IPS profile portal page. If checking and repairing any tables with your hosting provider doesn't fix the table send in a support ticket to IPS. I don't believe those tables are part of Mike's Portal.

Repairing tables requires machine resources that are defined in the configuration file for mysql. If there isn't enough memory allocated, for example, the repair process won't work and you can't see the problem without a root account. Finding and uploading plugin files won't fix a corrupt table if indeed that's what you have. From what I saw it just reports "In Use" which means it's not closed but may or may not be corrupt.

Hope that helps you.

 

Link to comment
Share on other sites

3 hours ago, thompsone said:

Contact your hosting provider they should be able to restart the mysql service and use mysqladmin to check and repair any corrupt tables.  That's your quickest solution and if I'm not mistaken that table keeps the latest visitor information for the IPS profile portal page. If checking and repairing any tables with your hosting provider doesn't fix the table send in a support ticket to IPS. I don't believe those tables are part of Mike's Portal.

Repairing tables requires machine resources that are defined in the configuration file for mysql. If there isn't enough memory allocated, for example, the repair process won't work and you can't see the problem without a root account. Finding and uploading plugin files won't fix a corrupt table if indeed that's what you have. From what I saw it just reports "In Use" which means it's not closed but may or may not be corrupt.

Hope that helps you.

 

Okay thank you for this information. I tried to merge two members today and this came up as an error again, so I really need to get this one sorted. I will create a support ticket with my host and also IPS see where this takes me. Thank you.

Edited by Jamer
Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

With IPB 4.1.4 the sort order of portal topics does not seem to work if selecting to sort by topic start time. Rather, it sorts by default of last updated topic no matter what the setting. It worked correctly with IPB 4.1.3.2 .

I had to change the sortBy line in portal.php from start_date to forums_topics.start_date and it then works as expected.

Link to comment
Share on other sites

  • 3 weeks later...

Is there a demo of this I can see somewhere?

I'm basically looking for something that pulls non-pinned topics from specifically set boards and displays them in order of topic creation date and allows users to comment on news via the thread itself. So I can have a news page, but have comments integrated into the forum thus doing away with my separate Wordpress installation that is used solely as a news blog for our specific genre. Would also be nice if the side-bar can utilize custom html boxes, and navigation links, etc.

Does this sound like this 'portal' app would be what I'm looking for?

Link to comment
Share on other sites

8 minutes ago, Mike John said:

I've sent you a PM with demo board setup. Might be easier for you to see how it works.

Thanks appreciate it. Looks like what I was hoping it'd do.

Just some suggestion: would it be hard to make the '0 replies' actually link to the thread comments or maybe the reply box? Not really sure it that is possible, but on wordpress for example that text links to the reply box on the page with /#respond

Also I read on your site that copyright removal is only for paid addons, but is it possible to pay to remove it still and if so, how much would that be?

Link to comment
Share on other sites

On 17/12/2015 at 0:39 PM, Koby said:

Just some suggestion: would it be hard to make the '0 replies' actually link to the thread comments or maybe the reply box? Not really sure it that is possible, but on wordpress for example that text links to the reply box on the page with /#respond

A simple edit in the template bit if this is needed.

On 17/12/2015 at 0:39 PM, Koby said:

Also I read on your site that copyright removal is only for paid addons, but is it possible to pay to remove it still and if so, how much would that be?

See here, that one covers the Portal and any of my free apps/plugins.

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

Hi,

Im using Portal 1.4.1 for IP.Board 3.4.x and I always get this error message when I try to enter my site with the mobile theme:

unp6l274.png

It only shows the error on the portal page, but I set the portal to the start page in the inidata file, so everyone that is entering my site from mobile get this error message.

Is there any possibility to solve this problem or auto. redirect to the forum page when someone is entering from mobile?

Edited by Biggi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...