Jump to content

Portal


Michael.J

Recommended Posts


Havent modified anything in the template bit yet:P


Default theme appears to be fine. My custom theme is fixed and the default is fluid though.





Ahhhh Kiwi ...thats it!



I did truncate my articles using a hack , thats whats causing my sidebar issue then :tongue:



Is there another way to truncate the text without breaking the sidebar then?




You using the one mentioned here? See my reply to 2 for alternative.


I've got this portal set up on my 3.2.3 test site. I'm just waiting for the final version of 3.2.3 to be released before upgrading my 3.1.4 site. Here's some suggestions / omissions:



1. No link to last post as there was with 3.1


2. No easy way to limit article length. You can truncate the text and specify the number of letters but when you do that you run into problems with the sidebar shifting down the right hand side. What I would like to is limit length by pixels as I do now with my 3.1 forum.



Apart from that, great work :smile:




1. Noted for next update, should be a simple change if wanted to apply this now.
2. I don't know of any way to do it without removing formatting. You can do it with css so it adds a scroll bar after lets say 250px height but it will still load the full topic. If that's a good alternative for you, I'll put together some instructions.
Link to comment
Share on other sites

1. Try this and see if it works, open admin > look & feel tab > Portal > articles.

Find:

<a href='{parse url="showtopic={$topic['tid']}"[/CODE]

Replace With:

[CODE]<a href='{parse url="showtopic={$topic['tid']}&amp;view=getlastpost"

Save. 2. Regarding the css limit, in the same template bit. Find:

<div class='ipsType_textblock ipsPad'>

Replace With:

<div class='ipsType_textblock ipsPad' style='height:250px; overflow:auto;'>[/code]

Save.



Link to comment
Share on other sites




Find:


<a href='{parse url="showtopic={$topic['tid']}"[/CODE]

Replace With:

[CODE]<a href='{parse url="showtopic={$topic['tid']}&amp;view=getlastpost"

Save. 2. Regarding the css limit, in the same template bit. Find:

<div class='ipsType_textblock ipsPad'>

Replace With:

<div class='ipsType_textblock ipsPad' style='height:250px; overflow:auto;'>[/code]

Save.








Get last post edit did nothing for me. Any ideas on truncating the articles without scroll bars?
Link to comment
Share on other sites

Mike,

I have all the latest versions of software installed (Board 3.2.3, Blog 2.4.1), and on the Manage Portal Plugins page, when you click the Gear icon next to the IP.Blogs entry, it just goes to the System Settings main page, with a popup that says: "No Group was passed. Please try again." And... nothing blog-related appears on the Portal Page itself. Is this a version incompatibility? Other?

Thanks in advance.

EDIT: I tried adding the exportable tags that weren't already in the skeletonTemplate, that just threw error pages about skin_cache.

Link to comment
Share on other sites


How do we edit the footer, the 'v1.0.1' and based on portal feature? I'd like to consolidate this to one line.




Open admin/applications_addon/other/portal/modules_public/portal/portal.php

Remove the 2nd instance:

<br />



Save.


I have all the latest versions of software installed (Board 3.2.3, Blog 2.4.1), and on the Manage Portal Plugins page, when you click the Gear icon next to the IP.Blogs entry, it just goes to the System Settings main page, with a popup that says: "No Group was passed. Please try again." And... nothing blog-related appears on the Portal Page itself. Is this a version incompatibility? Other?



Thanks in advance.



EDIT: I tried adding the exportable tags that weren't already in the skeletonTemplate, that just threw error pages about skin_cache.




Try an uninstall and re-install of the application, seems to fix the issue when reported. There aren't any IPS addon blocks included yet.


Is it possible to display latest posts from a specific forum, rather than from all forums?




For the main articles yes there is a setting but not for the sidebar latest posts. This is pulled directly from the IPB built in sidebar block hook and doesn't have this option.
Link to comment
Share on other sites


Try an uninstall and re-install of the application, seems to fix the issue when reported. There aren't any IPS addon blocks included yet.




An uninstall/reinstall didn't fix it, unfortunately. Identical symptom, too. Click the Gear icon next to the IP.Blogs entry on the Manage Portal Plug-ins page, and it just goes to the System Settings main page, with a popup that says: "No Group was passed. Please try again." And nothing blog-related shows on the portal. Not sure what to try next. :blink:
Link to comment
Share on other sites


Currently I don't have any php code to do this effectively, the code mentioned before seems to have problems. Right now the only solution I can offer is a css one, at least until I can find an appropriate function in IPB or write one myself.




If you wanted to do this as a paid app, then i would be willing to buy.

Also i would like to thank you for taking the portal on.

Great job appreciated...
Link to comment
Share on other sites


Sorry misread, I assume you upgraded your board from IPB 3.1? If so then it's still got the legacy blog plugin in place. The Portal doesn't included support for this addon yet.




Yes and no, really. One install was an upgrade from 3.0.x originally, another was a 3.2.2 to 3.2.3 upgrade, and the third was a fresh test install of Board 3.2.3 and Blog 2.4.1 (plus the other addons). Same symptoms in all cases.

But... if your Portal doesn't support Blog yet that would explain it I guess?

Thanks again.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...