Jump to content

Portal


Michael.J

Recommended Posts

everything works fine for me, but I have a question : in the "Latest Topics Main Block", I would like to see the images (with the size reduced) that are present in the original post. Is it possible ?

​No not in the current version. Has been suggested a lot and will be seriously looked at next version.

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

I'll apologise upfront for bombarding this with questions.

1) How do you edit the links within the 'Site Navigation' Block?
2) I tried to phase a IP.Content block but it just displayed the code or gave me back an error - How do I add blocks from IP.Content
3) Is is possible to list IP.Content's articles rather than topics in the middle section
4) Does anyone know all the available blocks for the portal? I searched within the market and found a few, though not many.

Edited by Joey_M
Link to comment
Share on other sites

2) I tried to phase a IP.Content block but it just displayed the code or gave me back an error - How do I add blocks from IP.Content
3) Is is possible to list IP.Content's articles rather than topics in the middle section
4) Does anyone know all the available blocks for the portal? I searched within the market and found a few, though not many.

​2) See here, the other option is to add the block variable within the Portals skeletonTemplate template bit.

3) See above, replace the "Main Topics" block with an ip.content block that displays articles.

4) There should be around a dozen blocks available in there. See z1000-forum.de's account as he has added quite a few himself.

Link to comment
Share on other sites

I have configured portal as my default app in the initdata.php file.   If I enter '/community/forums' it will take me to the portal where I wish it to take me to forums.  I want to utiilize '/community/forums and NOT  '/community/index' to access forums.  Please advise.

/**
 * Default app name
 * You can set this in your own scripts before 'initdata.php' is required.
 */
if ( ! defined( 'IPS_DEFAULT_PUBLIC_APP' ) )
{
    // define( 'IPS_DEFAULT_PUBLIC_APP', 'forums' );
    define( 'IPS_DEFAULT_PUBLIC_APP', 'portal' );
}

Link to comment
Share on other sites

Could you please check?

​Could you please try again, seems to be working now for me.

I have configured portal as my default app in the initdata.php file.   If I enter '/community/forums' it will take me to the portal where I wish it to take me to forums.  I want to utiilize '/community/forums and NOT  '/community/index' to access forums.  Please advise.

​The /index url is set by the forums not the Portal. Future changes will most likely needed to be made within the IPB source code itself. I can provide the patch necessary but I can neither guarantee it's without problems or support it.

Link to comment
Share on other sites

Hi Mike, what code should i use when i want a block with the 5 highest rated threads?

I'm not sure I understand, there is no block included for 5 highest topics. You'll need to have it written.

Hello mike. i have installed this product but it doesn't work for me in both skins..what's the problem?

​Try rebuilding your skin cache.

Link to comment
Share on other sites

  • 2 weeks later...

 

Hello Mike!

I've just installed Portal and I have one very important question. Is it possible to set up an RSS block so that I can import a certain blog's posts to my Portal? Our goal with portal is to use it as a home page where we can use our partner site's RSS feed to show their posts on our home page.

 

Thank you very much, and Portal looks great!

Link to comment
Share on other sites

I've just installed Portal and I have one very important question. Is it possible to set up an RSS block so that I can import a certain blog's posts to my Portal? Our goal with portal is to use it as a home page where we can use our partner site's RSS feed to show their posts on our home page.

​The best way I would be aware of would be to use the existing RSS import feature to import your blogs entries into a forum and then select that forum for display in the Portal.

Link to comment
Share on other sites

Fatal error: Call to a member function articles() on a non-object in /home/chaoticu/public_html/forums/admin/applications_addon/other/portal/sources/blocks.php on line 472

How can I fix this? :sad:

​Can you try first rebuilding your skin cache for all your skins. In ACP > Look & Feel Tab > Template Tools > Recache skin sets

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...