Jump to content

Portal


Michael.J

Recommended Posts

Hello & Thank you Michael for taking over the Portal mod!

I don't know if this is possible or not, but I have a forum where we create topics and post videos. What I would like is a block that fetches the posts made in that forum and displays it on the side along with the video linked in the post.

Kind of like a recent videos post that shows you the last 3 topics in a forum, along with the videos showing as well.

is that possible?

Link to comment
Share on other sites

will it be possible to use my old layout for the portal?

i used to use this:


<table class='ipbtable' cellspacing="0">

<tr>

	 <td width="20%" class="nopad" valign="top">

		 <!-- LEFT -->

		 {parse block="gamers_links"}

	    <!--::online_users_show::-->

		 <!--::poll_show_poll::-->

		 <!--::portal_affiliates::-->

		 <!--END LEFT-->

	 </td>

	 <!--SPACER-->

	 <td width="1%" class="nopad"> </td>

	 <td width="60%" class="nopad" valign="top">

		 <!--MAIN-->

		 {parse block="gamers_welcome"}

		 <!--::recent_topics_last_x::-->

		 {parse block="gamers_gaming_news"}

		 {parse block="gamers_sto"}

		 {parse block="apb_news"}

		 <!--END MAIN-->

	 </td>

	 <!--SPACER-->

	 <td width="1%" class="nopad"> </td>

	 <td width="20%" class="nopad" valign="top">

		 <!-- RIGHT-->

		 <!--::calendar_show_current_month::-->

		  {parse block="gamers_comments"}

		 <!--::recent_topics_discussions_last_x::-->

		 <!--END LEFT-->

	 </td>

</tr>

<!--End Main Content-->

</table>



however when i try to use this now it pulls up a driver error, i dont have this issue with anything else though, only when i do this, and the same layout is used on similar pages i made using IP Content, dont want to use ip content as a portal though and i dotn have a clue what i doing with the new default leayout that now comes with the portal.

Link to comment
Share on other sites





Hey, i sorted it, was pasting the error log to here and noticed all the things it was talkin about is the callender, becuase i had a miniview of the calender from the ips portal, removed the block from the layout and it works fine now

Thanks for the help

EDIT: I think that may be a bug actually unless ive not go tthe calender set up on my side, because i just realised this version also has a calender block.
Link to comment
Share on other sites


EDIT: I think that may be a bug actually unless ive not go tthe calender set up on my side, because i just realised this version also has a calender block.




Now that the calendar is not included by default, I did remove the block. Do you still have the old block calendar block in admin/applications_addon/ips/calendar/extensions/portalPlugins/ Shouldn't be too hard to change it to use the upgraded hook code.
Link to comment
Share on other sites

I've downloaded your file, but after extraction the "sql" folder is empty. I tried to re-download and still empty.
and i've success installed the application, but when clicking to portal link it said error with database.

do you know what's wrong with this?

Link to comment
Share on other sites


I've downloaded your file, but after extraction the "sql" folder is empty. I tried to re-download and still empty.


and i've success installed the application, but when clicking to portal link it said error with database.



do you know what's wrong with this?




did you delete the portal folder from admin/applications_addon/ips/


EDIT: actually nevermind, if you hadn't done that part it wouldnt even let you isntall it
Link to comment
Share on other sites


When I upload the files in ACP it shows this; I place the folders/files into the admin folder 'This application cannot be installed. Is it in the correct directory? You cannot install third party applications into the IPS directory or vice-versa.'




see my above post.


did you delete the portal folder from admin/applications_addon/ips/


Link to comment
Share on other sites


I've downloaded your file, but after extraction the "sql" folder is empty. I tried to re-download and still empty.


and i've success installed the application, but when clicking to portal link it said error with database.



do you know what's wrong with this?




The Portal currently doesn't require an sql data. As long as you uninstall the portal in the ips folder, should be fine to install.


Thanks that worked.



Is there any way to show last uploaded file/s. Latest IPContent article etc




I currently don't have blocks for these. I'll be adding more support for the official IPS addons in a future release.
Link to comment
Share on other sites


Thanks that worked.



Is there any way to show last uploaded file/s. Latest IPContent article etc





you could create a block in IP Content that shows the latest article, for example on my website i created a block that showed the latest blog post, then add the tags to the portals template, should work that way
Link to comment
Share on other sites


When you will release new version with custom blocks?




As soon as it's ready. Might come out with a smaller release with some highly requested features sooner.


Not very good at this :no: can someone please explain where I am going wrong.




What's the exportable tag your adding?, as long as you don't place it within another should be able to add below the existing ones.
Link to comment
Share on other sites

Done some re organizing Mike and the fault was in my test board. Yes I did add the tags underneath but some some reason the result (displayed) occurred. I then tried my live board (offline) and all went well. I can only guess I made an error somewhere within the test board that caused syntax error. At least I know I am now on the right track with the success of the live board. Thanks for replying.

Link to comment
Share on other sites

In a future version, would it be possible for portal plugin blocks to not have to execute an init() function? Just check to see if the function exists, and if it does then execute it, but if not then just skip it?

Most of my plugins (not checked all of them yet) only include this function because I have to, I don't actually use it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...