Jump to content

Download: Shoutbox


Pete T

Recommended Posts

I just noticed when I click on the "BBCode" button, I get this error:


Fatal error: Call to undefined method skin_gallery_global_18::bbCode() in C:\wamp\www\forumi\admin\applications_addon\ips\gallery\extensions\bbcode\gallery.php on line 298 



This happenes on both my live and localhost copy. Also happens with the default ip.board skin. Tried rebuilding the templates and recaching but it's still there. Looks like a template bit is missing?

Link to comment
Share on other sites

Ah, this was related to an issue I patched earlier today for version 1.2.1. Basically, the old version of the app looked for any emoticons that you had set to be 'clickable', and showed those in this list. In IP.Board 3.2, that 'clickable' concept is no more, but the clickable field is still there, but set to 0 for all of your emoticons, so they won't load.

As a quick fix, try running this query in your SQL Toolbox:

UPDATE ibf_emoticons SET clickable=1;


Be sure to change ibf_ in that query to whatever table prefix you use. You'd then need to rebuild your emoticons cache from the Cache Management page on the System tab in the Admin CP. Hopefully that will fix this button for you.

Link to comment
Share on other sites


Ah, this was related to an issue I patched earlier today for version 1.2.1. Basically, the old version of the app looked for any emoticons that you had set to be 'clickable', and showed those in this list. In IP.Board 3.2, that 'clickable' concept is no more, but the clickable field is still there, but set to 0 for all of your emoticons, so they won't load.



As a quick fix, try running this query in your SQL Toolbox:



UPDATE ibf_emoticons SET clickable=1;


Be sure to change ibf_ in that query to whatever table prefix you use. You'd then need to rebuild your emoticons cache from the Cache Management page on the System tab in the Admin CP. Hopefully that will fix this button for you.



You sir, are amazing.
Thanks so much!
Link to comment
Share on other sites

Michael, I know this is a bit early to be asking, and it just crossed my mind, but what are the chances that you would implement the user hover card? Where you put the cursor over a member's name and their card comes up (Send Message, Add as Friend, etc.)

Edit: Wow, I'm dumb. I just now realized their is a Feature Request link.

Link to comment
Share on other sites

After use any popup option in the post editor (add a link, add a picture, etc.) the screen keeps grayed and it is requiered to refresh (F5) to continue, losing any data added.

This started with the SB installation. I disabled the hook, and the problem stopped.

%7Boption%7Dhttp://www.gamingcr.com/images/7-28-2011 11-41-06 PM.jpg

Link to comment
Share on other sites


This is a bug with the sidebar version of the global shoutbox, it doesn't automatically refresh in any browser. I'll have this fixed for the next release.




Would you have any indication as to when you will release a new version including a fix for this? %7Boption%7D

Thanks.
Link to comment
Share on other sites

Hello,

First off i know there is an official tracker thread, I plan on posting there as soon as I get a chance too after that forum is back up from server transfer. Second, Michael, you are awesome.

I installed SB 1.2.0 for my 3.2.0 Forum. It looks great. My only problem is none of the buttons work. I can type text into the shout input field but absolutely none of the buttons work (shout, clear, refresh, smilies, etc etc. ).


Any insight would be great and I hope your server transfer is going smoothly!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...