Jump to content

Secondary Navigation Management System


Robert Simons

Recommended Posts

%7Boption%7D



File Name: Secondary Navigation Management System

File Submitter: Robert Simons

File Submitted: 05 Jun 2011

File Category: Performance



This hook will allow the end user to alter the secondary navigation to allow another application to be the default. It will not effect the default settings for removal of the board index navigation link when not in the forums application nor will it effect the settings in IP.Content for showing the generic 'Pages' navigation bar link. So if you choose to show said settings, it will effect this hooks output, though it will not break the look or structure of the navigation, only add them in their proper locations within the breadcrumb.


NOTE: This version is for 3.2.3 only !!!

For 3.2.2 use the v1.1.1

Pre 3.2.x versions of IPB require 1.0.2 or older



here to download this file

Link to comment
Share on other sites

Just a quick note from a fellow modder, it's probably better to use code in the 'eval php' field for your settings to loop through all apps installed on the site in question, rather than hard-code all of those. It'd be much more flexible as it never needs you as the author of this to update anything for your users to use any apps for it.

Link to comment
Share on other sites

  • 2 months later...

Hi, just install this Hokkaido and throws me this error now I can not remove

Warning: include() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/lang_cache/12/core_public_global.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: Invalid argument supplied for foreach() in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 793 Warning: include(/home/emuleson/public_html/foro/cache/lang_cache/12/forums_public_boards.php) [function.include]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: include() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/lang_cache/12/forums_public_boards.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: Invalid argument supplied for foreach() in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 793 Warning: include_once(/home/emuleson/public_html/foro/cache/skin_cache/cacheid_42/skin_global.php) [function.include-once]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/output/publicOutput.php on line 1769 Warning: include_once() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/skin_cache/cacheid_42/skin_global.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/output/publicOutput.php on line 1769 Fatal error: Class 'skin_global_42' not found in /home/emuleson/public_html/foro/admin/sources/classes/output/publicOutput.php(3366) : eval()'d code on line 13

Warning: include(/home/emuleson/public_html/foro/cache/lang_cache/12/core_public_global.php) [function.include]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791











I uninstalled the Hook but nothing stays the same
Upon entering the admin also fails me, we is loaded this hook my forum

Warning: include() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/lang_cache/12/core_public_global.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: Invalid argument supplied for foreach() in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 793 Warning: include(/home/emuleson/public_html/foro/cache/lang_cache/12/core_admin_global.php) [function.include]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: include() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/lang_cache/12/core_admin_global.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: Invalid argument supplied for foreach() in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 793 Warning: include(/home/emuleson/public_html/foro/cache/lang_cache/12/core_admin_login.php) [function.include]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: include() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/lang_cache/12/core_admin_login.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791 Warning: Invalid argument supplied for foreach() in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 793

Warning: include(/home/emuleson/public_html/foro/cache/lang_cache/12/core_public_global.php) [function.include]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791











My version is 3.2 Forum

Link to comment
Share on other sites

sounds like you have more going on than a hook failure...as this hook would not effect the admin panel at all (its just an override of the front end templates)...

I'de be happy to take a look to see if I could resolve the issue for you.....or you can submit a ticket to IPS....your choice..just lemme know which way you'd like to continue

Link to comment
Share on other sites

Broken Flag Removed

I cannot find anything amiss with this submission, it does work as indicated. :smile: ,

To the reporter: please ensure you are using the latest version as the download page lists four versions. You want the one on the top of the list as that's the latest.

Link to comment
Share on other sites


Broken Flag Removed



I cannot find anything amiss with this submission, it does work as indicated. :smile: ,



To the reporter: please ensure you are using the latest version as the download page lists four versions. You want the one on the top of the list as that's the latest.



Thanks .. I was wondering how I was going to get the "broken file" alert removed after I determined the issue .. now I know LOL
Link to comment
Share on other sites


Thanks .. I was wondering how I was going to get the "broken file" alert removed after I determined the issue .. now I know LOL



I get a notification when a file is reported as broken so I tend to look at it as soon as I can, although it can (not in this case :smile: ) sometimes appear as though nothing is being done, depending on the nature of the report I may have to contact the file submitter and / or the reporter to determine what action if any is required.
Link to comment
Share on other sites


I get a notification when a file is reported as broken so I tend to look at it as soon as I can, although it can (not in this case :smile: ) sometimes appear as though nothing is being done, depending on the nature of the report I may have to contact the file submitter and / or the reporter to determine what action if any is required.



Well from what I can tell, you (and all the other staff members) are doing a great job at moderation. I tend to browse the tech support forums to see if I can help out in some small part .. and see in most cases the topic is responded too in a timely fashion .. not always but most of the time..and considering the amount of postings during a major upgrade release ... its understandable if one gets missed on occasion
Link to comment
Share on other sites


Broken Flag Removed



I cannot find anything amiss with this submission, it does work as indicated. :smile: ,



To the reporter: please ensure you are using the latest version as the download page lists four versions. You want the one on the top of the list as that's the latest.




I made sure on the version you download, the version of my forum corresponds to the shown to use this hook, and my forum worked without any problems before installing this hook, so the problem is the hook
Link to comment
Share on other sites

a complete failure of his board .. he basically gets a white page with errors .. even his acp login page is effected..and the login of the acp either produces the whitepage with errors..and a couple times..just redirected back to admin login page

post-127210-0-13333800-1314387948_thumb.

seems to me to be a language and skin issue of some sort ... going by the errors

Link to comment
Share on other sites

Warning: include(/home/emuleson/public_html/foro/cache/lang_cache/12/core_public_global.php) [function.include]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791

Warning: include() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/lang_cache/12/core_public_global.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791

Warning: Invalid argument supplied for foreach() in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 793

Warning: include(/home/emuleson/public_html/foro/cache/lang_cache/12/forums_public_boards.php) [function.include]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791

Warning: include() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/lang_cache/12/forums_public_boards.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 791

Warning: Invalid argument supplied for foreach() in /home/emuleson/public_html/foro/admin/sources/classes/class_localization.php on line 793

Warning: include_once(/home/emuleson/public_html/foro/cache/skin_cache/cacheid_42/skin_global.php) [function.include-once]: failed to open stream: Permission denied in /home/emuleson/public_html/foro/admin/sources/classes/output/publicOutput.php on line 1769

Warning: include_once() [function.include]: Failed opening '/home/emuleson/public_html/foro/cache/skin_cache/cacheid_42/skin_global.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/emuleson/public_html/foro/ips_kernel/') in /home/emuleson/public_html/foro/admin/sources/classes/output/publicOutput.php on line 1769

Fatal error: Class 'skin_global_42' not found in /home/emuleson/public_html/foro/admin/sources/classes/output/publicOutput.php(3366) : eval()'d code on line 13

thats what I see when I goto his main site url...you can see why I was thinking skin and language issues..as I see alot of skin cache errors

Link to comment
Share on other sites

It can be language problems, but I repeat that the forum was working without any problem until the installation of this gancho.Creo you should check it if it suits the hook all languages

Which table of the database I can change the default sink? to test and try to put the default skin IPBOARD

Link to comment
Share on other sites

yes its setup so any language should be able to be used without issue...

(your prefix)_members is the table .. the fields are "skin" which you should set to 1 for default theme .. might wanna set yourself to english for the language too .. as it also seems to be an issue .. which that field is "language" and for english..it should set to 1

but honestly I dont see that resolving the issue...since your acp is effected as well and it has nothing to do with the skin your currently on (acp has its own independent theme) .. but it can't hurt to make the attempt

Link to comment
Share on other sites


I dont believe he can...as he has no front end or acp interface..just whitepage with the errors



UPDATE core_sys_lang SET lang_default = 1 WHERE lang_id =1;



Best to not run that, as you only want *one* to be default. Will need phpmyadmin to edit that table to ensure to do it properly.

Link to comment
Share on other sites

  • 2 weeks later...

Updated this hook to enable/disable view of the default breadcrumb when viewing the application itself. I also corrected the issue of displaying a hyperlink when viewing the default application, now it only shows when not viewing the default application. Exception to this rule would be if the user has chosen to set "Remove default forums navigation", then the hyperlink will still be produced.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...