Jump to content

(RSyvarth) Social Groups


rsyvarth

Recommended Posts

I have a question and I'm sorry if this has been asked before: this mod allows (or maybe this is planned for a next version) people to invite non-members to join their group? Or, to be more precise, can I send an invite (by email) to someone who is not registered on my forum so that when he receives my invite he will be able to both register on the forum AND join my group? I hope that this makes sense :)

Link to comment
Share on other sites

@StefanV: You're talking about several different features.

1. The current design only allows you to invite existing forum members to join your group.
1a. As far as a future feature that would allow you to invite a non-forum member, not sure if that will make the light of day. With the other mods, like facebook share, people can send out emails to others about their forum, and also about the topics in a forum. You just need to make sure your social group setting is configured to allow 'guests' to view your social group. Adding that kind of feature to the social group may be kind of complicated.

2. You are asking for a one-step process for registration that allows someone to join the overall ipb board and a particular group at the same time. I don't think that is possible with the current IPB design but maybe Robert has other opinions.

- Brian

Link to comment
Share on other sites


I found a bug deleting a group and its forum (table "forum_tracker" is no more with 3.2)





----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Date: anytime

Error: 1146 - Table 'ipb_forum_tracker' doesn't exist

IP Address: xxx.xxx.xxx.xxx - /admin/index.php?app=groups&module=groups&section=groups&do=dodelete&g_id=23

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

mySQL query error: DELETE FROM ipb_forum_tracker WHERE forum_id=932

.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.

| File                                                       				| Function                                                                  	| Line No.      	|

|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|

| admin/applications_addon/other/groups/modules_admin/groups/groups.php  	| [db_main_mysql].delete                                                    	| 788   			|

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

| admin/applications_addon/other/groups/modules_admin/groups/groups.php  	| [admin_groups_groups_groups].projectDoDelete                              	| 119   			|

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

| admin/sources/base/ipsController.php                       				| [admin_groups_groups_groups].doExecute                                    	| 299   			|

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'




I'll add a bug in the tracker. I will fix it in the next version.


I have a question and I'm sorry if this has been asked before: this mod allows (or maybe this is planned for a next version) people to invite non-members to join their group? Or, to be more precise, can I send an invite (by email) to someone who is not registered on my forum so that when he receives my invite he will be able to both register on the forum AND join my group? I hope that this makes sense [img]

[/img]




As Surferboy said, that seems to be slightly out of the scope of this mod currently. If you need this sort of functionality, it would need to be done through a custom modification... but it is possible.
Link to comment
Share on other sites

Any chance of this having more guild friendly add-ons like a full roster that shows everyone and their respectful roles? Also being able to set individual roles that people can apply for in each group and what each group is currently looking for. Like lets say group A needs 2 healers so it would show they need 2 healers and then you could apply as a healer. Also allowing to show what the forum overall needs...

Link to comment
Share on other sites

Hi,

Just have one small problem, I have created a group and posted two news items but the groups home page shows "There are no news articles yet..." in the New Box and "There are no posts in this group yet..." in the Latest Posts box. The Social Groups forum shows "No topics were found. This is either because there are no topics in this forum, or the topics are older than the current age cut-off."

Any ideas or help?

Paul

Link to comment
Share on other sites


Any chance of this having more guild friendly add-ons like a full roster that shows everyone and their respectful roles? Also being able to set individual roles that people can apply for in each group and what each group is currently looking for. Like lets say group A needs 2 healers so it would show they need 2 healers and then you could apply as a healer. Also allowing to show what the forum overall needs...




This may be possible eventually, but it really isn't a priority currently. I am currently busy with a few other projects, but I will start working on a big update to the app soon. I will see if I can include the ability to add more ranks other than the default ones that the groups come with. As for the application for each role, that could be sorted in a topic or something similar but if enough people request a rank application sort of feature, I will consider including it.


Hi,



Just have one small problem, I have created a group and posted two news items but the groups home page shows "There are no news articles yet..." in the New Box and "There are no posts in this group yet..." in the Latest Posts box. The Social Groups forum shows "No topics were found. This is either because there are no topics in this forum, or the topics are older than the current age cut-off."



Any ideas or help?



Paul




This is caused by a forum permissions issue. I will help you in the pm you sent me.


Sorry for asking but is there a functionality for converting an existing forum to a social group and visa versa? or even move single topics from a forum to a social group etc? This would be a very important.




The Social Group forums function just like any other forum, so you can move topics in and out of them and in between "normal" forums and "Social Group" forums at will. So yes, you can convert an existing forum to a Social Group forum by simply moving all of the topics from that forum to the forum which is created for the Social Group.
Link to comment
Share on other sites

I just recently bought the social groups, and i'm having problems with the discussion forums. The forum permissions aren't being created correctly.
They're not loading in any permissions at all.

Also when I go into the social group forum with the shoutbox global hook enabled, it isn't skinned right. It comes out like the attached image

Link to comment
Share on other sites


I just recently bought the social groups, and i'm having problems with the discussion forums. The forum permissions aren't being created correctly.


They're not loading in any permissions at all.




Have you configured the permissions grid under ACP > Social Groups > Forum Permissions? Once you have that configured, you will need to create a new group for the changes to apply to that group.. If you need more assistance with this, please send me a PM.


Also when I go into the social group forum with the shoutbox global hook enabled, it isn't skinned right. It comes out like the attached image




To fix that you simply have to move the "(RSyvarth) Social Group Forum" hook to the bottom of your list of hooks (drag and drop) and it will move the shoutbox back up top.
Link to comment
Share on other sites

Hello, I trying to delete category and here what I see -

There appears to be an error with the database.
If you are seeing this page, it means there was a problem communicating with our database. Sometimes this error is temporary and will go away when you refresh the page. Sometimes the error will need to be fixed by an administrator before the site will become accessible again.

You can try to refresh the page by clicking here

Link to comment
Share on other sites


Hi,



A few layout issues with this as can be seen in the images below:



Forum Group View


post-114071-0-16006900-1313189506_thumb.

Topic Group View


post-114071-0-54934800-1313189497_thumb.

Any ideas how to tidy this up please?



Thanks



Andy




I had to change the way I format the group forums in 3.2 and it seems to cause a few minor visual issues in certain skins. I will look into trying a different method in the next version...


Hello, I trying to delete category and here what I see -



There appears to be an error with the database.


If you are seeing this page, it means there was a problem communicating with our database. Sometimes this error is temporary and will go away when you refresh the page. Sometimes the error will need to be fixed by an administrator before the site will become accessible again.



You can try to refresh the page by clicking

here


It would help if you could give me the actual error which you are getting. Try deleting a category, then go to '/cache/sql_error_latest.cgi' and PM what the contents are.
Link to comment
Share on other sites

I've gone and given myself a nightmare.

1. Invision carried out the upgrade to 3.2 for me. All seemed OK.
2. I deleted v1 of the Groups software
3. Whilst installing v1.2.1 there must have been some form of error as I was dumped back to a database error screen.
4. I couldn't access the ACP but Invision resolved that.
5. With the Groups module disabled and the forum switched to Performance Mode I've now got back into the forum

I feel like I've sawn the tree branch off that I was sitting on. %7Boption%7D

Any ideas on my next steps to resolve this?

Link to comment
Share on other sites


I had to change the way I format the group forums in 3.2 and it seems to cause a few minor visual issues in certain skins. I will look into trying a different method in the next version...



Any idea when this might be and thanks for your attention to this.

Great APP and equally as good support.
Link to comment
Share on other sites


Yes, I am aware of this bug. A fix for this should also be included in the next version.



Look forward to it.

In addition to the issues I have posted in the posts above I have also noticed a character issue best seen in the image below:

post-114071-0-99891500-1313548260_thumb.


@Azoun



Just replace this at the end of the template skin_groups --> groupForumSidebar



<if test="$this->request['section'] == 'post' ">margin-top: 0px;<else />margin-top: -30px;</if>

with something like this:

margin-top: 15px;



Sorry replace what exactly?
Link to comment
Share on other sites


@Azoun



Just replace this at the end of the template skin_groups --> groupForumSidebar



<if test="$this->request['section'] == 'post' ">margin-top: 0px;<else />margin-top: -30px;</if>

with something like this:

margin-top: 15px;



I have done this and whilst it does improve it somewhat it still doesn't look like the equivalent does in the forum as can be seen in the two images below:

Groups
post-114071-0-52030600-1313559587_thumb.

Forum
post-114071-0-74481800-1313559599_thumb.

I suspect I will need to wait for an update to this excellent mod to have this sorted. Thanks for your suggestion though, much appreciated.
Link to comment
Share on other sites

Hi Robert,
I have been playing with your mod for the past day or so and I have a few questions.

1. Is there some secret way of getting the discussions to work? I assigned a category in the ACP and I have given everyone permission to access the forum in the group but for some reason I am unable to access them.

2. Uploading the logo background image seams to be resizing it to the height of the logo. Any easy way to turn this off?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...