Jump to content

Classifieds


Andy Millne

Recommended Posts

Hello,
When doing a search, the featured ads come up first instead of what is searched for. This could be an issue because if you have a lot of featured listings, someones going to have to thumb through a lot of listings before they get exactly what they want. When using the search specifically end users need to be able to find what they are looking for at the top imo. Not sure if this is a bug or not, just a mention though.

Kind Regards

Link to comment
Share on other sites


[color=#282828][font=helvetica, arial, sans-serif]Is there any way I could for (some categories) completely [/font][/color]disable the Price Field[color=#282828][font=helvetica, arial, sans-serif]? I have some categories where members are looking for pen friends (and many other non profit ones) And I would like to avoid people thinking of what should they fill if the price is not applicable. I think it would generally be very usefull. [/font][/color]




The only way to disable the price field currently is to skin it out completely. This is something I will be adding for 1.3.


Hello,


When doing a search, the featured ads come up first instead of what is searched for. This could be an issue because if you have a lot of featured listings, someones going to have to thumb through a lot of listings before they get exactly what they want. When using the search specifically end users need to be able to find what they are looking for at the top imo. Not sure if this is a bug or not, just a mention though.




This is working as intended I think but you do make a good point. Are the featured items in the search results not relevant to the search term? If so that is indeed a bug but I don't think that is what you are describing. If featured adverts are relevant to the search term and appear at the top I would say that should be the case otherwise they would not be featured ads. I'm willing to act on feedback here however if the general consensus is there is a better approach.
Link to comment
Share on other sites

I'll go ahead and help out this last time Andy, the featured items in the search are not related to the initial search but they show first anyhow.

Example, let's say I am selling domains, I have Mi.com for sale and there's a featured ad called MemberMedical.com, MemberMedical.com will appear before Mi.com. Remove MemberMedical.com and Mi.com shows up at top. Do a search for anything with M and MemberMedical.com shows up first because it's featured. The only time I would think anything featured should show up in search is when I search for that term or beginning of term. Featured should not take any precedence over the initial search term imo.

There's other issues, I have reported some to you by pm also, since I can't get a simple escrow function for sales and big ticket items which renders my buy useless I have to bow out for future help. Good luck.

Link to comment
Share on other sites

Few questions before buying...

Is it possible for users to buy pre-paid credits and then spend it when they want to? (paying small amount each time, will give more money to 2CO than us :( )

Can user buy package to allow him to set classified as featured for eg. 30days?

Link to comment
Share on other sites

Andy -

We have classifieds up and running. But I keep getting an error when trying to upload photos and attachments.

It says "Upload skipped: Error 401"


Other places in the system we can upload files and images without problems. Any idea whats up with this?

Link to comment
Share on other sites

Hi,
I'm getting this error when trying to add a new category

Latest SQL Error Today (3 minutes ago)
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- Date: Sat, 18 Feb 2012 12:48:07 +0000 Error: 1364 - Field 'lft' doesn't have a default value IP Address: 192.168.10.1 - /admin/index.php?adsess=6785c70d2bad81f0a68238d3fff7bebd&app=classifieds&&module=manage&section=categories&&do=doaddcat ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- mySQL query error: INSERT INTO classifieds_categories (`name`,`parent_id`,`seo_title`,`description`,`fieldset_id`,`advert_types`,`sort_order`) VALUES('Contractors For Hire',1,'contractors-for-hire','Contractors For Hire',0,'*',1) .--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------. | File | Function | Line No. | |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------| | R:ITProffs.v4adminapplications_addonotherclassifiedsmodules_adminmanagecategories.php| [db_main_mysql].insert | 272 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | R:ITProffs.v4adminapplications_addonotherclassifiedsmodules_adminmanagecategories.php| [admin_classifieds_manage_categories].categorySave | 84 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | R:ITProffs.v4adminsourcesbaseipsController.php | [admin_classifieds_manage_categories].doExecute | 302 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

Any ideas? :)

Link to comment
Share on other sites

This happened after I added a new package. It only shows up at http://www.emtcity.c...ort_order__desc


Warning: Invalid argument supplied for foreach() in /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php on line 397

Warning: Invalid argument supplied for foreach() in /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php on line 415

Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 114

Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 127

Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 136

Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 137

Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 141

Link to comment
Share on other sites

Hello,

We are using IP.Board 3.2.1, and we purchased this mod and we were able to FTP the necessary upload files.

We also were able to install the mod and create a package and various fields and categories.

The mod is currently enabled; however, whenever a forum user attempts to click on the "Classifieds" tab, they receive the following error on a white page:

Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /home/agentque/public_html/cache/skin_cache/cacheid_8/skin_classifieds.php on line 126

Can you let us know what you think?

Link to comment
Share on other sites

Looking for help to un-install then re-install. When I attempt to Uninstall this app, I get a driver error "There appears to be an error with the database. ". While working on the language files we had a few issues with the cache file.

When attempting to uninstall it deletes the DB tables but not the files.

********************************************************************************

here's my sql_error_latest.cgi report

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Date: Sun, 19 Feb 2012 11:32:35 +0000
Error: 1146 - Table 'a0026398.ibf_classifieds_categories' doesn't exist
IP Address: 98.208.90.237 - /forums/admin/index.php?adsess=f9b648a72d0d8ed43b7fdb4217f7de8c&app=classifieds&module=manage&section=categories&do=managecategories
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
mySQL query error: SELECT category_id,parent_id,sort_order,name,lft,rgt,depth,seo_title,description,fieldset_id,advert_types FROM ibf_classifieds_categories WHERE category_id = 1
.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| File | Function | Line No. |
|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
| admin/applications_addon/other/classifieds/sources/classes/classifieds/categories.php| [classifieds_categories].getNode | 129 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/applications_addon/other/classifieds/modules_admin/manage/categories.php| [classifieds_categories].getDescendants | 145 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/applications_addon/other/classifieds/modules_admin/manage/categories.php| [admin_classifieds_manage_categories].manageCategories | 76 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/base/ipsController.php | [admin_classifieds_manage_categories].doExecute | 302 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'




Thanks,
Luni

Link to comment
Share on other sites


Hello,



We are using IP.Board 3.2.1, and we purchased this mod and we were able to FTP the necessary upload files.



We also were able to install the mod and create a package and various fields and categories.



The mod is currently enabled; however, whenever a forum user attempts to click on the "Classifieds" tab, they receive the following error on a white page:



Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /home/agentque/public_html/cache/skin_cache/cacheid_8/skin_classifieds.php on line 126



Can you let us know what you think?




Okay, looks like we solved our own problem.

We went back and double checked every single upload file, and made sure we FTP'ed the correct upload files via the correct pathways.

As a result, we realized that we were missing the admin-->sources-->template plugins-->tp_time_until.php file

We also had trouble following the right pathway in order to properly upload the public-->style_css-->master_css and master_css mobile

However, this is an issue with our inexperience, not with this application.

Once we corrected our error, it still didn't work UNTIL we recached both the module AND our skin template.

Here's how we accomplished this:

Recache of the Classified App -->ACP-->System-->Manage Applications & Modules-->"Recache Apps and Modules" Button at the top

Recache of our skin template-->ACP-->Look & Feel-->Template Tools-->Recache Skin Sets-->Select a Skin Set dropdown-->"be sure to select the proper skin"--RECACHE SKIN SET button
Link to comment
Share on other sites

Any suggestions for a fix?


This happened after I added a new package. It only shows up at

http://www.emtcity.c...ort_order__desc


Warning: Invalid argument supplied for foreach() in /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php on line 397



Warning: Invalid argument supplied for foreach() in /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php on line 415



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 114



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 127



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 136



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 137



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 141


Link to comment
Share on other sites

Hello Andy, we have reached a new stage of developing our site and found very important the need of being able to rss export the post on the category basis. I would be willing to pay extra for having this feature prioritized. Would it be something that could be done?

At present we are creating a facebook fan page for each country our compatriots are living/working, at present we are rss importing forums and calendar data from our main IP presentation and having the option to import the classified listings related to their particular country would be a great help for them. :) Many thanks for your consideration.

Link to comment
Share on other sites


A field set is a group of custom fields that can then be assigned to a category. As an example you might want to have a category for cars. You could then set up a "cars" field set and add fields for engine size, colour, make, model etc. and then assign it to the cars category. You could then have a completely seperate category for real estate and in that category a field set that contains fields for number of bedrooms/bathrooms, plot size etc.




We just purchased this mod, and are attempting to configure it.

We understand this concept of custom fields and field sets, and we were hoping to use it.

However, when we click on Manage Custom Fields link, we can only create and customize the Global Fields (the ones appearing on ALL the adverts.)

When we click on "Add Field Set", it only gives us an input box called "Set Name" with an ADD SET button.

However, shouldn't there be a way to create and associate custom fields TO the field sets?

Otherwise, the field set just exists without any custom fields attached to it... right?

Are we missing files or functionality?
Link to comment
Share on other sites


Still waiting for a fix....



I ran into a "similar" issue with Nexus. My issue turned out to be with memcache. After adding a package, I got those errors until I restarted memcache. If you're running an external cache, it's something to try? If not, did you try to rebuild the HTML in the skins screens?
Link to comment
Share on other sites


Example, let's say I am selling domains, I have Mi.com for sale and there's a featured ad called MemberMedical.com, MemberMedical.com will appear before Mi.com. Remove MemberMedical.com and Mi.com shows up at top. Do a search for anything with M and MemberMedical.com shows up first because it's featured. The only time I would think anything featured should show up in search is when I search for that term or beginning of term. Featured should not take any precedence over the initial search term imo.




I cannot reproduce this issue locally. Only relevant results are showing in my search results regardless of featured status. I suspect the "com" aspect following the period may be matching as a separate word due to the way MySQL searching works. Could you please provide ACP/FTP access so I may investigate?

Few questions before buying...



Is it possible for users to buy pre-paid credits and then spend it when they want to? (paying small amount each time, will give more money to 2CO than us

)



Can user buy package to allow him to set classified as featured for eg. 30days?




Separate packages can be defined in the ACP to allow 30 day featured adverts but it is currently not possible to pre-pay for multiple listings.


Andy -



We have classifieds up and running. But I keep getting an error when trying to upload photos and attachments.



It says "Upload skipped: Error 401"




Other places in the system we can upload files and images without problems. Any idea whats up with this?




401 is a server error and is thrown when a request requires authentication. I can't see why that would be the case here. Again I'd need ACP/FTP access to investigate. Could you please PM that info?


Hello, I am usinga translatorbecause my Englishis very basic.I havesome problems withthe classifieds, I can notmake the buttonto addan ad isdisplayed to usersand evenadministrators.I can not findthe permissions tochange this,any helpis welcome,I'm newusingIPB.Thank you.




Please check your group permissions from ACP > Members > Manage Member Groups > (edit) > Classifieds


Hi,


I'm getting this error when trying to add a new category



Latest SQL Error Today (3 minutes ago)





Problem solved, I had Strict Mode enabled in MYSQL.


Disabling it solved the problem.




This is still an issue I will need to resolve, Classifieds should be compatible with strict mode so I will make sure that gets fixed up. thank you for bringing it to my attention.


This happened after I added a new package. It only shows up at

http://www.emtcity.c...ort_order__desc


Warning: Invalid argument supplied for foreach() in /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php on line 397



Warning: Invalid argument supplied for foreach() in /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php on line 415



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 114



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 127



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 136



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 137



Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/emsonli/forum/cache/skin_cache/cacheid_1/skin_classifieds.php:397) in /usr/www/users/emsonli/forum/admin/sources/classes/output/formats/html/htmlOutput.php on line 141




This is most likely caused by the IPB bug whereby templates were not getting properly imported due to no default key being set. If you not only recache the skin but first use the tool to rebuild master templates for the classifieds application this should be resolved. If not please provide an admin login so I may investigate.


Looking for help to un-install then re-install. When I attempt to Uninstall this app, I get a driver error "There appears to be an error with the database. ". While working on the language files we had a few issues with the cache file.



When attempting to uninstall it deletes the DB tables but not the files.



********************************************************************************



here's my sql_error_latest.cgi report



----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


Date: Sun, 19 Feb 2012 11:32:35 +0000


Error: 1146 - Table 'a0026398.ibf_classifieds_categories' doesn't exist



--------------------------------------------------------------------------------------------------------------------------------------------------------------------------




I believe I answered your PM, once again please accept my apologies for the gap in support.


Okay, looks like we solved our own problem.



We went back and double checked every single upload file, and made sure we FTP'ed the correct upload files via the correct pathways.



As a result, we realized that we were missing the admin-->sources-->template plugins-->tp_time_until.php file



We also had trouble following the right pathway in order to properly upload the public-->style_css-->master_css and master_css mobile



However, this is an issue with our inexperience, not with this application.



Once we corrected our error, it still didn't work UNTIL we recached both the module AND our skin template.



Here's how we accomplished this:








I'm glad you were able to resolve this issue on your own. Please feel free to PM me directly if you require any further assistance.


Hello Andy, we have reached a new stage of developing our site and found very important the need of being able to rss export the post on the category basis. I would be willing to pay extra for having this feature prioritized. Would it be something that could be done?




Per category RSS feeds have been added to the todo list for 1.3


We just purchased this mod, and are attempting to configure it.



We understand this concept of custom fields and field sets, and we were hoping to use it.



However, when we click on Manage Custom Fields link, we can only create and customize the Global Fields (the ones appearing on ALL the adverts.)



When we click on "Add Field Set", it only gives us an input box called "Set Name" with an ADD SET button.



However, shouldn't there be a way to create and associate custom fields TO the field sets?



Otherwise, the field set just exists without any custom fields attached to it... right?



Are we missing files or functionality?




Once you have created the field group you should be able to add fields within it. Click the group title then check the buttons on the resulting page.


Can anyone tell me why when going to my settings, and ticking the classified notifications, then save it doesn't hold these changes?




Notification settings are working locally for me. If you would like me to investigate anything specific to your site please send me a PM with connection details.

If I have missed any queries within this topic please do not hesitate to send me a PM. I have no objections to answering support queries via PM as the structured nature of the responses often means I can deal with them in a more organised manner than hunting through a single support topic.
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...