Jump to content

(DP34) Global Sidebars


DawPi

Recommended Posts

  • Replies 1k
  • Created
  • Last Reply

bakermi1: I see that all works fine! :o

This is what I see:
%7Boption%7Dpre_1303222452__1.png' alt='' class='ips" alt="" class="ipsImage">
%7Boption%7Dpre_1303222464__2.png' alt='' class='ips" alt="" class="ipsImage" width="1000" height="559">
%7Boption%7Dpre_1303222477__3.png' alt='' class='ips" alt="" class="ipsImage" width="1000" height="518">

The same good skin is when I logged id. So what's wrong?

Link to comment
Share on other sites

  • 2 weeks later...

I don't have any custom skins but do have the problem on the mobile skin as long as I enable the hook. I can disable on mobile skin and/or XML, does not make any difference. If I disable the hook and refresh on my mobile device (Iphone 4 using the IPB app btw) all is fine once again.

Still no fix for this?

Link to comment
Share on other sites


I don't have any custom skins but do have the problem on the mobile skin as long as I enable the hook. I can disable on mobile skin and/or XML, does not make any difference. If I disable the [u]hook[/u] and refresh on my mobile device (Iphone 4 using the IPB app btw) all is fine once again.



Still no fix for this?




DawPi,

Same issue for us here, we've disabled the sidebars for the mobile skin, and if you view the forum as a guest everything works, but the minute you login everything breaks in the mobile skin. The odd thing is the sidebars are enabled for guests and members, but only Guests are able to use the mobile skin whereas members get a broken interface (not loading forum, thread or post list - just title, breadcrumb nav and footer).

I've kept the sidebar enabled on one of our new forums:

http://rangersfanzone.com

If you go there as a guest everything works fine, the minute you login everything breaks. I'm sending you a PM with a test account login for you to check.
Link to comment
Share on other sites

tired170:
When I'm logged in:
%7Boption%7Dpre_1305144968__2011-05-11_22-15-46.png'" alt="" class="ipsImage" width="1000" height="548">
%7Boption%7Dpre_1305144980__2011-05-11_22-15-54.png'" alt="" class="ipsImage" width="1000" height="490">

And logged out:
%7Boption%7Dpre_1305145022__2011-05-11_22-16-44.png'" alt="" class="ipsImage" width="1000" height="510">
%7Boption%7Dpre_1305145034__2011-05-11_22-16-52.png'" alt="" class="ipsImage" width="1000" height="490">

So as you can see I can't reproduce this error. Could you show me screens how it looks on your board?

P.s. I'm also working on the new version and I've checked code triple times - all is okay for me.

Link to comment
Share on other sites

New version is almost ready! I must make few more tests!

What's new:

  • added option exclude selected groups from viewing each sidebar,
  • add new sidebar type - 'standard' - the same as on the main board page,
  • added option to see sidebar on the right or the left of the board,
  • added option to disable 'forum' sidebar type in specified forums.


Any other suggestions before final release?
Link to comment
Share on other sites

I would like to add several 'blocks' beneath each other with their own title. Just like a single hook could do.

As of the mobile skin problem, get an iPhone somewhere and use Safari or the IPB app to open the forums. Not use a PC and just select the mobile skin (works here). Somehow the code breaks the index on the real mobile device, what I tested is an iPhone 4 using the IPB app.

I cannot use this mod if it breaks my mobile pages. There are many visitors using their mobile device to browse these days.

Link to comment
Share on other sites

An addendum to my previous post:

Our business requires that we can add individual boxes for content and have these throughout the entire forum, as well as being able to allow the user to show and hide these in the same way that the official blocks work. We bought your mod and unfortunately, as it doesn't meed our needs we won't be using it just yet. However, if you can add the features requested above then your mod would be absolutely perfect.

Is this something you will be adding in in the future? or can we request this addition.

You can see an example of another mod we are currently using here: Police Specials forum, however that mod is limited in that it does not go through all of the areas of the forum, other than that it has all of the functionality we require.

Link to comment
Share on other sites

When I opted for slidebar to be on left side the width is not the same as was on left side on the board index

left side
http://spicyflavours.net/


Right side
http://mechanical-engineering.in/forum/

even the percentage change from 84 and 15 to 80 and 19 kept the things same

Link to comment
Share on other sites

Hi, after adding any type of sidebar I get an issue related view in topic. As you can see on screenshots there is a green background in topic block and it is the same background I use for Ad Code Integration in Header Code.

How can I fix this issue? Thanks

Link to comment
Share on other sites

With FireBug (thanks for suggestion) I found issue by myself but I am not able to fix it.

This is the code that create issue.. How can I fix it?

<div class="bannerFooter"><script type='text/javascript'><!--//<![CDATA[

   document.MAX_ct0 ='';

   var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');

   var m3_r = Math.floor(Math.random()*99999999999);

   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);

   document.write ("zoneid=20052");document.write("&nodis=1");

   document.write ('&cb=' + m3_r);

   if (document.MAX_used != ',') document.write ("&exclude=" + document.MAX_used);

   document.write (document.charset ? '&charset='+document.charset : (document.characterSet ? '&charset='+document.characterSet : ''));

   document.write ("&loc=" + escape(window.location));

   if (document.referrer) document.write ("&referer=" + escape(document.referrer));

   if (document.context) document.write ("&context=" + escape(document.context));

   if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {

       document.write ("&ct0=" + escape(document.MAX_ct0));

   }

   if (document.mmm_fo) document.write ("&mmm_fo=1");

   document.write ("'></scr"+"ipt>");

//]]>--></script><noscript><a href='http://cas.criteo.com/delivery/ck.php?n=7d84005d&cb=74df101608' target='_blank'><img src='http://cas.criteo.com/delivery/avw.php?zoneid=20052&n=7d84005d&ct0=' border='0' alt='' /></a></noscript></div>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...