Jump to content

Download: (SOS31) Emoticons and BBCodes in Members Profile Comments v1.0.0


Adriano Faria

Recommended Posts

Hey Adriano,

first of all: I really love this hook. :)

Unfortunately I have a problem. I tested the hook in my profile on my board. When I add text and emoticons it works fine. It also works fine with just adding a video.
But when adding a video and text/emoticons it messes up the comments. I checked the database for the comment I added (a youtube video followed by text and 2 emoticons) and that's the comment in the database:

<object width="425" height="355"><param name="movie" value="http://youtube.com/v/RHV6QDBAYLM&fs=1&hl=en_US"></param><param name="allowFullScreen" value="true"></param><param name="wmode" value="transparent"></param><embed src="http://youtube.com/v/RHV6QDBAYLM&fs=1&hl=en_US" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" wmode="transparent" width="...

You see it ends with "..." in the middle of the video code. Video is displayed nevertheless but like I said it messes up the comments... here's the source code:

<div id="comment_1401" class="comment_content">


							<object height="355" width="425"><param name="movie" value="http://youtube.com/v/RHV6QDBAYLM&amp;fs=1&amp;hl=en_US"><param name="allowFullScreen" value="true"><param name="wmode" value="transparent"><embed src="http://youtube.com/v/RHV6QDBAYLM&amp;fs=1&amp;hl=en_US" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" wmode="transparent" http:="" shakiraforum.de="" user="" 302-niki="" width="...

						&lt;/div&gt;

						&lt;ul class='comment_options'&gt;

								&lt;li&gt;

									&lt;a href='http://shakiraforum.de/index.php?app=members&amp;module=profile&amp;section=comments&amp;do=delete&amp;comment_id=1401&amp;member_id=1&amp;secure_key=fd202d1e3adacb85ce366fdde154c810' title='Delete this comment' class='delete_comment'&gt;Delete&lt;/a&gt;

								&lt;/li&gt;


							&lt;/ul&gt;

					&lt;/div&gt;

				&lt;/li&gt;



			&lt;li id='comment_id_1377'&gt;

					&lt;div class='comment clearfix off '&gt;

						&lt;img src='http://shakiraforum.de/uploads/profile/photo-thumb-302.png' width='50' height='29' class='photo' alt='Photo' /&gt;

						&lt;h4&gt;

							&lt;a href=">Niki&nbsp;<a href="http://shakiraforum.de/user/302-niki/" class="__user __id302" title="View Profile"><img src="		" alt=""></a>


I tried it with different media services (youtube, myvideo, google video, myspace video etc.). Any ideas? Cause I really like the fact users can share their favorite videos etc. on friends profiles... :) I have version 3.1.4, tried with IP.Board skin and a custom skin. EDIT: Ok, I found out that when you post a video only it seems as if the video is posted correctly but when you check the database entry it ends the same way like posted above... with "..."

<object style='width:470px;height:285px;' width='470' height='285'><param name='movie' value='http://www.myvideo.de/movie/7961418/Schlittengaudi_2'></param><param name='AllowFullscreen' value='true'></param><param name='AllowScriptAccess' value='always'></param><embed src='http://www.myvideo.de/movie/7961418/Schlittengaudi_2' width='470' height='285' type='application/x-shockwave-flash' allowsc...



It's also like that in the source code.

Could it be that there's a character limit in profile comments?

Link to comment
  • 5 weeks later...
  • 2 years later...

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...