Jump to content

(M34) Videos System


Michael.J

Recommended Posts

whats memory limit set to in php.ini?

looks like you are set to approx 1gb memory, when I was streaming a lot of videos through a php based site I had to use 2gb.

more addons/users/strain etc adds up, you may have been close but just never quite triggered the error in the past.

I did see less strain enabling pseudostreaming in apache.

not positive but thinking it may be due to many people watching the videos at once, know avsim is busy site.

Mike John may think otherwise though as there is the other error I don't know about.

Link to comment
Share on other sites

whats memory limit set to in php.ini?

looks like you are set to approx 1gb memory, when I was streaming a lot of videos through a php based site I had to use 2gb.

more addons/users/strain etc adds up, you may have been close but just never quite triggered the error in the past.

I did see less strain enabling pseudostreaming in apache.

not positive but thinking it may be due to many people watching the videos at once, know avsim is busy site.

Mike John may think otherwise though as there is the other error I don't know about.

Misunderstanding. I am trying to create categories and that is the error that is thrown when I do. We won't be streaming video but provide a simple library of videos hosted elsewhere.

Link to comment
Share on other sites

I updated to the new version...and it made a complete mess out of everything.

My featured videos dissapeared, the video comments dissapeared, the thumbnails of latest member videos dissapeared, videos titles dissapeared...in short everything was pretty much unusable. I had to restore my old files and database but it was a nerve wrecking expirience. If I have time I will try to see what went wrong on a test installation, but so far I am happy that everything is back to normal. As the old saying goes "if it ain't broke, don't fix it". 3.0.1. is still working pretty well for me...

Link to comment
Share on other sites

Please, advise how to add the following stream video code:

I've send a PM with some code for you to test out. I'll need to test out the secuirity inplications before I add it as standard.

I have gone back in this topic to earlier this year to see if this was reported and there was a fix available. There wasn't as far as I could find. I have also reported this to Mike in the DEVFUSE Ticket System yesterday. I will cross post it here hoping to hear from someone with a fix. It is probably something stupid we are doing, but I need to ask anyway.

I'm just preperaing a list of possibles causes for you to troubleshoot. But I can only theorize at this point, I may need forum access to get in and look through the code more.

I updated to the new version...and it made a complete mess out of everything.

My featured videos dissapeared, the video comments dissapeared, the thumbnails of latest member videos dissapeared, videos titles dissapeared...in short everything was pretty much unusable. I had to restore my old files and database but it was a nerve wrecking expirience. If I have time I will try to see what went wrong on a test installation, but so far I am happy that everything is back to normal. As the old saying goes "if it ain't broke, don't fix it". 3.0.1. is still working pretty well for me...

I can't explain why that would be. I've found v3.0.2 very stable and so far with only 1 or 2 bug reports. If you do manage to get that test installation setup, let me know and I can be on hand if your able to reproduce this again. v3.0.2 fixes a lot of bugs but there is nothing major done in the upgrade files.

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...
  • 4 weeks later...

ok love this video system its a main feature on my board yet where can i set the users for the video banner on the index page i would like to turn that off for one group

As in the global videos hook? The only permission that this follows is the view videos one in acp > members tab > manage member groups > videos system tab.

Link to comment
Share on other sites

I have a question that may have been answered in this thread, but my searching has turned up nothing. When I began the installation, it gave me an error that the videos, thumbnails and cat_images folders were not writable and to change the permissions. I did and it installed nicely. My question is, what should these folders be set at from here on out?

Thanks for your time in answering my question.

Eric B)

Link to comment
Share on other sites

I have a question that may have been answered in this thread, but my searching has turned up nothing. When I began the installation, it gave me an error that the videos, thumbnails and cat_images folders were not writable and to change the permissions. I did and it installed nicely. My question is, what should these folders be set at from here on out?

Exactly the same as what you have set for your uploads folder. That should allow for videos/thumbnails to be uploaded without any problems.

Link to comment
Share on other sites

  • 1 month later...

What happened when original video deleted in youtube. Suppose I have more than 200 video and 30 are deleted. Can I fix or delete Youtube deleted videos using quick search or I have to manually find them and delete.

You would have to fix them manually at this point. I'll look at including something to deal with this in the rebuild tools in a future version.

Link to comment
Share on other sites

Hi Mike,

I also catch following SQL error in error-logs:

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 Date: Tue, 03 Sep 2013 15:43:14 +0000
 Error: 1054 - Unknown column 'ranking' in 'order clause'
 IP Address: 178.154.243.114 - /index.php?app=core&module=search&do=user_activity&sid=2d512d34a8be6d5750815d9d7299cafe&mid=2&search_app=videos&userMode=title&search_app_filters[videos][searchInKey]=videos&search_app_filters[videos][videos][sortKey]=relevancy&search_app_filters[videos][videos][sortDir]=0
 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 mySQL query error: SELECT v.*, v.description LIKE '%%',mem.member_id, mem.members_seo_name, mem.members_display_name, mem.member_group_id, mem.mgroup_others FROM ibf_videos v  LEFT JOIN ibf_members mem ON ( mem.member_id=v.author_id )   WHERE v.cid IN(1,2,3) AND v.author_id=2 AND v.status=0 ORDER BY ranking desc LIMIT 0,25
 .--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.

I don't know where this link is actually located, but still... you can try to reproduce by following same kind of link on your dev board: /index.php?app=core&module=search&do=user_activity&sid=2d512d34a8be6d5750815d9d7299cafe&mid=2&search_app=videos&userMode=title&search_app_filters[videos][searchInKey]=videos&search_app_filters[videos][videos][sortKey]=relevancy&search_app_filters[videos][videos][sortDir]=0

Did you manage to fix this as I am now also getting sql errors with this app that are breaking the database.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Date: Tue, 22 Apr 2014 07:41:35 +0000
Error: 1054 - Unknown column '66' in 'order clause'
IP Address: removed - /videos/list-all/?listview=1&sort_by=66&sort_order=asc
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
mySQL query error: SELECT v.*,f.f_vid, f.f_mid,m.member_id, m.member_group_id,xxx.* FROM ibf_videos v LEFT JOIN ibf_videos_favorites f ON ( f.f_vid=v.tid )
LEFT JOIN ibf_members m ON ( v.author_id=m.member_id )
LEFT JOIN ibf_core_tags_cache xxx ON ( xxx.tag_cache_key=MD5(CONCAT('videos',';','videos',';',v.tid)) ) WHERE v.status=0 GROUP BY v.tid ORDER BY 66 asc LIMIT 0,20
.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| File | Function | Line No. |
|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
| admin/applications_addon/other/videos/modules_public/display/index.php| [public_videos_display_index].catView | 41 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/base/ipsController.php | [public_videos_display_index].doExecute | 306 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Date: Tue, 22 Apr 2014 08:35:50 +0000
Error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '"; waitfor delay '0:0:4' -- LIMIT 20,20' at line 3
IP Address: removed

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Date: Tue, 22 Apr 2014 06:50:23 +0000
Error: 0 -
IP Address: removed - /videos/list-all/?listview=1&sort_by=video_rating'%2b(select%201%20from%20(select%20sleep(4))A)%2b'&sort_order=desc&st=40
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
SUB SELECT query joins are not allowed.
Add ipsRegistry::DB()->allow_sub_select=1; before any query construct to allow them
.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| File | Function | Line No. |
|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
| admin/applications_addon/other/videos/modules_public/display/index.php| [public_videos_display_index].catView | 41 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/base/ipsController.php | [public_videos_display_index].doExecute | 306 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

- /videos/list-all/?sort_by=date&sort_order=desc%22;%20waitfor%20delay%20'0:0:4'%20--%20&st=20
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
mySQL query error: SELECT v.*,f.f_vid, f.f_mid,m.member_id, m.member_group_id,xxx.* FROM ibf_videos v LEFT JOIN ibf_videos_favorites f ON ( f.f_vid=v.tid )
LEFT JOIN ibf_members m ON ( v.author_id=m.member_id )
LEFT JOIN ibf_core_tags_cache xxx ON ( xxx.tag_cache_key=MD5(CONCAT('videos',';','videos',';',v.tid)) ) WHERE v.status=0 GROUP BY v.tid ORDER BY date desc"; waitfor delay

'0:0:4' -- LIMIT 20,20
.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| File | Function | Line No. |
|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
| admin/applications_addon/other/videos/modules_public/display/index.php| [public_videos_display_index].catView | 41 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/base/ipsController.php | [public_videos_display_index].doExecute | 306 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...