Jump to content

(M34) Videos System


Michael.J

Recommended Posts

The files on my site and the marketplace are completely the same. To do otherwise would be unfair to some of my customers. Yes I'll stage a big update in a few steps to avoid support overload. But if I have patched a file, I will update both sites within minutes of each other.


Just 1 example:
As I saw, 'Error on language change' was fixed on the Jun 16 2013 07:35 PM on your site. I reported about this on the 21 June 2013 - 08:40 AM for the files which were purchased from you by my employer on the Jun 18 2003. And your files were not changed on Marketplace and it was v.3.0.0 here until yesterday.

So, you could just tell the truth that you did not added this fix to the sold on the 18th June 2003 product. At least you could focus my attention on your fix to avoid any questions. But other man did this instead of you. But you began to fight telling: "I'm not seeing any purchase data from your username, if you purchased through my site, you will have access to the support tickets."

I've been creating mods for IPB for close to a decade now. I've dealt will probably a few thousand members, customers, staff etc.. and 99.5% of them have been an absolute pleasure to deal with. But you sir have been one of the worst. You openly flaunt that your using my application without buying it and then you expect me to reply to your support questions.


I am still considering of purchasing your addon. But as I could see in your fixed bugs list, you did not improve the reported bugs:

1) http://community.invisionpower.com/topic/326137-download-m34-videos-system/?p=2415093
2) http://community.invisionpower.com/topic/326137-download-m34-videos-system/?p=2415735

So, my duty is to report this to the customers who will deside to purchase this.

Even that I can let pass but your attitude is what turns off a lot of modders from IPB.

I've tried to be patient and professional with you but I suggest looking elsewhere. As a matter of principle I can't support you.


You are not supporting me, since you can not support me. I believe that only God can do this. You are supporting the products sold via Marketplace since this is the policy here. Otherwise you will not be able to be the part of the comunity here and be the contributor. At least for the paid files. I did not insult you personally anywhere. I just told you about found bugs and you may wish to be thankful for this since you got the funds from my employer who gave me your product to translate. Please, do not strike a pose and improve the above mentioned bugs. I am still considering of purchasing your product for my personal use.
Link to comment
Share on other sites

Thank you a lot Mike! I've just installed the app but there isn't a featured videos bloc on the portal page. Could you tell me, how can I mark a video like featured?

I'm pretty sure it uses the system "like" system so it should work the same as forums. SO if you are using Reputation on your forums then you get the rep number not Like. If you are using Like then you get the Like This button.

Link to comment
Share on other sites

I'm pretty sure it uses the system "like" system so it should work the same as forums. SO if you are using Reputation on your forums then you get the rep number not Like. If you are using Like then you get the Like This button.

It doesn't work... I still can't see a features video block...

Futhermore, I have bugs...

1. When users try to use mobile skin they see a error on the white page:
Fatal error: Call to a member function portalIndex() on a non-object in/usr/www/users/tradee/admin/applications_addon/other/videos/modules_public/display/index.php on line 376

2. Moreover, users can't see the page /index.php?app=videos I, like an admin, and guests can, but users can't... Fatal error: Call to a member function menu() on a non-object in /usr/www/users/tradee/admin/applications_addon/other/videos/sources/functions.php on line 83

Link to comment
Share on other sites

Thank you a lot Mike! I've just installed the app but there isn't a featured videos bloc on the portal page. Could you tell me, how can I mark a video like featured?

Make sure you've setup your group permissions for manage, in Admin CP > Members Tab > select group > Videos System tab > Can approve/deny and manage videos?

You should be able to see a "Add Featured" option in the Videos Options dropdown then.

It doesn't work... I still can't see a features video block...

Futhermore, I have bugs...

1. When users try to use mobile skin they see a error on the white page:
Fatal error: Call to a member function portalIndex() on a non-object in/usr/www/users/tradee/admin/applications_addon/other/videos/modules_public/display/index.php on line 376

2. Moreover, users can't see the page /index.php?app=videos I, like an admin, and guests can, but users can't... Fatal error: Call to a member function menu() on a non-object in /usr/www/users/tradee/admin/applications_addon/other/videos/sources/functions.php on line 83

1 & 2: Try rebuilding your skin cache in Admin CP > Look & Feel Tab > Template Tools > Recache Skin Sets.

Mike, could you give me your skype? Also I need some changes in the app, so it will be better chatting in skype not in the topic.

Sorry I don't use Skpye but your welcome to PM or email me. I'll tell you now that any major changes will have to wait, I'm only working on smaller custom requests right now.

Link to comment
Share on other sites

Just 1 example:
As I saw, 'Error on language change' was fixed on the Jun 16 2013 07:35 PM on your site. I reported about this on the 21 June 2013 - 08:40 AM for the files which were purchased from you by my employer on the Jun 18 2003. And your files were not changed on Marketplace and it was v.3.0.0 here until yesterday.

So, you could just tell the truth that you did not added this fix to the sold on the 18th June 2003 product. At least you could focus my attention on your fix to avoid any questions. But other man did this instead of you. But you began to fight telling: "I'm not seeing any purchase data from your username, if you purchased through my site, you will have access to the support tickets."

My sites client centre and the IPS Marketplace files had exactly the same files. Yes I do provide patches for serious issues in my tracker but this is publicly available to anyone, including those who purchased through the IPS Marketplace.

I didn't start any fight, I simply said that you didn't purchase anything from me and if you purchased through my site instead, you have access to the support tickets in my site. Now you provided new information and say you got access from your employer, I assume for translation or other purposes. Which is fine, I've provided and gotten access from other developers when working on other paid mods. But you could of mentioned this from the outset and not reported my application as broken without giving me a chance to reply. ;)

You are not supporting me, since you can not support me. I believe that only God can do this. You are supporting the products sold via Marketplace since this is the policy here. Otherwise you will not be able to be the part of the comunity here and be the contributor. At least for the paid files. I did not insult you personally anywhere.

I respect your beliefs but at the end of the day, I get up in the morning and support this application. Yes if you believe, you could say through God.

Honestly I find this highly offensive. I've been doing this for years, this is something I enjoy doing. What right do you have to tell me I should not be part of this community?

Link to comment
Share on other sites

Hi, again.

I still want to purchase this addon. I have sold one of my translations recently on the Marketplace and have some funds on the balance here. When I was translating your addon, I found several bugs which are stopping me to do this right now.

I have 2 languages on my system: English and Russian.

When I was translating your addon, I found that the main title is not language abstracted. Generally this title is language abstracted in the official addons like IP.Blog, IP.Downloads, etc. and the same as the titles in the header menu tabs. Can you please, tell if this was fixed and if the files were updated here on the Marketplace?

post-383686-0-69088600-1372902051_thumb.

Also, it will be very nice, if you will comment some minor bugs listed by me previously.

I was trying to use the IP.Gallery to publish youtube videos from my youtube channel, but IP.Gallery does not have the embedding URL option. I even tried to order some fix, but still awaiting any chance to purchase your addon.

Hope, you will not be angry and will reply.

Edited by Ivan Gorshkov
Link to comment
Share on other sites

When I was translating your addon, I found that the main title is not language abstracted. Generally this title is language abstracted in the official addons like IP.Blog, IP.Downloads, etc. and the same as the titles in the header menu tabs. Can you please, tell if this was fixed and if the files were updated here on the Marketplace?

attachicon.gif1.jpg

Also, it will be very nice, if you will comment some minor bugs listed by me previously.

That one was fixed in v3.0.1, it uses the same navigation tab title. It's only in the portalIndex template at the moment, I'll be making more use in future versions. Yes IPS Marketplace was updated a few days ago, there is a post not far back that lists all the bug fixes in v3.0.1.

Regarding previous bugs, the missing langauge strings were all added with exception of the split "Add/Remove Featured", I'm aware of the problem for non English use but was unable to include a fix in v3.0.1. Some style changes were made from your list, regarding thumbnail distortion, that's unavoidable if you've got the fixed thumbnail setting enabled.

Link to comment
Share on other sites

Just to inform you. The following menu items are still not influenced by the new language strings:

Can you try rebuilding your menu cache? See ACP > System Tab > Cache Management > app_menu_cache. I had this at first but rebuilding the cache fixed this for me.

Link to comment
Share on other sites

I have tried to rebuild menu cache according to your instruction. Seams to be this is not influencing anything for me. The only method at the moment is to make hard translation in the following files and make uninstall&install of the addon in the ACP. But in this case the menu in always in Russian.

Also, I have noticed that pre-defined tags are not automatically changed for the category if the category is being changed during the upload in the upload form.

applications_addon.zip

Link to comment
Share on other sites

Just to inform you. The following menu items are still not influenced by the new language strings:

This is a confirmed bug, I've added a bug report with a manual patch here.

If I delete video inside the category, I am being redirected to the index page of this addon. It would be great to stay within the category in this case.

Good idea, will be included in v3.0.2.

can we remove the footer link " Videos System v3.0.1 © 2013 DevFuse " ? if so, how ?

Full details on copyright removal here.

Link to comment
Share on other sites

Michael, can you help me with the IP.Content block? I go to add plugin, choose Video Sidebar block, but the template looks empty. When I create and parse the block, it is not shown on homepage...

Tried with both blocks and with and without including the $content variable in the template.

Link to comment
Share on other sites

One item in the menu is still not language abstracted and is dependent from the translation in the Applications & Modules > Manage Applications & Modules menu.

Unless I'm missing something, I don't see a way to add language strings for the module name. You need to change the module name itself.

Michael, can you help me with the IP.Content block? I go to add plugin, choose Video Sidebar block, but the template looks empty. When I create and parse the block, it is not shown on homepage...

Tried with both blocks and with and without including the $content variable in the template.

The ip.content block will use the sidebar block hook, so make sure you have it enabled in the settings.

Link to comment
Share on other sites

Fatal error: Call to a member function bbCodeVideo() on a non-object in /home/soliddn/public_html/SEcommunity/admin/applications_addon/other/videos/extensions/sharedmedia/plugin_videos.php on line 139

This is the error message i get when try to acess my community using the mobile skin

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...