Jump to content

Community

Mike John

(M34) Videos System

Recommended Posts

Hello,

The video system seems to be intefearing with the latest upgrade, it stops the generation of sitemap.xml.

 
</p><div>[03-Dec-2012 17:47:10] PHP Warning:  require_once(/home/{userdir}/public_html/{admindir}/applications_addon/other/ipseo/sources/sitemapplugin.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home/{admindir}/public_html/{admindir}/applications_addon/other/videos/extensions/sitemapPlugins/videos.php on line 8</div> <div>[03-Dec-2012 17:47:10] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/home/{admindir}/public_html/{admindir}/applications_addon/other/ipseo/sources/sitemapplugin.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/{admindir}/public_html/ips_kernel/') in /home/{admindir}/public_html/{admindir}/applications_addon/other/videos/extensions/sitemapPlugins/videos.php on line 8</div> <div> </div> <div>

Here is that line, there is no php file by that name at that location anymore.

 
require_once( IPSLib::getAppDir('ipseo') . '/sources/sitemapplugin.php');

I had to uninstall the video system to be sure.


I am able to generate .xml files, but am missing out on the cool video display.

Share this post


Link to post
Share on other sites

This application will require a re-upload of the latest files to fix the following IPB 3.4.x specific bugs: Legacy IP.SEO Plugin code.

To update, re-download latest files from IPS Marketplace and then re-upload the latest files. Running of the upgrade script is not required if you already had the latest version of this application installed.

Share this post


Link to post
Share on other sites

This application will require a re-upload of the latest files to fix the following IPB 3.4.x specific bugs: Legacy IP.SEO Plugin code.

To update, re-download latest files from IPS Marketplace and then re-upload the latest files. Running of the upgrade script is not required if you already had the latest version of this application installed.

Hmm, I did this last night. No joy, have you updated these files since?

Share this post


Link to post
Share on other sites

Does anyone know of any video hosting system that will bridge to IPB ? anything at all ? even through another medium ?

I've got 200 + videos hosted on vbtube (vbulletin) but am porting to IPB and wish to find a similar system ??

TIA for any & all suggestions.

Share this post


Link to post
Share on other sites

The Videos System currently only allows embed codes to be used. If you want to upload your own videos, you might want to check out the Gallery. I believe it supports it.

Either way you'll need a converter script that can port your video database over to use in an IPB application.

Share this post


Link to post
Share on other sites

Hello Mike John :thumbsup:

This module is good if you can also upload the video and not just post or share. expand the module as a video server, which you can also upload video.
I give from me and a big thank you to like your work.

Share this post


Link to post
Share on other sites

This module is good if you can also upload the video and not just post or share. expand the module as a video server, which you can also upload video.

I can't promise it next version but I am looking at ways to achieve this.

Thanks :)

Share this post


Link to post
Share on other sites

I've read the feature list of the video system and it says it supports 'edit videos' permissions, however I don't see any such capability unless i'm going blind. The permissions I have, per group, are : 'View Category', 'View Videos', 'Add Videos', 'Add Comments', 'Auto Approve',but nothing about permissions for editing a video which currently means only the author can edit a video.

Am i missing something, else this would be a desired feature.

Share this post


Link to post
Share on other sites

You'll have both category permissions which you've already described and also member group permissions for each group. You can find these in acp > members tab > manage member groups > select group > videos system tab.

Share this post


Link to post
Share on other sites

Hello Mike,

Just installed the video system. I think I can handle all of it. Only the thumbnails of the portal block don't show.

What should I do?

I see what happened. I supplied a thumbnail. Leaving it empty does it

Thanks anyway

post-3846-0-91044800-1365016881_thumb.pn

Share this post


Link to post
Share on other sites

One more question Mike,

Can I use the video portal block in global sidebar's topic view ? And if yes, what code to use?

I also use 'Statcounter'. The portal seems not to be counted. Where do I place the stat counter script? The Portal is outside the forums as index page

Share this post


Link to post
Share on other sites

Just installed the video system. I think I can handle all of it. Only the thumbnails of the portal block don't show.

If you right click and click view image, what's the image url? This is the official portal block for portal v1.4?

Can I use the video portal block in global sidebar's topic view ? And if yes, what code to use?

I also use 'Statcounter'. The portal seems not to be counted. Where do I place the stat counter script? The Portal is outside the forums as index page

Global sidebar topic view? Do you mean the board index sidebar blocks? If so, there is already a hook for that area.

If this is for the Portal I work on, you can find the support topic for it here.

Share this post


Link to post
Share on other sites

I've come across a minor display bug below when the you have enough sub categories that it forces a multiple lines to display them in the portal layout category view on the left.

devfuse.png

i.e. it indents 'Studio Arts' and 'Dance' a little.

I don't mind the way it does the portal layout, but when you have a lot of entries it can start to look a little tardy imo, perhaps an option for the next version would be to make it behave like IP.Downloads (recent versions at least) where you can dynamically expand/hide sub category listings, it would also make it a more consistent interface.

Share this post


Link to post
Share on other sites

Hi again

I have some more suggestions.

How about feed block for IP.Content?

It make sense to adding quote и and report buttons to comment.

s_1365426347_7047663_d41d8cd98f.jpg

There name of user and under it is date of adding video. This is little confused me at first. I think you need to replace date of video with date of comment.

Or you can make it like this

s_1365426908_1587489_d41d8cd98f.png

Share this post


Link to post
Share on other sites

I've come across a minor display bug below when the you have enough sub categories that it forces a multiple lines to display them in the portal layout category view on the left.

Working on next version now, I've actually got improving the category sidebar planned. Will probably try to setup something like ip.downloads, where subs are loaded into a dropdown.

Hi again

I have some more suggestions.

How about feed block for IP.Content?

It make sense to adding quote и and report buttons to comment.

s_1365426347_7047663_d41d8cd98f.jpg

There name of user and under it is date of adding video. This is little confused me at first. I think you need to replace date of video with date of comment.

Or you can make it like this

s_1365426908_1587489_d41d8cd98f.png

I don't have access to the latest ip.content but I will be trying to include feed support for at least videos. (I can't promise anything yet.) I've just upgraded the comments to use IPB's built in comments, so it will have that functionality. That's going to be included in the next version.

Regarding the comments, I see what you mean. I'm adding profile pic support now but I will be including some more improvements to make it more intuitive.

Share this post


Link to post
Share on other sites

I upgraded to v2.3.2 and now I have thumbnails on my main video page that are grayed out. See http://forum.avsim.net/videos/. There does not seem to be any consistency from browser to browser (or account) and all browsers show the same effect, only not always the same thumbnails. Did I miss something somewhere?

Was a recent feature to grey out watched videos (item marking based). Making it optional in v3, quick simple css edit if you wanted to remove it until then, let me know.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...