Jump to content

Super News Feed


HeadStand

Recommended Posts

Changed news_feed to

 

Activity Stream

 

but not worked

http://www.ifsqn.com/forum/index.php/stream.html

Very strange. That is definitely where it's coming from. Are you sure your language pack isn't protected or something? It is definitely not hard-coded.​

 

Manage Applications and Modules  > [HSC] Super News Feed  v4.2      - GLOBAL CACHE

 

That's typically set by a developer. Leave it as is.

Link to comment
Share on other sites

  • 4 weeks later...

I am about to begin rewriting this app for version 4.0. 

Before I go any further, I would like to remind everyone (so that there are no surprises) that as I've stated multiple times in multiple threads, the v4 version will be a separate purchase. If you have purchased the current version and are upgrading to v4, you will need to purchase again. I made this decision mainly because I don't charge for renewals AND because I do intend to support the v3 version for quite some time. The cost of the new version may be slightly higher, but not much (maybe by $5). That's undecided. I can only promise that I don't intend to outrageously raise prices.

Now that that's out of the way, for those of you that don't want to murder me in my sleep, I am looking for feedback. Since this update requires a total rewrite, I have the opportunity to make major changes. At this time, I am not looking specifically for enhancement requests. What I AM looking for is:

  • What do you consider to be the major flaws of this app?
  • What do you least like about this app, or what is your biggest frustration?
  • Is there anything about this app that is preventing you from using it in the way that you would like?
  • Are there any features that you find excessive or just not particularly useful?

Please do not give me design-related comments. Design is completely subjective and completely customizable and you can always have a skinner change the templates for you. I'm looking for functional changes and improvements.

Thank you!

Edited by HeadStand
Link to comment
Share on other sites

Hi

Is there a way to embed the feed within another page on he forum board? Perhaps with parameters that can be defined to show only last 5 feed entries? Specifically I am thinking of adding it to my chat room side bar for example.

Thanks

​There is an IP.Content block that will generate a sidebar block. You can limit the sidebar block to 5 entries (it's currently a global setting) and then show the IPC block anywhere you want.

Link to comment
Share on other sites

​There is an IP.Content block that will generate a sidebar block. You can limit the sidebar block to 5 entries (it's currently a global setting) and then show the IPC block anywhere you want.

​Hi - thanks for the above - will the block auto refresh x number of seconds etc like the main page does without reloading the page and just updating the block?

Link to comment
Share on other sites

Checked my site last night before going to bed, everything working just fine (loving the stream feed).  Wake up and check it again, only to find that there's something wrong with the stream now... 

There appears to be an error with the database.

If you are seeing this page, it means there was a problem communicating with our database. Sometimes this error is temporary and will go away when you refresh the page. Sometimes the error will need to be fixed by an administrator before the site will become accessible again.

You can try to refresh the page by clicking here

As mentioned, I haven't done anything to my site to cause this.  What could have happened, and how can I fix this?  The stream has become a pretty central thing for my users. :)

If it helps, I pulled this from the SQL Error Logs:

Latest SQL Error Today (22 January 2015 - 12:27 PM)
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Date: Thu, 22 Jan 2015 20:27:49 +0000
Error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'and comment_mid=62' at line 1
IP Address:  - /stream.html
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
mySQL query error: SELECT comment_text FROM cal_event_comments WHERE comment_eid=164 and comment_date= and comment_mid=62
.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| File | Function | Line No. |
|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
| admin/applications_addon/other/supernewsfeed/sources/classes/class_feed_display.php| [feed_eventComment].getContent | 306 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/applications_addon/other/supernewsfeed/sources/classes/class_feed_display.php| [class_feed_display].getAdditionalContent | 122 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/applications_addon/other/supernewsfeed/modules_public/feed/feed.php | [class_feed_display].getFeedData | 47 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/applications_addon/other/supernewsfeed/modules_public/feed/feed.php | [public_supernewsfeed_feed_feed]._showFeed | 30 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/base/ipsController.php | [public_supernewsfeed_feed_feed].doExecute | 306 |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

 

Thank you for your time! :)

Link to comment
Share on other sites

Checked my site last night before going to bed, everything working just fine (loving the stream feed).  Wake up and check it again, only to find that there's something wrong with the stream now... 

As mentioned, I haven't done anything to my site to cause this.  What could have happened, and how can I fix this?  The stream has become a pretty central thing for my users. :)

If it helps, I pulled this from the SQL Error Logs:

 

Thank you for your time! :)

​I'm attaching a patch, please upload to admin/applications_addon/other/supernewsfeed/sources/actions.

BUT.

This shouldn't be happening, not ever. Can you please make sure you are running the latest version of the Calendar plugin? I think it should be 4.2, but perhaps just in case you should reinstall just that one hook.

eventComment.php

Link to comment
Share on other sites

Thank you for the patch!  That did the trick. :D

It looks like the gallery hook is version 4.3 while all the others are 4.2 (including calendar).  For reinstalling the calendar hook, how do I go about doing just the one?  They all got installed when the main app was installed, I thought. ^^;  Forgive me if I'm spacing out on something obvious.  ^^;

Link to comment
Share on other sites

Thank you for the patch!  That did the trick. :D

It looks like the gallery hook is version 4.3 while all the others are 4.2 (including calendar).  For reinstalling the calendar hook, how do I go about doing just the one?  They all got installed when the main app was installed, I thought. ^^;  Forgive me if I'm spacing out on something obvious.  ^^;

​Somehow I missed this post. My notifications here are all screwy. :(

All the hooks can be found in the admin/applications_addon/other/supernewsfeed/xml/hooks folder. Just download the calendar.xml and then install it like you would any other hook.

Link to comment
Share on other sites

I need a favor from anyone here.... one of my private clients is looking for an example of someone using this mod, but specifically with gallery images included and showing as thumbnails in the feed. Does anyone here have that setup and if so, would you be willing to give me a URL to share?

Thanks.

Link to comment
Share on other sites

Hi!

I was reading the complete Topic, and i`m wondering about something:

please it's possible to have a number near the tab on the board to show how many feed ? (like the chat tab)

(This one is from Nov. 2010) And it sounds like a good idea...

And your answer was:


I guess you mean to show how many NEW items are in the feed? I'll add it to my enhancement list.

Furthermore there is another one (What i need BADLY for my IP.C-Landing Page, cause it is a "News Feed" not a "Reload News" ...)

Is there an available IP.Content block (that auto-refresh of course) to show configurable number feeds?

This is from Dec. 2013 

And your answer:

Unfortunately, no, not at this time. Multiple people have requested it, and it's been on my to-do list for a while,
but unfortunately it just takes a lower priority than some of the other things I have going on. If only there were
like 100 hours in a day. :(

Well, until now, the day follow to have 24 hours, but more than one year and nothing happend???

I think, this (auto updated IP.C-Block) would be a good selling argument, or not?

@HeadStand  I have an issue as well: I have installing in my XAMPP Testground, but when i upload a File (IP.Download), there is no screenshot in the Stream.

Furthermore, it shows if there is a Gallery-comment or when a new album is created, but it DON`T show a new upload Image (No entry nor the thumbnail) Any ideas? No errors are logged.

Thank you!

BTW: Great App !!!

Link to comment
Share on other sites

Furthermore, it shows if there is a Gallery-comment or when a new album is created, but it DON`T show a new upload Image (No entry nor the thumbnail) Any ideas? No errors are logged.

Some more Informations:

The picture didn`t show, if an image is uploaded directly in the category. 

When i upload an Image in an album, it shows correctly (with thumbnail!)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...