Jump to content

Super News Feed


HeadStand

Recommended Posts

Hi,

Any ideas - just had this tech support question in
Be handy for members to choose their privacy options I guess.


"Is there a way to hide the news feed from google? If I search my username, followed by the site name, I can find my profile page. However, even though I'm logged in as non active, and the "last online" shows as private, my news feed shows all my recent activity, thus giving a good indication of when I was last online."

If you allow it (in the global settings in the ACP), members do have the ability to opt-out of the feed altogether. However, this would just stop their content from showing up ever (not just when they're logged in anonymously).

To be honest, I'm a little confused about this person's complaint. The feed should only show actual activity - if the member makes a post, if the member comments on a blog entry. So.... whether you're logged in anonymously or not, that would still tell people when they were online, wouldn't it?
Link to comment
Share on other sites

Database Comments do not show the comment in the feed ie; There is no exert like new posts/topics.

Would be great if this work like the other streams.

I know, that's been on my to-do list FOREVER. The problem is that because you can have comments in both the forums and/or the databases, the logic is complicated and takes much longer than any other component... so I just haven't gotten around to adding support for it. Wish I could tell you "it'll be there tomorrow!" :sad:
Link to comment
Share on other sites

I know, that's been on my to-do list FOREVER. The problem is that because you can have comments in both the forums and/or the databases, the logic is complicated and takes much longer than any other component... so I just haven't gotten around to adding support for it. Wish I could tell you "it'll be there tomorrow!" :sad:

That's fair enough, cant have everything ;) Thanks all the same, great product and great support as ever. Dave.

Link to comment
Share on other sites

  • 2 weeks later...

This is an extremely badass hook. Thank you!

One question - Is there a way to:

- Make the homepage land here?

- Have a field at the top that allows users to type/post youtubes similar to the way Facebook's works? That would be insane.

- In general, has anyone heard of a hook that pulls the "user feed" box from the profile tab onto the overview page and allows you to go to your profile, and make a post like a video or your thoughts and have it appear right there on your profile?

Link to comment
Share on other sites

This is an extremely badass hook. Thank you!

One question - Is there a way to:

- Make the homepage land here?
- Have a field at the top that allows users to type/post youtubes similar to the way Facebook's works? That would be insane.
- In general, has anyone heard of a hook that pulls the "user feed" box from the profile tab onto the overview page and allows you to go to your profile, and make a post like a video or your thoughts and have it appear right there on your profile?


1. Yes. You need to create a file (if it doesn't already exist) called constants.php in your forum root directory (same location as conf_global.php). At minimum, it should contain the following:
<?php
define( 'IPS_DEFAULT_PUBLIC_APP', 'supernewsfeed' );
2. Not at the moment, sorry. Perhaps in a future version.
Link to comment
Share on other sites

  • 3 weeks later...

What isn't compatible?

I'm using it, the only edit I've made thus far is to not show Profile updates in the SuperNewsFeed (which is a built in configuration option of SuperNewsFeed so no extra code was needed) because any Content Rating click/rating creates a new feed item and it just floods them with it.

Link to comment
Share on other sites

Ah so the non-compatibility part is seeing the Content Ratings IN Supers News Feed?

Not that it "breaks" Super News Feed, it just isn't detected by it?

Like I said, the update I saw for Content Ratings submitted was profile updates because the content ratings are kept there.

Other than that, I didn't see any other updates occurring in Super News Feed.

Link to comment
Share on other sites

What isn't compatible?

I'm using it, the only edit I've made thus far is to not show Profile updates in the SuperNewsFeed (which is a built in configuration option of SuperNewsFeed so no extra code was needed) because any Content Rating click/rating creates a new feed item and it just floods them with it.

Exactly! That's the problem. Instead of saying "Member John Doe received a rating" it will say "Member John Doe updated his profile". It logs reputation ratings a profile changes.

It would be desiered that ratings are shown as ratings and profile updates as profile updates

Link to comment
Share on other sites

Well, let's try again! Headstand's app extends the OFFICIAL reputation system. That other one ISN'T official. If it's appearing profile something that's due to any particularity on script (I never used it!) or a default module.

The right is NOT support Rating Content (for obvious reasons and shows nothing). Why? So if tomorrow John Doe creates another kind of rating, will this or other app/hook related to reputation needs to be compatible or works? The answer is NO! Plus: will Hesdstand have to buy Jonh Doe reputation or this Content Rating to make it compatible with her app? Again, the answer is NO.

This is something more like a custom job to any of the authors do: content rating or super news feed.

Link to comment
Share on other sites

By default does it not show Admin's gallery uploads? I just uploaded a few images to my gallery and nothing appeared on the news feed main page or block, despite Admin being checked as having access in settings, and gallery being switched on in settings. I refreshed for a while and ensured re-load time was set to 1 minute.

Link to comment
Share on other sites

By default does it not show Admin's gallery uploads? I just uploaded a few images to my gallery and nothing appeared on the news feed main page or block, despite Admin being checked as having access in settings, and gallery being switched on in settings. I refreshed for a while and ensured re-load time was set to 1 minute.


As long as the album is public, the image should show up. Is it a private (or friends only) album? Are you uploading directly to a category (instead of an album)?
Link to comment
Share on other sites

Hey,

I'm receiving this SQL error

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 Date: Fri, 28 Mar 2014 06:37:43 +0000
 Error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'and member_id=71942' at line 1
 IP Address: - /stream/blog-comment/
 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 mySQL query error: SELECT comment_text FROM blog_comments WHERE entry_id=1693 and comment_date= and member_id=71942
 .--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
 | File                                                                       | Function                                                                      | Line No.          |
 |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
 | admin/applications_addon/other/supernewsfeed/sources/classes/class_feed_display.php| [feed_blogComment].getContent                                                 | 306               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications_addon/other/supernewsfeed/sources/classes/class_feed_display.php| [class_feed_display].getAdditionalContent                                     | 122               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications_addon/other/supernewsfeed/modules_public/feed/feed.php  | [class_feed_display].getFeedData                                              | 47                |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications_addon/other/supernewsfeed/modules_public/feed/feed.php  | [public_supernewsfeed_feed_feed]._showFeed                                    | 30                |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/sources/base/ipsController.php                                       | [public_supernewsfeed_feed_feed].doExecute                                    | 306               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

Do you perhaps have a fix :)

Thanks

Link to comment
Share on other sites

Hey,

I'm receiving this SQL error

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 Date: Fri, 28 Mar 2014 06:37:43 +0000
 Error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'and member_id=71942' at line 1
 IP Address: - /stream/blog-comment/
 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 mySQL query error: SELECT comment_text FROM blog_comments WHERE entry_id=1693 and comment_date= and member_id=71942
 .--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
 | File                                                                       | Function                                                                      | Line No.          |
 |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
 | admin/applications_addon/other/supernewsfeed/sources/classes/class_feed_display.php| [feed_blogComment].getContent                                                 | 306               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications_addon/other/supernewsfeed/sources/classes/class_feed_display.php| [class_feed_display].getAdditionalContent                                     | 122               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications_addon/other/supernewsfeed/modules_public/feed/feed.php  | [class_feed_display].getFeedData                                              | 47                |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications_addon/other/supernewsfeed/modules_public/feed/feed.php  | [public_supernewsfeed_feed_feed]._showFeed                                    | 30                |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/sources/base/ipsController.php                                       | [public_supernewsfeed_feed_feed].doExecute                                    | 306               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

Do you perhaps have a fix :smile:

Thanks

I don't even understand how that's possible, honestly. But a patch is attached. Upload to admin/applications_addon/other/supernewsfeed/sources/actions.

blogComment.php

Link to comment
Share on other sites

By default does it not show Admin's gallery uploads? I just uploaded a few images to my gallery and nothing appeared on the news feed main page or block, despite Admin being checked as having access in settings, and gallery being switched on in settings. I refreshed for a while and ensured re-load time was set to 1 minute.

I am having this same problem for gallery uploads not showing, and also blog entries not showing up for admin account.

Is there a fix for this?

Link to comment
Share on other sites

A patch has been uploaded to the marketplace to fix the following issue: when a blog entry was deleted, the feed redirected to an error page.

To apply the patch, simply upload the files to the server. No actual upgrade is required.

I am having this same problem for gallery uploads not showing, and also blog entries not showing up for admin account.

Is there a fix for this?

There is nothing in the code that would stop an admin-owned item from showing up. As long as the item is public, it should appear in the feed.

Link to comment
Share on other sites

There is nothing in the code that would stop an admin-owned item from showing up. As long as the item is public, it should appear in the feed.

Well all I can say is we definately have the same issue with the admin account like that other person does.

You can see for yourself here http://www.caarer.com/stream.html

none of my husbands (admin account) album or blog entries are showing up - He is the one uploading the pics in the albums and they are public to guests but not showing in the feed - same with the blog

Link to comment
Share on other sites

  • 2 weeks later...

Well all I can say is we definately have the same issue with the admin account like that other person does.

You can see for yourself here http://www.caarer.com/stream.html

none of my husbands (admin account) album or blog entries are showing up - He is the one uploading the pics in the albums and they are public to guests but not showing in the feed - same with the blog

Hi,

Sorry for bumping but haven't heard anything for a couple of weeks and we really need this fixed before the site is launched

Thanks,

Link to comment
Share on other sites

Hi,

Sorry for bumping but haven't heard anything for a couple of weeks and we really need this fixed before the site is launched

Thanks,

I do all of my development and initial testing with an admin account, so there really is no way that it's related to an admin account - I'm pretty sure I would have noticed it. ;) It has to be something else.

That being said, I can't reproduce this and I haven't had anyone else report this problem. At this point the only way I can troubleshoot this is by getting ACP access to your site. if you're OK with that, please PM me with details and I will take a look over the weekend.

Link to comment
Share on other sites

Quick question - does the feed follow forum permissions? IE - if someone posts in a private forum for example, will it only be shown to people who have read access to that forum - or everyone?

It should follow permissions. If you're seeing something that you think shouldn't be visible, please let me know, as that would be a bug.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...