Jump to content

312_sept_patch


ifdef

Recommended Posts

The instructions in seemed a little unclear. The zip file provided contains an admin/sources/classes/bbcode/custom/defaults.php as well as an admin/sources/classes/bbcode/custom/defaults.php.zip containing a defaults.php that is identical to the former. There is also a ._defaults.php.zip.

In my installed copy of 3.1.2, there is an admin/sources/classes/bbcode directory containing a defaults.php. There is no "custom" subdirectory under it, but I assume I need to create that subdirectory and copy the new defaults.php into it.

Link to comment
Share on other sites

I just uploaded the php file and ignored the zips. I agree this is confusing. I see Matt is reading this so no doubt will get the zip file updated to just include the php file.

3DKiwi

Update: Make sure you redownload this patch and install. The original produced errors at my site. They have updated the patch.

Link to comment
Share on other sites


Sorry about that. I have fixed the zip to remove the extraneous zip file.




It appears that more than just the extraneous zip file was changed.

The php file has changed as well.

I'd suggest posting a note in the original thread so that those who downloaded before you updated the file will know that they need to update again.

Thanks.
Link to comment
Share on other sites

Thanks, I will download the patch again as one of my admins has advised me of the following error showing after I installed the original patch yesterday:

Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 15 in mysite.../admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 42 in mysite.../admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 15 in mysite... /admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 42 in mysite... /admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 15 in mysite.../admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 42 in mysite.../admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 15 in mysite.../admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: preg_match() [function.preg-match]: Compilation failed: unmatched parentheses at offset 42 in mysite... /admin/sources/classes/bbcode/cu


stom/defaults.php on line 608



Warning: Cannot modify header information - headers already sent by (output started at mysite... /admin/sources/classes/bbcode/cu


stom/defaults.php:608) in mysite.../admin/sources/classes/output/fo


rmats/html/htmlOutput.php on line 109



Warning: Cannot modify header information - headers already sent by (output started at mysite.../admin/sources/classes/bbcode/cu


stom/defaults.php:608) in mysite... /admin/sources/classes/output/fo


rmats/html/htmlOutput.php on line 120

Link to comment
Share on other sites


From the email - " If you are running IP.Board versions less than 3.1.2 [size="4"]simply[/size] upgrade your software version."



I added the large bold. :lol:



Yeah, I saw that and was disappointed that additional information wasn't provided, as I imagine many people are still running 3.0.5. I am working on upgrading my forum to 3.1.2 but I run a large forum (over 2 million posts) with various and sundry source modifications and a fairly custom skin that I'm redoing from scratch. So upgrading is a non-trivial and time consuming process to do properly.

..Al
Link to comment
Share on other sites


Yeah, I saw that and was disappointed that additional information wasn't provided, as I imagine many people are still running 3.0.5. I am working on upgrading my forum to 3.1.2 but I run a large forum (over 2 million posts) with various and sundry source modifications and a fairly custom skin that I'm redoing from scratch. So upgrading is a non-trivial and time consuming process to do properly.



..Al





According to:

http://community.invisionpower.com/topic/320847-about-security-issues/page__view__findpost__p__2016633

it doesn't impact the 3.0.x series.
Link to comment
Share on other sites

Can this patch be used on 3.1.1? My thread here seems a bit forgotten: http://community.invisionpower.com/topic/320887-ipboard-31x-security-patch-released/page__p__2016863__fromsearch__1#entry2016863

How can we go by patching 3.1.1 without updating to 3.1.2?

Would be good to get some reply from an IPS Suppport person.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...