Jump to content

xcache not caching any var

Recommended Posts

Hi, some day ago i changed caching system from apc to xcache. Looks like i have a problem caching variables.

post-119430-082192600 1283419467_thumb.p

Here is my xcache.ini settings

; configuration for php xcache module



xcache.admin.user = "ehehheh"

xcache.admin.pass = "hohohooh" 


xcache.shm_scheme = "mmap" 

xcache.size = 64M ; set to cpu count (cat /proc/cpuinfo |grep -c processor) 

xcache.count = 2 

xcache.slots = 8K ; ttl of the cache item, 0=forever 

xcache.ttl = 0 ; interval of gc scanning expired items, 0=no scan, other values is in seconds 

xcache.gc_interval = 0 ; same as aboves but for variable cache 

xcache.var_size = 2M 

xcache.var_count = 2 

xcache.var_slots = 8K 

xcache.var_ttl = 0 

xcache.var_maxttl = 0 

xcache.var_gc_interval = 300 

xcache.test = Off ; N/A for /dev/zero 

xcache.readonly_protection = Off 

xcache.mmap_path = "/tmp/xcache" 

xcache.coredump_directory = "" ; per request settings 

xcache.cacher = On 

xcache.stat = On 

xcache.optimizer = On 


xcache.coverager = Off 

xcache.coveragedump_directory = "" 

Did i missed something ?

Link to comment
Share on other sites

What does php.ini show for xcache? ;)

You mean php info i think.

additional .ini files parsed
....., /etc/php5/cgi/conf.d/xcache.ini .....

XCache section of php infos


XCache Support	enabled

Version 	1.3.0

Modules Built 	cacher

Readonly Protection 	N/A

Cache Init Time 	2010-09-01 21:22:43

Cache Instance Id 	19879

Opcode Cache 	enabled, 67,

108,864 bytes, 2 split(s), with 8192 slots each

Variable Cache 	enabled, 2,

097,152 bytes, 2 split(s), with 8192 slots each

Shared Memory Schemes 	mmap 

Directive	Local Value	Master Value

xcache.admin.enable_auth	On	On

xcache.cacher	On	On

xcache.coredump_directory	no value	no value

xcache.count	2	2

xcache.gc_interval	0	0

xcache.mmap_path	/tmp/xcache	/tmp/xcache

xcache.readonly_protection	no value	no value

xcache.shm_scheme	mmap	mmap

xcache.size	64M	64M

xcache.slots	8K	8K

xcache.stat	On	On

xcache.test	no value	no value

xcache.ttl	0	0

xcache.var_count	2	2

xcache.var_gc_interval	300	300

xcache.var_maxttl	0	0

xcache.var_size	2M	2M

xcache.var_slots	8K	8K

xcache.var_ttl	0	0

Link to comment
Share on other sites

Scrap xCache and go with eAccelerator for the best performance...

May be installed but is the /tmp/xcache writable ? If nothing is being cached then to me it either cannot write or the path given is not correct.

There not /tmp/xcache directory on my serv. Btw, should it be a directory or a file ? Which permission should i set to this directory/file if i manualy add it ?

I try to have a look at main caching system, i ll try eaccelerator once my problem with xcache will be solved. Need it to work proporly if i want to compare correctly :D.
Link to comment
Share on other sites

All depends what your settings are and where its being cached,

Have you tried doing a search ?

if you cannot find then make that directory and chmod to 777 ( chmod 777 TEMPORY TEST ) then do an apache restart and then check if anything is being loaded.

Link to comment
Share on other sites

Hi, i found some day ago my mistake.
Thanks for trying to help that unsolvable problem anyway.

Solution :
in my conf global, i was using memecache + xcache
As a result, memecache was doing the var caching, and xcache the phpcaching. I didn't realized that earlyer cuz i rarely check my memecache admin pannel.
I discovered this while i decided to clean my conf global for old parameters not needed anymore.

Use memecache = 0 Magic ! xcache now caching vars ;).

About eaccelerator, i would like to have a try at it too. But it looks like a pain to get it on debian. Would require some downgrade on my system and thing like that. As i am not a pro with my serv, i am not sure about installing it succefully without breaking many thing on the serv.

Once again, sorry for my horrible english.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...