Jump to content
Announcing Achievements! ×

Community

Advanced Tags & Prefixes


Ryan H.

Recommended Posts

  • Replies 1.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Apologies for the months of non-answers. One of the site updates must have unfollowed me; I was never notified of any posts being made here.   ​That's a limitation imposed by IP.Board, sorry. Some

View File Advanced Tags & Prefixes This plugin enhances IP.Board's built-in tag and prefix system, providing custom styling and fine-grained control over prefixes, a

Released a small compatibility update to address all issues mentioned in the past couple pages. I also added some code such that the 'public multi-mods' plugin should work with tags and prefixes--but

Posted Images

Okay, that's what I thought. I assume you're using Dawpi's Advanced Thumbnails mod here... You need to ask him how to move the thumbnails, because those are being inserted into the skin dynamically, whereas the prefixes are there by default. Even if you did change where the prefixes are at in the template, I don't know that it would help.

Link to comment
Share on other sites

Hi,

This mod seems just awesome.

I've a question about the old version Topic Prefixes 1.1.4 and the new one Advanced Tags & Prefixes.

If I create prefixes with old version (1.1.4) and I change later my IPB version for 3.2.x.

I will have to use Advanced Tags & Prefixes but every prefixes will be save on the new version ?

Thanks

Link to comment
Share on other sites


Hi, great mod. I was wondering if there was any way to move the Topic Prefix dropdown next to the Topic Title in the New Topic page? Like:


It's nothing major, just visual consistency that I'd like to achieve on my forum.



Possible, but not easy. Currently the prefix dropdown is just appended to the template bit for the tag input--a couple reasons make that the simplest and most attractive from my standpoint. Moving it would require adding another template hook and shifting some of the existing code around to account for that. It would take custom work, probably not something you'll be able to figure out on your own.


If I create prefixes with old version (1.1.4) and I change later my IPB version for 3.2.x.





Hi, Thomas. As you've noticed, there are two versions of the application. Topic Prefixes is the version compatible with IP.Board 3.1; for IP.Board 3.2, I changed the name to Advanced Tags & Prefixes to reflect some of the new features. The upgrade process between them completely converts your old topic prefixes in 3.1 into 3.2's tag and prefix system.

If you install Topic Prefixes on 3.1 and then update to 3.2 and Advanced Tags & Prefixes later, all of your data will be saved. Nothing is lost.
Link to comment
Share on other sites


Thanks, last question.



How many prefixes can I integrate into 1 sub-forum ?



Is it unlimited or a specific number is imposed ?



There is a technical limit on account of the database column it's being stored in [you can only put so much data in a single cell], but that limit should be higher than you will ever use. 64 KB, by the looks of it. If need be, increasing that is trivial.
Link to comment
Share on other sites

Hi Ryan,

I have set some pre made Prefixes in a feedback forum.

In the IPB global Tag settings, I have it closed, so only pre defined ones can be used.

In that forum section settings, I've changed the Tag mode to 'Prefixes Only'.

Having tested this, it is still adding a tag, even though when creating a post, it states the tags are disabled in this forum?

Am I missing something?

Regards

Jim

Link to comment
Share on other sites

Jim,

Prefixes are part of the tag system. Saying "prefixes only" means you can't add additional tags beyond the prefix itself. The prefix is also displayed as a tag within the topic--that was a design decision made by IPS and one I believe they're discussing changing in a future version. [There's a report on it in the bug tracker.]

If I'm misunderstanding, and people are adding tags in addition to the prefix they chose, then that's definitely a bug.

Link to comment
Share on other sites

Ryan,

Thanks for your time to reply and explain. It is all working fine, I just assumed (through lack of experience with tags) that the prefix only stopped showing the tags altogether.

From a personal view, I hope IPS do provide the option to switch it off as the way I'm using some prefixes are going to create fairly pointless tags.

I have a 'Ask the Staff' forum section, so I've created 'Answered', 'Pending' and 'Unanswered' Prefixes... the unanswered is used as default and the rest is obvious, the problem is that I'm going to have a large quantity of 'answered' tags which mean nothing... not the end of the world or anything :)

Well done for making a cracking and extremely useful addon... it should be built in :)

Regards

Jim

Link to comment
Share on other sites


I don't want display tags, I want use only prefixe. It's possible ?



Partially. You can change the settings so that only prefixes can be used--they'll get a dropdown to select a prefix, and they can't add any extra tags. At the moment, the prefix they select will still show up as a "tag" inside the topic, though.

%7Boption%7D

%7Boption%7D
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy